Just getting the basics



I had the Vs2003 NetCF extensions addin for some time and have been able to
create NetCF App's etc that run on the WinCE emulator, usually without
problems. I recently installed Microsoft eMbedded Visual C++ 4.0 with Sp2.
After the installation of the various components I started the eVcp4 and as
soon as I tried to create a project the IDE would throw an exception and
shutdown. I contacted the embedded Vcp newsgroup and it was suggested that I
install Sp4 for the eVcp4. I did this. Same behavior with the IDE. It thru an

Next another newsgroup suggested to remove the eVcp4 and re-install. Now the
eVcp4 installation contains a number of elements. I removed them in what I
believe was the order that the Cd installed them in. For example, I removed
the Sdk first.

The uninstalls went fine. I then found that I could no longer deploy from
the Vs2003 IDE. I could build but not deploy. The error was that "some of the
files for the Emulator were not present". I tried many different things such
as re-installing the initial Vs2003 IDE Addon. No good.

I then removed every component (using the Add/Remove Programs from the
Console Panel) that was connected with NetCF and WinCE. I went through it
twice to be sure that every component that involved WinCE and NetCF was

Strangely enough I found that the Compact Framework directory under the
Vs2003 directory was still present (at "E:\Program Files\Microsoft Visual
Studio .NET 2003\CompactFrameworkSDK"). Also even though I had uninstalled
the NetCF Addon the NetCF project choices were still present in the create
project selectins under the Vs2003 IDE.

I rebooted and finally got the Vs2003 IDE to build and deploy NetCF App's
using the WinCE Emulator. Note that this happened even though I had not
re-installed the Vs2003 IDE NetCF Addin.

My question is this. All we want on our development system is Vs2003 with
the NetCF extensions (we have this now) AND the eMbedded Visual C++ IDE. Is
there a way to do this? My experience to date suggests that there is an
overlap between the two and if I again install the eMbedded Visual C++ IDE
and run into the IDE exception I will be stuck as to what to remove to leave
the Vs2003 IDE still NetCF functional.

Any suggests would be appreciated.

Part of the problem may have been that I downloaded a number of WinCE
components before the installation of the eMbedded Visual C++ IDE. So could
someone indicate exactly what I need to install (given that the Vs2003 NetCF
functionality appears to be working) to get the eMbedded Visual C++ IDE it
would be very much appreciated. Just the minimum items (including Sp's).


If I need to cross post this please let me know.




This is my order, and it all works:

ActiveSync 3.6
eVC 3.0
CE 3.0 SDKs (HPC, PPC)
eVC 4.0
eVC 4.0 SP3
eVC 4.0 SDKs (I've got 3)
Studio 2003
PPC 2003 SDK
Studio Add-On Pack


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question