IIS forcing app to use .Net 2.0 when 1.1 is specified



I have a Windows Server 2003 + IIS6 with both .Net 1.1 and 2.0
installed. In the past, I've had no problems using the ASP.NET tab in
the IIS Manager to specify which framework version a given application
should use.

I created a .Net 1.1 VB.NET web service in Visual Studio.NET 2003. I
built it and then copied it to the web server described above,
specifying in IIS Manager that it should use the 1.1. framework. When
I try to run the app, however, I get the exception below. As you can
see, it is using the 2.0 framework, which makes the exception an
expected one given the changes to System.Configuration in 2.0.

The IIS Manager GUI lets me switch between 1.1 and 2.0 frameworks for
this application all day long, but the settings are not truly applied;
no matter what's specified, IIS always uses 2.0. I've tried various
IIS restart permutations with no success.

I've even gone into the application configuration settings to specify a
specific 1.1 AppPool, but this too had no effect.

I'd appreciate any insight into this.

Configuration Error
Description: An error occurred during the processing of a configuration
file required to service this request. Please review the specific error
details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.



Cowboy \(Gregory A. Beamer\)

App Pool for 1.1? Chck
Put the site in the App pool for 1.1? ??????
Run aspnet_regiss /s on the directory in question? ??????

Gregory A. Beamer

Think outside of the box!




Running aspnet_regiis /s (the 1.1 version) on the specific application
worked, and now that application runs under 1.1.

It did have some side effects: All of the 2.0 applications on that
server broke, even those that lived in different websites. The error
that I got was:

"It is not possible to run two different versions of ASP.NET in the
same IIS process. Please use the IIS Administration Tool to reconfigure
your server to run the application in a separate process."

When I checked the the ASP.NET tab on my 2.0 apps, they all still
reported that they were configured to use .Net 2.0 in the default app
pool. I modified these apps to explicitly use the 2.0 app pool, and
they came back online. So at this point, all of my 1.1 and 2.0 apps
appear to be co-existing peacefully.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question