J
Jack Addington
I am just looking for some advice on naming my methods - I am getting
confused as to what some of them mean now
I have the following scenario - A Visual Data Object and a Logical Data
Object.
I wanted to make sure that there were calls that could be made to either for
things like Validate or InsertRow and that I could easily override and
inherit both objects.
The most cumbersome example is with Validation. I have a Validate data to
do the whole dataset as well as ValidateRow to do a specific row. I wanted
to be able to call the logic method which in turn fired the visual objects
event which in turn called a processing method on the logic.
So:
Logic.DataValidate -> Visual.OnDataValidate( )
Visual.OnDataValidate -> trigger Visual.DataValidate( )
Visual.DataValidate( ValidateEventArg )
{
try{
Logic.ValidateData(ValidateEventArg)
catch ...
}
Thus I seem to have three methods/events for each action I want to capture.
Plus I've got menu actions I'm trying to capture and its confusing it even
more. I've been flipping the names around using the verb/noun or noun/verb
to name the methods and I'm getting annoyed with it. Any suggestions would
be greatly appreciated!
thx
jack
confused as to what some of them mean now
I have the following scenario - A Visual Data Object and a Logical Data
Object.
I wanted to make sure that there were calls that could be made to either for
things like Validate or InsertRow and that I could easily override and
inherit both objects.
The most cumbersome example is with Validation. I have a Validate data to
do the whole dataset as well as ValidateRow to do a specific row. I wanted
to be able to call the logic method which in turn fired the visual objects
event which in turn called a processing method on the logic.
So:
Logic.DataValidate -> Visual.OnDataValidate( )
Visual.OnDataValidate -> trigger Visual.DataValidate( )
Visual.DataValidate( ValidateEventArg )
{
try{
Logic.ValidateData(ValidateEventArg)
catch ...
}
Thus I seem to have three methods/events for each action I want to capture.
Plus I've got menu actions I'm trying to capture and its confusing it even
more. I've been flipping the names around using the verb/noun or noun/verb
to name the methods and I'm getting annoyed with it. Any suggestions would
be greatly appreciated!
thx
jack