VS 2005, WinCE 5.0, debug ethernet, activesync - explosion mix!



Hello to all NG,
i've this problem. I'm developing a .NET CF 2.0 application running on
x86 WinCE 5.0 CEPC device (I builded the CEPC image myself). X86 hasn't
USB client, so I can't attach x86 board to development workstation
using USB cable/Activesync. The only way is to use a serial cable over
Activesync (very low speed connection) or use ethernet lan card. On
WinCE lan card is working propelly, I can ping, copy data over network,
web surfing etc, the only problem I have is with VS2005.

Under menù Tools/Options/Device tools/Devices I've cloned a standard
"Windows CE 5.0 Device" profile to a new "Windows CE 5.0 Device via
TCP/IP" profile, changed the Transport to "TCP Connect Transport"
(without check Use fixed port number, and using specific IP address - -> the WinCE lan card IP address), and as Bootstrapper
"Activesync Startup Provider" (the only choose I've in the combo). When
I run application I can see that .exe file and dipendences are quickly
downloaded to WinCE PC (I can see under \Program Files the new created
folder) but the VS IDE hangs for about 15 seconds (any button or menu
responds to mouse click..), then all restart working and on WinCE
device application is displayed.

Using SysInternals TCPView (freeware, thanks to the author!!) I can see
that there are always (also during design-time) 4 processes devenv.exe
connected to ports 5655 (2), 6510 (2) cepc device (cepc seems to be the
DNS name of WinCE Device); connection state is always ESTABLISHED. When
I run application and deploy starts I can see that a new connection is
created between development PC and a "new" endpoint, wich has IP
address, using destination port 6511. is
the IP address that VMINI1 virtual ethernet adapter card takes when
WinCE starts on x86 device. In fact running "ipconfig /all" on WiCE
device I get that IP associated to "VMINI1" adapter. TCPView shows that
connection in SYN_SENT state for 15 seconds, then that connection hides
and 2 new connections, always from devenv.exe, to cepc:6511 are created
and in less than 1 ms the application become visibile on WinCE.

So, VS2005 seems to wait for a response from VMINI1 adapter (that I
think it will be used when connecting a CE 5.0 device via USB
Activesync), waiting for some packets from device.
However, network isn't reachable from development PC and
after a timeout of 15 seconds devenv.exe bypass and starts a new
connection via ethernet using original cepc IP address ( using
destination port 6511.

What do you think about? This is the configuration:

Development PC:
VS 2005
2 ethernet cards:
- connected to the company network
- connected via cross cable to WinCE device

x86 with rtl8139 ethernet adapter IP address on PCI\RTL81391 adapter IP address on VMINI1 virtual adapter
conmanclient2.exe / CMAccept.exe are running.

Thanks to all for the help, and sorry for my poor english!




OK, problem solved!

The answer is: DISABLE KITL support when building release image in
Platform Builded 5.0. this will not create VMINI1 device and all works
fine! I get application running on WinCE in less than 3 seconds!!!!


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question