TableAdapter - Refresh the data table option


C

cwineman

I'm having some trouble receiving the identity value after an insert. I've
seen several posts about this, and the solution that seemed the most obvious
was to enable the advanced TableAdapter option - "Refresh the data table".

Well, I tried that After I insert a row and call update, the table still
doesn't have the new identity value. Isn't that how it's supposed to work?
However, if I do my own Fill(), I get back a table that does indeed have the
rows with the new identity. I'm not sure if I'm doing it wrong or the
refresh isn't actually happening.

I went back into the wizard and tried to configure the Tableadapter and I
noticed that the "Refresh the data table" option was no longer checked, even
though it had been checked before. Is that expected behaviour? If not, what
do I need to do to make the refresh option stick.

-cwineman
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top