L2TP connectivity problem.


R

Raghavan

Hi,
As part of my academic project, I am developing my own
Windows based L2TP server.
I am currently into testing my application for interop
with WindowsXP/2000 LAC.
My tests pass when I run the Windows LAC and my LNS on
different machines.
However, when I run my LNS on the same Windows machine
that has the LAC, the connection fails just before
starting the PPP negotiations.
Windows LAC uses port 1701 and sends pkts on loopback IP.
My application listens for the first packet on 1701,
(SCCRQ) and then changes to a different port when sending
the SCCRP(L2TP port change feature). I am not using the
1701 port anymore. After this, the tunnel establishment
and session establishment are successful. But immediately
after the ICCN message is sent by the LAC, StopCCN is
also being sent by the LAC. I did not understand why this
is happening. The Result Error Code and Error Code in the
L2TP AVP indicates value of 2 and 4 respectively.
The same test is successful if I run my LNS of different
Windows machine... The error shown on the connection
progress window is 651: Modem has reported a error. On a
few occasion I saw error 678.
Kindly help.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top