Connecting Mobile Phone via Infrared Port


P

phuile

I need to connect my mobile phone to an infrared port on my laptop for
modem access to the Internet. When I follow the manufacturer's
instructions to install a standard 33600bps modem the only port
available is Com1. My infrared is Com2, using IRQ3, DMA3, and IO
02F8-02FF and 0280-0287. But it's not listed.

I know the infrared port is working properly because I use it for other
types of connections. For instance, I use it to transfer data between
my phone device and ActiveSync and it works fine. Device Manager
indicates the infrared device is installed and working properly (no
exclamation marks or anything), but only shows Com1 and LPT1 in the
Ports section. There are no conflicts indicated for the Infrared port
in any of the Device Manager views. I've checked system services and I
have the Infrared Monitor service running. Wireless Link detects the
presence of my phone device for ordinary IR data transfers when I
activate that feature.

Knowledge Base suggests the port may not appear because another process
is holding the COM port open. However, I can't see anything that might
be doing this. I've disabled ActiveSync by removing the checkmarks from
both USB and COM ports in ActiveSync Connections. I've even manually
shut down the RAPI service. I can't see anything else that might be
holding the port. Perhaps I'm missing something.

Why then isn't an infrared port showing up for selection in the modem
installation dialog?

I'm using XP with SP2 and all the latest updates.

Thanks for any suggestions.

Petre.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

infrared transceivers 1
CONNECT 2 PC'S FOR WINDOWS MOBILE NET SHARING 1
Mobile contacts 2
Phone Dialer 4
Mobile Active Sync 0
Mobile Laptop Users 0
COM Ports 0
Com Port 2

Top