XpE mounts USB Keys as Fixed volume

Discussion in 'Windows XP Embedded' started by DD85, May 17, 2011.

  1. DD85

    DD85 Guest

    Good evening all , (Forgive me and my english if something is not
    clear)
    I'm working on creating an XpE image for a gaming application that
    will be installed into a playroom.
    The application in question starts as main shell and everything
    works fine except the following problem:

    The application is able to detect the presence of USB keys.
    If the key is inserted the application automatically saves game data
    on it , and this works only if the device is a removable device.
    What i found is that when i insert a usb key into my system , the
    volume is mounted as fixed (and displayed as a local disk ) and not as
    removable device.

    I wanted to ask you for advice on how to solve this problem because i
    really don't know where to start from .

    Thank you to all.
    Ivan
     
    DD85, May 17, 2011
    #1
    1. Advertisements

  2. DD85

    Roland

    Joined:
    Oct 20, 2009
    Likes Received:
    0
    Roland, Jun 7, 2011
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark K Vallevand

    Will XPe ever support non-fixed CF boot devices?

    Mark K Vallevand, Mar 18, 2005, in forum: Windows XP Embedded
    Replies:
    12
    Views:
    815
    Slobodan Brcin \(eMVP\)
    Mar 21, 2005
  2. Guest
    Replies:
    5
    Views:
    525
    Slobodan Brcin \(eMVP\)
    Jul 17, 2005
  3. Guest

    Do I need to upgrade XPe to XPe SP2 ?

    Guest, Sep 21, 2005, in forum: Windows XP Embedded
    Replies:
    0
    Views:
    539
    Guest
    Sep 21, 2005
  4. Dietmar

    Break through in XPE USB INSTALL on any USB device

    Dietmar, Dec 19, 2005, in forum: Windows XP Embedded
    Replies:
    5
    Views:
    1,327
    Dietmar
    Dec 21, 2005
  5. Guest

    .net performance not fixed xpe sp2

    Guest, Jan 6, 2006, in forum: Windows XP Embedded
    Replies:
    3
    Views:
    362
  6. Tony Y
    Replies:
    2
    Views:
    227
    Tony Y
    Mar 15, 2006
  7. Dan H.

    Upgrade a deployed XPe SP2 to XPe SP3

    Dan H., Sep 16, 2009, in forum: Windows XP Embedded
    Replies:
    1
    Views:
    2,449
    Sean Liming - MVP
    Sep 16, 2009
  8. Ralph A. Schmid, dk5ras

    Fixed or not fixed, this is the question :-)

    Ralph A. Schmid, dk5ras, Jan 20, 2010, in forum: Windows XP Embedded
    Replies:
    7
    Views:
    1,111
    Sean Liming \(MVP\)
    Jan 21, 2010
Loading...