XP and Vista Computers don't see each other

Discussion in 'Windows XP Networking' started by SilviaLaura, Aug 12, 2009.

  1. SilviaLaura

    SilviaLaura Guest

    How do I start troubleshooting this problem? I am using a wireless router
    for the network, both computers are set up using the same workgroup name.
    Both are configured to share printers and files. Network discovery is turned
    on in Vista (don't know the equivalent in XP). Password-protected sharing is
    turned off. Where do I start?
    Silvia
     
    SilviaLaura, Aug 12, 2009
    #1
    1. Advertisements

  2. SilviaLaura

    Malke Guest

    SilviaLaura wrote:

    > How do I start troubleshooting this problem? I am using a wireless router
    > for the network, both computers are set up using the same workgroup name.
    > Both are configured to share printers and files. Network discovery is
    > turned
    > on in Vista (don't know the equivalent in XP). Password-protected sharing
    > is
    > turned off. Where do I start?


    Turn Password Protected Sharing ON.

    Here are general network troubleshooting steps. Not everything may be
    applicable to your situation, so just take the bits that are. It may look
    daunting, but if you follow the steps at the links and suggestions below
    systematically and calmly, you will have no difficulty in setting up your
    sharing.

    Excellent, thorough, yet easy to understand article about File/Printer
    Sharing in Vista. Includes details about sharing printers as well as files
    and folders:

    http://technet.microsoft.com/en-us/library/bb727037.aspx

    For XP, start by running the Network Setup Wizard on all machines (see
    caveat in Item A below).

    Problems sharing files between computers on a network are generally caused by
    1) a misconfigured firewall or overlooked firewall (including a stateful
    firewall in a VPN); or 2) inadvertently running two firewalls such as the
    built-in Windows Firewall and a third-party firewall; and/or 3) not having
    identical user accounts and passwords on all Workgroup machines; 4) trying
    to create shares where the operating system does not permit it.

    A. Configure firewalls on all machines to allow the Local Area Network (LAN)
    traffic as trusted. With Windows Firewall, this means allowing File/Printer
    Sharing on the Exceptions tab. Normally running the Network Setup Wizard on
    XP will take care of this for those machines.The only "gotcha" is that this
    will turn on the XPSP2 Windows Firewall. If you aren't running a third-party
    firewall or have an antivirus/security program with its own firewall
    component, then you're fine. With third-party firewalls, I usually configure
    the LAN allowance with an IP range. Ex. would be 192.168.1.0-192.168.1.254.
    Obviously you would substitute your correct subnet. Refer to any third party
    security program's Help or user forums for how to properly configure its
    firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS;
    CONFIGURE THEM CORRECTLY.

    B. For ease of organization, put all computers in the same Workgroup. This
    is done from the System applet in Control Panel, Computer Name tab.

    C. Create matching user accounts and passwords on all machines. You do not
    need to be logged into the same account on all machines and the passwords
    assigned to each user account can be different; the accounts/passwords just
    need to exist and match on all machines. DO NOT NEGLECT TO CREATE PASSWORDS,
    EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly to the
    Desktop (into one particular user's account) for convenience, you can do
    this:

    XP - Configure Windows to Automatically Login (MVP Ramesh) -
    http://windowsxp.mvps.org/Autologon.htm

    Vista - Start Orb>Search box>type: netplwiz [enter]
    Click on Continue (or supply an administrator's password) when prompted by
    UAC

    Uncheck the option "Users must enter a user name and password to use this
    computer". Select a user account to automatically log on by clicking on the
    desired account to highlight it and then hit OK. Enter the correct password
    for that user account (if there is one) when prompted. Leave it blank if
    there is no password (null).

    D. If one or more of the computers is XP Pro or Media Center, turn off Simple
    File Sharing (Folder Options>View tab).

    E. Create shares as desired. XP Home does not permit sharing of users' home
    directories or Program Files, but you can share folders inside those
    directories. A better choice is to simply use the Shared Documents folder.
    See the first link above for details about Vista sharing.

    Malke
    --
    MS-MVP
    Elephant Boy Computers - Don't Panic!
    http://www.elephantboycomputers.com/#FAQ
     
    Malke, Aug 12, 2009
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Philip Schoen

    Networked computers don't see each other

    Philip Schoen, Jul 11, 2003, in forum: Windows XP Networking
    Replies:
    0
    Views:
    224
    Philip Schoen
    Jul 11, 2003
  2. Oscar

    My two computers can't see each other.

    Oscar, Aug 1, 2003, in forum: Windows XP Networking
    Replies:
    0
    Views:
    171
    Oscar
    Aug 1, 2003
  3. Michael R. Grabois ... change $ to \s\

    Network: computers see router, but can't see each other

    Michael R. Grabois ... change $ to \s\, Sep 7, 2003, in forum: Windows XP Networking
    Replies:
    2
    Views:
    466
    Michael R. Grabois ... change $ to \s\
    Sep 7, 2003
  4. Erma
    Replies:
    1
    Views:
    440
    Steve Winograd [MVP]
    Oct 12, 2003
  5. Guest
    Replies:
    5
    Views:
    318
    Chuck
    May 7, 2006
Loading...

Share This Page