Wrong drive letters...

Discussion in 'Microsoft Windows 2000 Hardware' started by Rayb, Aug 3, 2003.

  1. Rayb

    Rayb Guest

    I recently installed a new 80gb WD hd in addition to an
    existing 40gb hd on a Win2000Pro machine (stand alone).
    The new (80) drive was assigned the next available letter
    which was "G". I read in the MSFT Knowledgebase article
    223188 that editing the registry under mounted devices
    that I could rename the drives to the proper sequence. I
    wanted 80gb=drive c, 40gb-drive d, cdrw=drive e, and cdr-
    drive f. After editing, I get duplicates of the 80gb and
    each of the cdroms in this registry key. My computer and
    device manager only show the correct drives in the proper
    position. What can I do? Please help....Ray
     
    Rayb, Aug 3, 2003
    #1
    1. Advertisements

  2. Rayb

    rayb Guest

    correction

    My computer shows the duplicates also. Device manager
    shows only the single drives.
     
    rayb, Aug 3, 2003
    #2
    1. Advertisements

  3. Rayb

    Overlord Guest

    Uh..... if you want the 80gig to be the C drive put your Win2k on it
    and boot from it. For it is said, "Thou shalt boot from C and the
    drive thou bootest from shall BE C {unless you have the ram to run
    Knoppix OS from CD in which case you're surfing the net off A:} else
    thou pissest off Winders".

    The rest of it you're making needlessly complex.
    Open Admin tools/Computer management/Disk management.
    Right click the drive you want to change and select "Change drive
    letter and path". Then change it. The drive letters in use are
    already greyed out or not listed. Start with your D drive and change
    it to Z {temporarily} then you have the D drive letter option
    available to change the drive you actually want to become D.
    In this way you can change all your drive letters to what you want
    them to be except for the silly notion of your 40gig C drive coming up
    as D drive.

    On Sun, 3 Aug 2003 05:25:11 -0700, "Rayb" <> wrote:

    >I recently installed a new 80gb WD hd in addition to an
    >existing 40gb hd on a Win2000Pro machine (stand alone).
    >The new (80) drive was assigned the next available letter
    >which was "G". I read in the MSFT Knowledgebase article
    >223188 that editing the registry under mounted devices
    >that I could rename the drives to the proper sequence. I
    >wanted 80gb=drive c, 40gb-drive d, cdrw=drive e, and cdr-
    >drive f. After editing, I get duplicates of the 80gb and
    >each of the cdroms in this registry key. My computer and
    >device manager only show the correct drives in the proper
    >position. What can I do? Please help....Ray


    ~~~~~~
    Bait for spammers:
    root@localhost
    postmaster@localhost
    admin@localhost
    abuse@localhost
    postmaster@[127.0.0.1]
    ~~~~~~
    Remove "spamless" to email me.
    The spam was just getting overwhelming.
    I had to...
     
    Overlord, Aug 3, 2003
    #3
  4. Rayb

    rayb Guest

    Kurt, thanks for replying. My new 80gb is now the c: drive
    and the 40gb is now the d: drive. However, the 80gb also
    shows up as g: drive. I have done what you requested,
    except through the registry (renaming drives) but the 80
    still shows up at the end of the list also.

    Ray




    >-----Original Message-----
    >Uh..... if you want the 80gig to be the C drive put your

    Win2k on it
    >and boot from it. For it is said, "Thou shalt boot from

    C and the
    >drive thou bootest from shall BE C {unless you have the

    ram to run
    >Knoppix OS from CD in which case you're surfing the net

    off A:} else
    >thou pissest off Winders".
    >
    >The rest of it you're making needlessly complex.
    >Open Admin tools/Computer management/Disk management.
    >Right click the drive you want to change and

    select "Change drive
    >letter and path". Then change it. The drive letters in

    use are
    >already greyed out or not listed. Start with your D

    drive and change
    >it to Z {temporarily} then you have the D drive letter

    option
    >available to change the drive you actually want to become

    D.
    >In this way you can change all your drive letters to what

    you want
    >them to be except for the silly notion of your 40gig C

    drive coming up
    >as D drive.
    >
    >On Sun, 3 Aug 2003 05:25:11 -0700, "Rayb"

    <> wrote:
    >
    >>I recently installed a new 80gb WD hd in addition to an
    >>existing 40gb hd on a Win2000Pro machine (stand alone).
    >>The new (80) drive was assigned the next available

    letter
    >>which was "G". I read in the MSFT Knowledgebase article
    >>223188 that editing the registry under mounted devices
    >>that I could rename the drives to the proper sequence. I
    >>wanted 80gb=drive c, 40gb-drive d, cdrw=drive e, and cdr-
    >>drive f. After editing, I get duplicates of the 80gb and
    >>each of the cdroms in this registry key. My computer and
    >>device manager only show the correct drives in the

    proper
    >>position. What can I do? Please help....Ray

    >
    >~~~~~~
    >Bait for spammers:
    >root@localhost
    >postmaster@localhost
    >admin@localhost
    >abuse@localhost
    >postmaster@[127.0.0.1]
    >~~~~~~
    >Remove "spamless" to email me.
    >The spam was just getting overwhelming.
    >I had to...
    >.
    >
     
    rayb, Aug 3, 2003
    #4
  5. On Sun, 3 Aug 2003 09:03:04 -0700, rayb wrote:

    >Kurt, thanks for replying. My new 80gb is now the c: drive
    >and the 40gb is now the d: drive. However, the 80gb also
    >shows up as g: drive. I have done what you requested,
    >except through the registry (renaming drives) but the 80
    >still shows up at the end of the list also.
    >
    >Ray


    If the 40GB drive is the system drive (with Windows on it) change it back to
    C:, and make the 80GB drive the D: drive. Delete the 80GB drive at the end of
    the list. Reboot. You should see the drives in "normal order" -- with the
    CD-drives after the D: drive.

    I advise against using the Registry Editor to change drive names. Use Disk
    Management instead (Start Up --> Settings --> Control Panel -->
    Administrative Tools --> Computer Management --> Disk Management)

    As Kurt said, do NOT make the W2K drive anything other than C:. It's not a
    fatal problem if you do so, but there are a variety of consequences that are
    too much hassle, for my taste anyway

    Now, if you decide to partition the 80GB drive (something that I recommend -
    the MS obsession with One Humungous Partition is a bad idea, for a variety of
    reasons), W2K will assign "drive letters" as it usually does. Use Disk
    Management to change the drive letters into whatever order you want.

    Personally, I just leave the drive letters alone. I give each "drive" a
    volume label, and that's enough to remind me what's on each drive.

    Footnote: Strictly speaking, the "drive letters" are "volume letters" or
    "partition letters." The drives are HD0, HD1, etc, depending on where they
    are on the controller cables. BIOS queries each drive for type and partition
    information (if applicable), and passes this information on to Windows, which
    the assigns "drive letters" according to a standard scheme (one also used by
    other OSs.) Just thought you might like to know. :)

    HTH&GL


    --
    Best Wishes,
    Wolf Kirchmeir, Blind River ON
    "Not that brains are everything --
    you'll also need a skull to put them in." (Nancy Franklin, 1997)
     
    Wolf Kirchmeir, Aug 3, 2003
    #5
  6. Rayb

    rayb Guest

    Wolf, thanks for replyng. I got totally frustrated and
    reverted everything back to its original place using
    GoBack. Now, my 40gb is drive c: (disk 1) and my 80gb is
    drive g: (disk 0). Drive g: is my system (boot)drive and
    drive c: is a (pagefile). Both are NTFS. I tried to change
    the c: drive designation in the administrator folder but
    it won't let me because it's the system drive. Now what?

    >-----Original Message-----
    >On Sun, 3 Aug 2003 09:03:04 -0700, rayb wrote:
    >
    >>Kurt, thanks for replying. My new 80gb is now the c:

    drive
    >>and the 40gb is now the d: drive. However, the 80gb also
    >>shows up as g: drive. I have done what you requested,
    >>except through the registry (renaming drives) but the 80
    >>still shows up at the end of the list also.
    >>
    >>Ray

    >
    >If the 40GB drive is the system drive (with Windows on

    it) change it back to
    >C:, and make the 80GB drive the D: drive. Delete the 80GB

    drive at the end of
    >the list. Reboot. You should see the drives in "normal

    order" -- with the
    >CD-drives after the D: drive.
    >
    >I advise against using the Registry Editor to change

    drive names. Use Disk
    >Management instead (Start Up --> Settings --> Control

    Panel -->
    >Administrative Tools --> Computer Management --> Disk

    Management)
    >
    >As Kurt said, do NOT make the W2K drive anything other

    than C:. It's not a
    >fatal problem if you do so, but there are a variety of

    consequences that are
    >too much hassle, for my taste anyway
    >
    >Now, if you decide to partition the 80GB drive (something

    that I recommend -
    >the MS obsession with One Humungous Partition is a bad

    idea, for a variety of
    >reasons), W2K will assign "drive letters" as it usually

    does. Use Disk
    >Management to change the drive letters into whatever

    order you want.
    >
    >Personally, I just leave the drive letters alone. I give

    each "drive" a
    >volume label, and that's enough to remind me what's on

    each drive.
    >
    >Footnote: Strictly speaking, the "drive letters"

    are "volume letters" or
    >"partition letters." The drives are HD0, HD1, etc,

    depending on where they
    >are on the controller cables. BIOS queries each drive for

    type and partition
    >information (if applicable), and passes this information

    on to Windows, which
    >the assigns "drive letters" according to a standard

    scheme (one also used by
    >other OSs.) Just thought you might like to know. :)
    >
    >HTH&GL
    >
    >
    >--
    >Best Wishes,
    >Wolf Kirchmeir, Blind River ON
    >"Not that brains are everything --
    >you'll also need a skull to put them in." (Nancy

    Franklin, 1997)
    >
    >
    >.
    >
     
    rayb, Aug 3, 2003
    #6
  7. Rayb

    rayb. Guest

    Found the problem

    The problem was - "me". When I assigned new letters I was
    using lower case. When I did that, the drive would be
    duplicated with the uppercase letter as well as the
    lowercase letter! I renamed them with uppercase and
    deleted the extra drives and all is fine now. Thanks
    everyone.

    >-----Original Message-----
    >I recently installed a new 80gb WD hd in addition to an
    >existing 40gb hd on a Win2000Pro machine (stand alone).
    >The new (80) drive was assigned the next available letter
    >which was "G". I read in the MSFT Knowledgebase article
    >223188 that editing the registry under mounted devices
    >that I could rename the drives to the proper sequence. I
    >wanted 80gb=drive c, 40gb-drive d, cdrw=drive e, and cdr-
    >drive f. After editing, I get duplicates of the 80gb and
    >each of the cdroms in this registry key. My computer and
    >device manager only show the correct drives in the proper
    >position. What can I do? Please help....Ray
    >.
    >
     
    rayb., Aug 4, 2003
    #7
  8. On Sun, 3 Aug 2003 15:33:16 -0700, rayb wrote:

    >Wolf, thanks for replyng. I got totally frustrated and
    >reverted everything back to its original place using
    >GoBack. Now, my 40gb is drive c: (disk 1) and my 80gb is
    >drive g: (disk 0). Drive g: is my system (boot)drive and
    >drive c: is a (pagefile). Both are NTFS. I tried to change
    >the c: drive designation in the administrator folder but
    >it won't let me because it's the system drive. Now what?


    I thunk you said that G: is the boot drive???? There's something wierd here.
    It looks like one of two things: a boot problem - you have the bootloader on
    one drive, and the system itself on another. That would IMO require a
    complete reinstall, but I would hope someone else can provide better advice.

    Or you have a cabling problem, since C; should be on HD0

    Note that BIOS looks for boot information on HD0 -- but it will boot from
    whatever partition (drive) it's directed to boot from. The Master Boot Record
    resides on HD0, and it directs BIOS to a boot partition, or a boot manager.

    Here's the pattern that should work and give you the correct drive letter
    designations, assuming the boot information and the system are on the same
    drive.

    --> 80GB drive: master on primary controller --> HD0 --> C:

    --> 40GB drive: slave on primary controller --> HD1 --> D:

    --> CD drives: master and slave on secondary controller --> E: and F: (These
    will also be HD0 and HD1, but on the 2ndy controller, which is OK, since BIOS
    keeps that straight.)

    To achieve this, I would disconnect the 40GB and CD drives completely and
    connect the 80GB as listed above. Make sure it is at the end of the cable,
    and that its jumper is set to Master or Single Drive, as directed by the mfr.
    Reboot. The drive should now show as C:. (Footnote) If it doesn't boot, then
    you know that the requisite boot info is on the missing 40GB drive. In that
    case, there will be an error message about a missing file, or the BSOD. In
    that case, boot from the install CD, and repair the installation.

    If the machine boots, power down and connect the 40GB drive, first setting
    the 80GB drive to Master. It should be between the 80GB drive and the
    controller, and its jumper should be set to Slave. Reboot. You should now see
    the drives as C: and D: in proper order.

    Power down and connect the CD drives, one at a time, reinstalling drivers if
    necessary. You should now see the drives properly designated and in proper
    order.

    Footnote: If the drive still doesn't show as C:. try using DM to set it as
    C:, and while you're at it, delete any other drives still showing. You want
    W2K to detect and install the missing drives when you add them. If this
    doesn't work, and the drive is still not C: on the next reboot, you've got
    problems I can't diagnose, let alone help you with.

    HTH&GL


    --
    Best Wishes,
    Wolf Kirchmeir, Blind River ON
    "Not that brains are everything --
    you'll also need a skull to put them in." (Nancy Franklin, 1997)
    <just one w and plain ca for correct address>
     
    Wolf Kirchmeir, Aug 4, 2003
    #8
  9. Re: Found the problem

    On Sun, 3 Aug 2003 17:07:54 -0700, rayb. wrote:

    >The problem was - "me". When I assigned new letters I was
    >using lower case. When I did that, the drive would be
    >duplicated with the uppercase letter as well as the
    >lowercase letter! I renamed them with uppercase and
    >deleted the extra drives and all is fine now. Thanks
    >everyone.


    Now that's good news - and a new one on me. I thought the lower case letters
    were just your typos.

    :)



    --
    Best Wishes,
    Wolf Kirchmeir, Blind River ON
    "Not that brains are everything --
    you'll also need a skull to put them in." (Nancy Franklin, 1997)
    <just one w and plain ca for correct address>
     
    Wolf Kirchmeir, Aug 4, 2003
    #9
  10. Rayb

    Overlord Guest

    Re: Found the problem

    How odd.....
    I've never typed in a drive letter. Always used the drop down list of
    available drive letters and never had a problem. I had no idea that
    upper and lower case would matter typing the drive letter in as I've
    never done it that way. Glad you got it nailed down!


    On Sun, 3 Aug 2003 17:07:54 -0700, "rayb." <> wrote:

    >The problem was - "me". When I assigned new letters I was
    >using lower case. When I did that, the drive would be
    >duplicated with the uppercase letter as well as the
    >lowercase letter! I renamed them with uppercase and
    >deleted the extra drives and all is fine now. Thanks
    >everyone.
    >
    >>-----Original Message-----
    >>I recently installed a new 80gb WD hd in addition to an
    >>existing 40gb hd on a Win2000Pro machine (stand alone).
    >>The new (80) drive was assigned the next available letter
    >>which was "G". I read in the MSFT Knowledgebase article
    >>223188 that editing the registry under mounted devices
    >>that I could rename the drives to the proper sequence. I
    >>wanted 80gb=drive c, 40gb-drive d, cdrw=drive e, and cdr-
    >>drive f. After editing, I get duplicates of the 80gb and
    >>each of the cdroms in this registry key. My computer and
    >>device manager only show the correct drives in the proper
    >>position. What can I do? Please help....Ray
    >>.
    >>


    ~~~~~~
    Bait for spammers:
    root@localhost
    postmaster@localhost
    admin@localhost
    abuse@localhost
    postmaster@[127.0.0.1]
    ~~~~~~
    Remove "spamless" to email me.
    The spam was just getting overwhelming.
    I had to...
     
    Overlord, Aug 6, 2003
    #10
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. GWHSU

    Order in Which MS-DOS and Windows Assign Drive Letters

    GWHSU, Oct 24, 2003, in forum: Microsoft Windows 2000 Hardware
    Replies:
    4
    Views:
    242
    GWHSU
    Oct 24, 2003
  2. Timothy

    Installing Windows 2000 Drive Letters

    Timothy, Jul 21, 2004, in forum: Microsoft Windows 2000 Hardware
    Replies:
    13
    Views:
    326
    Mike Brown
    Jul 23, 2004
  3. teejg

    Lost my CD drive letters in My Computer Win 2000

    teejg, Jul 24, 2004, in forum: Microsoft Windows 2000 Hardware
    Replies:
    1
    Views:
    162
    Dave Patrick
    Jul 24, 2004
  4. teejg

    Lost DVD/CD-ROM drive letters in "My Computer"

    teejg, Jul 26, 2004, in forum: Microsoft Windows 2000 Hardware
    Replies:
    2
    Views:
    380
    Guest
    Jul 27, 2004
  5. Bob

    Help; drive letters have changed

    Bob, Oct 31, 2004, in forum: Microsoft Windows 2000 Hardware
    Replies:
    10
    Views:
    341
    Bob H
    Nov 1, 2004
Loading...

Share This Page