Windows Embedded Standard (WES) - ACPI - USB Boot - Power Off Fails

Discussion in 'Windows XP Embedded' started by Nothing Special, Oct 9, 2009.

  1. Hi.

    In short i have a problem with USB Boot and ACPI Computer Hardware. I made an pmq file out of this an image for a notebook, added usb boot, ntldr loader, winlogon (standard) and so on. really basic stuff.

    In the end of FBA the system won't restart. It shutdowns, windows quits all processes fine but it won't power off. for a restart you have to power off the notebook by hand (4sec. power button).

    this problems happens since WES / sp3. i have an image which is build in sp2 / fp2 and acpi works fine. after upgradre the image got the same error.

    any ideas what this could be?
    i think all acpi components are in (power, sleep, fan, fix, lid and so on.), including the "microsoft acpi ..." components.

    someone has an idea? / sean, any idea? ;)

    i already read somthing about this problem, but i didn't find the thread again.

    regards

    EggHeadCafe - Software Developer Portal of Choice
    IDisposable, Destructors, Finalizers and Garbage
    http://www.eggheadcafe.com/tutorial...de8-6f44c0686f27/idisposable-destructors.aspx
     
    Nothing Special, Oct 9, 2009
    #1
    1. Advertisements

  2. Nothing Special

    No One Guest

    Solution

    There is a failure in "USBSTOR.SYS" (Version: 5.3.1201.0).

    If you exchange the file from the FP2 or SP3(5.1.2600.2996/5512) there will be no Power Off Problem anymore. :)

    i take much time to figur it out. i hope this helps people in present and future ;)



    Nothing Special wrote:

    Windows Embedded Standard (WES) - ACPI - USB Boot - Power Off Fails
    09-Okt-09

    Hi.

    In short i have a problem with USB Boot and ACPI Computer Hardware. I made an pmq file out of this an image for a notebook, added usb boot, ntldr loader, winlogon (standard) and so on. really basic stuff.

    In the end of FBA the system won't restart. It shutdowns, windows quits all processes fine but it won't power off. for a restart you have to power off the notebook by hand (4sec. power button).

    this problems happens since WES / sp3. i have an image which is build in sp2 / fp2 and acpi works fine. after upgradre the image got the same error.

    any ideas what this could be?
    i think all acpi components are in (power, sleep, fan, fix, lid and so on.), including the "microsoft acpi ..." components.

    someone has an idea? / sean, any idea? ;)

    i already read somthing about this problem, but i didn't find the thread again.

    regards

    Previous Posts In This Thread:

    EggHeadCafe - Software Developer Portal of Choice
    The .NET Framework FINAL: An Analysis
    http://www.eggheadcafe.com/tutorial...764-e25e7cbd00f6/the-net-framework-final.aspx
     
    No One, Oct 14, 2009
    #2
    1. Advertisements

  3. Nothing Special

    Craige Guest

    RE: Windows Embedded Standard (WES) - ACPI - USB Boot - Power Off Fail

    I'm a novice at best but maybe I can get this conversation rolling. I've had
    issues with my FBA when both ACPI Computer Hardware and "Standard PC" were
    included in my final image. In some build instances these two components
    would throw an error and halt my build. I Removed ACPI and used PC Standard
    and the system then behaved nicely. Not sure at this point what trade off I
    made by doing this.

    "Nothing Special" wrote:

    > Hi.
    >
    > In short i have a problem with USB Boot and ACPI Computer Hardware. I made an pmq file out of this an image for a notebook, added usb boot, ntldr loader, winlogon (standard) and so on. really basic stuff.
    >
    > In the end of FBA the system won't restart. It shutdowns, windows quits all processes fine but it won't power off. for a restart you have to power off the notebook by hand (4sec. power button).
    >
    > this problems happens since WES / sp3. i have an image which is build in sp2 / fp2 and acpi works fine. after upgradre the image got the same error.
    >
    > any ideas what this could be?
    > i think all acpi components are in (power, sleep, fan, fix, lid and so on.), including the "microsoft acpi ..." components.
    >
    > someone has an idea? / sean, any idea? ;)
    >
    > i already read somthing about this problem, but i didn't find the thread again.
    >
    > regards
    >
    > EggHeadCafe - Software Developer Portal of Choice
    > IDisposable, Destructors, Finalizers and Garbage
    > http://www.eggheadcafe.com/tutorial...de8-6f44c0686f27/idisposable-destructors.aspx
    >
     
    Craige, Oct 15, 2009
    #3
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Guest

    ACPI Uniprocessor & ACPI Multiprocessor

    Guest, Apr 18, 2005, in forum: Windows XP Embedded
    Replies:
    2
    Views:
    849
  2. Günter Wirth

    Standard PC and Power Interface(ACPI) PC in one image?

    Günter Wirth, Apr 18, 2005, in forum: Windows XP Embedded
    Replies:
    2
    Views:
    362
    Slobodan Brcin \(eMVP\)
    Apr 18, 2005
  3. Rob White
    Replies:
    1
    Views:
    438
    Rob White
    Jan 20, 2006
  4. Krickster

    WES CTP (sp3) To WES 2009 RTM problem

    Krickster, Oct 30, 2008, in forum: Windows XP Embedded
    Replies:
    2
    Views:
    562
    steves
    Nov 3, 2008
  5. Andreas Aegerter

    WES: USB Stick prevents system from entering hibernation

    Andreas Aegerter, Sep 21, 2009, in forum: Windows XP Embedded
    Replies:
    2
    Views:
    497
    Andreas Aegerter
    Oct 8, 2009
Loading...

Share This Page