Set English UK as default spell check language

Discussion in 'Microsoft Word Document Management' started by Jessie Leung, Jun 11, 2009.

  1. Jessie Leung

    Jessie Leung Guest

    I am using Microsoft office 2007. But I find it impossible to set English
    (UK) as the default spell check language. It keeps boucing back to English
    (US).
    I tired to follow http://homepage.swissonline.ch/cindymeister/LangFmt.htm
    but it didn't work for Microsoft 2007.

    It has been a very disturbing issue as our company requires us to write in
    English (UK). Anyone know how to solve this problem? Many thanks.
     
    Jessie Leung, Jun 11, 2009
    #1
    1. Advertisements

  2. Jessie Leung

    Graham Mayor Guest

    If from Windows regional settings you delete the US English option and
    configure as English UK; and you turn off the automatically detect language
    option from Review > Set Language, English UK should hold for typed text.
    Inserted text will still adopt the language in which it was formatted.

    --
    <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    Graham Mayor - Word MVP

    My web site www.gmayor.com
    Word MVP web site http://word.mvps.org
    <>>< ><<> ><<> <>>< ><<> <>>< <>><<>


    Jessie Leung wrote:
    > I am using Microsoft office 2007. But I find it impossible to set
    > English (UK) as the default spell check language. It keeps boucing
    > back to English (US).
    > I tired to follow
    > http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it didn't
    > work for Microsoft 2007.
    >
    > It has been a very disturbing issue as our company requires us to
    > write in English (UK). Anyone know how to solve this problem? Many
    > thanks.
     
    Graham Mayor, Jun 11, 2009
    #2
    1. Advertisements

  3. Jessie Leung

    Jessie Leung Guest

    I already set windows regional as Eng UK. I also set Eng UK as custom
    dictionary for spell check but still it doesn't work. :-(

    "Graham Mayor" wrote:

    > If from Windows regional settings you delete the US English option and
    > configure as English UK; and you turn off the automatically detect language
    > option from Review > Set Language, English UK should hold for typed text.
    > Inserted text will still adopt the language in which it was formatted.
    >
    > --
    > <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    > Graham Mayor - Word MVP
    >
    > My web site www.gmayor.com
    > Word MVP web site http://word.mvps.org
    > <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    >
    >
    > Jessie Leung wrote:
    > > I am using Microsoft office 2007. But I find it impossible to set
    > > English (UK) as the default spell check language. It keeps boucing
    > > back to English (US).
    > > I tired to follow
    > > http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it didn't
    > > work for Microsoft 2007.
    > >
    > > It has been a very disturbing issue as our company requires us to
    > > write in English (UK). Anyone know how to solve this problem? Many
    > > thanks.

    >
    >
    >
     
    Jessie Leung, Jun 11, 2009
    #3
  4. Jessie Leung

    DeanH Guest

    Have you checked the language assigned to the dictionary, i.e. Tools,
    Options, Spelling & Grammar, Custom Dictionaries, Modify. Do you see English
    UK, US, or All Languages?
    Also have you checked all your styles and templates, that none of these have
    English (US) in their settings?
    If this is all OK, then the only thing I can think that is causing the
    conflict is the Language Registry Code, which is set upon install. Sometime
    ago I had a spurious French (France) appearing (just like your English US)
    and it turned out that because my new build (going from Word 2000 on 2000 to
    Word2003 on XP) was done in-house and the disks were bought in France (I work
    for a French company – stop… don't turn-off), and even though the IT chappie
    did the build in English and told everything to be in English, the default
    language was French! So the only remedy was to go into the Registry and
    change the Language code to English (UK), which has solved my problems of
    both French and US.

    English (UK) code is 2057 (LCID Dec) but please check on:
    http://www.microsoft.com/globaldev/reference/lcid-all.mspx
    Where this is changed I am not entirely sure, maybe someone else on the
    Newsgroup will chip in here with the correct procedure for Registry changes.

    Please remember that if the document is distributed to others that may have
    EN US as their language, you may/will get occurances of this language in your
    document.

    All of the above is for 2003 and prior, instructions may differ for 2007.

    Hope this helps
    DeanH

    "Jessie Leung" wrote:

    > I already set windows regional as Eng UK. I also set Eng UK as custom
    > dictionary for spell check but still it doesn't work. :-(
    >
    > "Graham Mayor" wrote:
    >
    > > If from Windows regional settings you delete the US English option and
    > > configure as English UK; and you turn off the automatically detect language
    > > option from Review > Set Language, English UK should hold for typed text.
    > > Inserted text will still adopt the language in which it was formatted.
    > >
    > > --
    > > <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    > > Graham Mayor - Word MVP
    > >
    > > My web site www.gmayor.com
    > > Word MVP web site http://word.mvps.org
    > > <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    > >
    > >
    > > Jessie Leung wrote:
    > > > I am using Microsoft office 2007. But I find it impossible to set
    > > > English (UK) as the default spell check language. It keeps boucing
    > > > back to English (US).
    > > > I tired to follow
    > > > http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it didn't
    > > > work for Microsoft 2007.
    > > >
    > > > It has been a very disturbing issue as our company requires us to
    > > > write in English (UK). Anyone know how to solve this problem? Many
    > > > thanks.

    > >
    > >
    > >
     
    DeanH, Jun 11, 2009
    #4
  5. Jessie Leung

    Graham Mayor Guest

    The proofing language is a paragraph formatting attribute. The default is
    set according to the Windows regional settings. Check that the normal
    paragraph style has the proofing option set to English UK.

    You need to set the language associated with the text and as I suggested
    earlier you need to turn off the automatically detect language option.

    See also See http://sbarnhill.mvps.org/WordFAQs/MasterSpellCheck.htm
    --
    <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    Graham Mayor - Word MVP

    My web site www.gmayor.com
    Word MVP web site http://word.mvps.org
    <>>< ><<> ><<> <>>< ><<> <>>< <>><<>

    Jessie Leung wrote:
    > I already set windows regional as Eng UK. I also set Eng UK as custom
    > dictionary for spell check but still it doesn't work. :-(
    >
    > "Graham Mayor" wrote:
    >
    >> If from Windows regional settings you delete the US English option
    >> and configure as English UK; and you turn off the automatically
    >> detect language option from Review > Set Language, English UK should
    >> hold for typed text. Inserted text will still adopt the language in
    >> which it was formatted.
    >>
    >> --
    >> <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    >> Graham Mayor - Word MVP
    >>
    >> My web site www.gmayor.com
    >> Word MVP web site http://word.mvps.org
    >> <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
    >>
    >>
    >> Jessie Leung wrote:
    >>> I am using Microsoft office 2007. But I find it impossible to set
    >>> English (UK) as the default spell check language. It keeps boucing
    >>> back to English (US).
    >>> I tired to follow
    >>> http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it
    >>> didn't work for Microsoft 2007.
    >>>
    >>> It has been a very disturbing issue as our company requires us to
    >>> write in English (UK). Anyone know how to solve this problem? Many
    >>> thanks.
     
    Graham Mayor, Jun 11, 2009
    #5
  6. Jessie Leung

    JayDee1946

    Joined:
    Jan 7, 2010
    Messages:
    1
    Likes Received:
    0
    I am running Office 2007 under Windows 7.

    As I understand it having read the various help files and the posts in this and another forum, the default language is now controlled by the regional setting in the operating system. But that also defines the keyboard layout.

    So I can have UK English if I have a UK keyboard.
    But I cannot find any way to select a US keyboard while still wishing to use UK spelling.

    Am I mistaken?

    The symptoms I observe seem to be worse than that in fact. I can change my language in the Language bar to be UK English then create a Word document and it will be checked for UK spelling. Fine.
    But as soon as I quit Word, the Language Bar insists on reverting to US English.

    Any suggestions?
    (Or do I have to get used to pretending I have a UK keyboard and therefore mistyping the @ (") sign frequently?)
     
    JayDee1946, Jan 7, 2010
    #6
  7. Jessie Leung

    WJR

    Joined:
    Feb 1, 2010
    Messages:
    1
    Likes Received:
    0
    WJR, Feb 1, 2010
    #7
  8. Jessie Leung

    techo

    Joined:
    Jun 10, 2010
    Messages:
    1
    Likes Received:
    0
    Hi everyone! this is my first post in this forum.

    I have the same issue and the solution is to set the "system locale" to English (Singapore).

    I am from Singapore, we study UK english but use US keyboard.

    cheers! : D
     
    techo, Jun 10, 2010
    #8
  9. Jessie Leung

    Marmit3

    Joined:
    Dec 14, 2012
    Messages:
    1
    Likes Received:
    0
    hi all,

    work for a multilingual company and my OS is set to German and i have to write in both German and English.

    The reason i found this thread (and decided now ther is no solution): I started a PPT in English without changing my default language to English.

    I wanted to ask: Can I afterwards change the spell checking language for all text in the PPT to English? and the answer is: No, PowerPoint will always revert back to the language it was started in even if you delete the German spell checker, even if you change your reginal settings and even if you change your keyboard layout to Engliush, it still doesnt work.

    Why would it? It's not like this is modern technology... its not like this problem is 15 years old and still not fixed. (sarcasm off)

    piece of ***** software :mad:


    PS: Office 2010
     
    Last edited: Dec 14, 2012
    Marmit3, Dec 14, 2012
    #9
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Guest

    RE: spell check language keeps resetting itself from english to french

    Guest, Jun 16, 2004, in forum: Microsoft Word Document Management
    Replies:
    0
    Views:
    261
    Guest
    Jun 16, 2004
  2. Guest

    Canadian English Spell Check should Check for Consistency

    Guest, Nov 2, 2005, in forum: Microsoft Word Document Management
    Replies:
    0
    Views:
    481
    Guest
    Nov 2, 2005
  3. Guest

    Remove English (U.S.) language as a default language

    Guest, Mar 20, 2006, in forum: Microsoft Word Document Management
    Replies:
    3
    Views:
    589
    Suzanne S. Barnhill
    Mar 21, 2006
  4. Guest

    why does spell check revert from English UK to English US

    Guest, Feb 9, 2007, in forum: Microsoft Word Document Management
    Replies:
    2
    Views:
    404
    Guest
    Feb 9, 2007
  5. Jimmy Moggles

    Default Spell Checker Language Always Defaults To 'English Singapo

    Jimmy Moggles, Dec 6, 2008, in forum: Microsoft Word Document Management
    Replies:
    1
    Views:
    237
    Suzanne S. Barnhill
    Dec 7, 2008
Loading...

Share This Page