Laptop shuts off when AC adapter is removed. Battery is OK.

Discussion in 'Windows XP Hardware' started by Maninder, Feb 9, 2004.

  1. Maninder

    Maninder Guest

    Hi,
    My presario laptop (Windows Xp) recently developed this
    snag. With Ac power, it works fine but moment the adapter
    is removed the unit shuts off. The meter on battery is
    showing 50% charged.

    Can somebody advise to help me rectify this problem.
    Maninder.
     
    Maninder, Feb 9, 2004
    #1
    1. Advertisements

  2. Maninder,

    Recalibrate the battery. (Discharge completely / recharge / discharge) Check
    your model's driver page, for any battery controller firmware updates. Next,
    check with another battery.

    Best of luck,

    Prasad
    (AOL - prasadbgd)

    "The strongest oak..was once a small nut that held its ground"

    "Maninder" <> wrote in message
    news:d06401c3eeed$bf719e20$...
    > Hi,
    > My presario laptop (Windows Xp) recently developed this
    > snag. With Ac power, it works fine but moment the adapter
    > is removed the unit shuts off. The meter on battery is
    > showing 50% charged.
    >
    > Can somebody advise to help me rectify this problem.
    > Maninder.
     
    Prasad Addepalli, Feb 9, 2004
    #2
    1. Advertisements

  3. Maninder

    Mainder Guest

    Hi Prasad,,
    Thanks for responding to my SOS.

    I did tried to recalibrate but thats not working. I will
    explain to you why:
    For recalibration, I need to discharge the battery first.
    But in my case, moment I remove the AC Adapter, the laptop
    shuts off. And when I try to reboot it, it doesn't power-
    up.
    Then I have to plug in the AC adapter, & then power up, it
    does boot but the Battery Icon shows 47% charged. It
    neither moves up or down, reading is stuck at 47% only.

    Meter on battery is also showing 50% charged. Thats why I
    don't doubt the battery.

    Could it be because of some problem in BIOS or Windows XP.

    Battery controller firmware is also the updated one.

    Maninder

    >-----Original Message-----
    >Maninder,
    >
    >Recalibrate the battery. (Discharge completely /

    recharge / discharge) Check
    >your model's driver page, for any battery controller

    firmware updates. Next,
    >check with another battery.
    >
    >Best of luck,
    >
    >Prasad
    >(AOL - prasadbgd)
    >
    >"The strongest oak..was once a small nut that held its

    ground"
    >
    >"Maninder" <> wrote in

    message
    >news:d06401c3eeed$bf719e20$...
    >> Hi,
    >> My presario laptop (Windows Xp) recently developed this
    >> snag. With Ac power, it works fine but moment the

    adapter
    >> is removed the unit shuts off. The meter on battery is
    >> showing 50% charged.
    >>
    >> Can somebody advise to help me rectify this problem.
    >> Maninder.

    >
    >
    >.
    >
     
    Mainder, Feb 9, 2004
    #3
  4. Maninder

    Endan Guest

    Hi,
    maybe it is because the cmos battery is dead. In that case, you need to send
    your laptop back to the manufacture for replacing battery. I used to try
    replacing cmos battery myself, and my laptop died in my hand. :(

    good luck

    Endan
     
    Endan, Feb 9, 2004
    #4
  5. Maninder

    NobodyMan Guest

    On Mon, 9 Feb 2004 12:31:02 -0000, "Endan" <> wrote:

    >Hi,
    >maybe it is because the cmos battery is dead. In that case, you need to send
    >your laptop back to the manufacture for replacing battery. I used to try
    >replacing cmos battery myself, and my laptop died in my hand. :(
    >
    >good luck
    >
    >Endan
    >


    This has "NOT CMOS BATTERY" written all over it. CMOS has nothing to
    do with power management.

    I do agree that it needs to go back to the manufacturer for repair.
    It has nothing to do with XP.
     
    NobodyMan, Feb 10, 2004
    #5
  6. Maninder

    kunun Guest


    >-----Original Message-----
    >Hi,
    >My presario laptop (Windows Xp) recently developed this
    >snag. With Ac power, it works fine but moment the adapter
    >is removed the unit shuts off. The meter on battery is
    >showing 50% charged.
    >
    >Can somebody advise to help me rectify this problem.
    >Maninder.
    >.
    >check on the compaq site they have updates for your

    presario. I think they are under the bios upgrade.
     
    kunun, Feb 11, 2004
    #6
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chris

    Laptop Monitor shuts off by itself.

    Chris, Aug 12, 2003, in forum: Windows XP Hardware
    Replies:
    0
    Views:
    218
    Chris
    Aug 12, 2003
  2. Alex

    Laptop Monitor shuts off by itself.

    Alex, Aug 17, 2003, in forum: Windows XP Hardware
    Replies:
    0
    Views:
    197
  3. Thomas F
    Replies:
    0
    Views:
    298
    Thomas F
    Aug 18, 2003
  4. loren

    Laptop shuts off in 30 sec. on battery. ok on AC

    loren, Jan 1, 2004, in forum: Windows XP Hardware
    Replies:
    1
    Views:
    262
  5. Bill & Debbie

    Help! How can the driver for a plug & play adapter be removed?

    Bill & Debbie, Jul 2, 2007, in forum: Windows XP Hardware
    Replies:
    1
    Views:
    150
    Ghostrider
    Jul 2, 2007
Loading...

Share This Page