http://127.0.0.1 works, NOT http://localhost or http://MyCompute...

Discussion in 'Microsoft Dot NET Framework' started by Pieter Coucke, Mar 29, 2006.

  1. Hi,

    This is a problem that I had before, went away for some reason I don't know,
    and that I got back now with my freshly installed pc.

    I have XP Pro, with all service packs, latest updates etc installed, and
    IIS.
    http://localhost, http://MyComputer and http://127.0.0.1 worked fine.

    After installing:
    - .NET 1.1 + Visual Studio .NET 1.1 + SDK 1.1
    - .NET 2.0 + Visual Studio .NET 2.0 + SDK 2.0 + Sql Express
    - SQL 2000 + Reporting Services
    - SQL 2005 + Reporting Services

    Only http://127.0.0.1 works... the two others don't...

    I tried playing around with the aspnet_regiis.exe -i etc, cheched my
    "C:\WINDOWS\system32\drivers\etc\hosts" (it contains "127.0.0.1
    localhost"), googled a lot, ... but I din't find a solution.

    This annoys me really a lot: it's a freshly formatted and installed pc (took
    me 2 days), everything installed as it should be, but I get this stinky
    problem.

    Anybody has any idea? I can't be the only one I guess? I had it with my
    other pc also, but for some reason it once wen't away suddenly..

    Any help, hints, etc would be really appreciated!

    Thanks a lot in advance,

    Pieter
     
    Pieter Coucke, Mar 29, 2006
    #1
    1. Advertisements

  2. Never mind, my network-administrator find the solution/reason. It seemed
    that, when de-connecting my pc from the network localhost worked. And when
    doing a "ping localhost" it returned me a TCP/IP verison 6 ip-adress.

    I desinstalled the TCP/IP version 6, and that solved the problem!
     
    Pieter Coucke, Mar 29, 2006
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dave Uphoff

    Can't use localhost

    Dave Uphoff, Dec 3, 2003, in forum: Microsoft Dot NET Framework
    Replies:
    10
    Views:
    792
    Ricky K. Rasmussen
    Dec 9, 2003
  2. Mad Scientist Jr
    Replies:
    1
    Views:
    724
    chris m
    Oct 8, 2004
  3. IT Drone

    VS 2003 won't open existing web project on localhost

    IT Drone, Feb 24, 2005, in forum: Microsoft Dot NET Framework
    Replies:
    2
    Views:
    546
    Alvin Bruney [Microsoft MVP]
    Feb 27, 2005
  4. KKS

    DirectorySecurity's SetAccesControl works/not works?

    KKS, May 4, 2007, in forum: Microsoft Dot NET Framework
    Replies:
    0
    Views:
    266
  5. JDJ
    Replies:
    2
    Views:
    1,320
Loading...

Share This Page