Error - Windows Installer not correctly installed

Discussion in 'Microsoft Windows 2000 MSI' started by John, Nov 10, 2003.

  1. John

    John Guest

    Any programs and applications that needs Windows Installer
    will not run. Message reads: "The Windows Installer
    Service could not be accessed. This can occur if running
    Windows in safe mode, or if the Windows Installer is nt
    correctly installed. Contact your support personnel for
    assistance." First answer to that is "No I'm not running
    in safe mode" and I try to reinstall "msiexec.exe" and
    message say's "The specified service already exists". In
    Administrative Services, Services, properties of Windows
    Installer I try starting and message reads " Could not
    start the Windows Installer service on local computer. The
    service did not return an error. This could be an internal
    Windows error or an internal service error.
    If the problem persists,contact your system administrator".
    I'll try any cure but don't really what to reinstall
    Windows if possible. Thanks, John
     
    John, Nov 10, 2003
    #1
    1. Advertisements

  2. Please try the steps described here:
    http://www.msifaq.com/error/1719.htm


    --
    Stefan Krueger
    Microsoft Windows Installer MVP

    Please post your questions in the newsgroup or vist one of these web sites:

    Windows Installer FAQ
    http://www.msifaq.com - http://www.msifaq.de

    InstallSite - Resources for Setup Developers
    http://www.installsite.org
    http://www.installsite.de (GERMAN)

    "John" <> schrieb im Newsbeitrag
    news:02b101c3a71d$b2e86250$...
    > Any programs and applications that needs Windows Installer
    > will not run. Message reads: "The Windows Installer
    > Service could not be accessed. This can occur if running
    > Windows in safe mode, or if the Windows Installer is nt
    > correctly installed. Contact your support personnel for
    > assistance." First answer to that is "No I'm not running
    > in safe mode" and I try to reinstall "msiexec.exe" and
    > message say's "The specified service already exists". In
    > Administrative Services, Services, properties of Windows
    > Installer I try starting and message reads " Could not
    > start the Windows Installer service on local computer. The
    > service did not return an error. This could be an internal
    > Windows error or an internal service error.
    > If the problem persists,contact your system administrator".
    > I'll try any cure but don't really what to reinstall
    > Windows if possible. Thanks, John
     
    Stefan Krueger [MVP], Nov 10, 2003
    #2
    1. Advertisements

  3. John wrote:

    > Any programs and applications that needs Windows Installer
    > will not run. Message reads: "The Windows Installer
    > Service could not be accessed. This can occur if running
    > Windows in safe mode, or if the Windows Installer is nt
    > correctly installed. Contact your support personnel for
    > assistance." First answer to that is "No I'm not running
    > in safe mode" and I try to reinstall "msiexec.exe" and
    > message say's "The specified service already exists". In
    > Administrative Services, Services, properties of Windows
    > Installer I try starting and message reads " Could not
    > start the Windows Installer service on local computer. The
    > service did not return an error. This could be an internal
    > Windows error or an internal service error.
    > If the problem persists,contact your system administrator".
    > I'll try any cure but don't really what to reinstall


    Hi

    For Windows 2000:
    http://groups.google.com/groups?selm=

    For Windows XP:
    http://groups.google.com/groups?selm=


    --
    torgeir
    Microsoft MVP Scripting and WMI, Porsgrunn Norway
    Administration scripting examples and an ONLINE version of the 1328 page
    Scripting Guide: http://www.microsoft.com/technet/scriptcenter
     
    Torgeir Bakken (MVP), Nov 10, 2003
    #3
  4. John

    Jim Leach Guest

    I too have had this problem after playing with COM.

    Do you have OfficeXP - If so, this is my solution..

    Delete the registry key in
    HKEY_CLASSES_ROOT \ Installer \ Products
    that matches the same folder namer in
    ..\WINNT\Installer\
    that contains the OfficeXP files.

    In my case (I don't know if this will be the same for
    other installations the CLSID was {91110409-6000-11D3-8CFE-
    0050048383C9}

    Thus both the registry key and folder {91110409-6000-11D3-
    8CFE-0050048383C9} were deleted from the Installer
    key/folder.

    Then Reinstall OfficeXP from the CD. Your Office settings
    are kept, and it would seem that so are any Service Packs,
    but you will need to reinstall Service Packs as Office
    Update won't see them.
     
    Jim Leach, Nov 11, 2003
    #4
  5. John

    ufo973

    Joined:
    Oct 14, 2007
    Messages:
    1
    Likes Received:
    0
    Here is the sulotion

    Hi
    i had same problem but fortuanately i found the solution.
    The solution described in the microsoft is not working and i emailed them this new solution.
    There is problem with your installscript engine.
    http://www.installsite.org/pages/en/msifaq/a/1027.htm
     
    ufo973, Oct 14, 2007
    #5
  6. John

    fanaudi

    Joined:
    Feb 8, 2008
    Messages:
    2
    Likes Received:
    0
    Hi this is another easy solution

    Hello Guys ,
    I' m a newbe here and hope that my modest experience can eventually be of any help to anyone.
    The solution described in Microsoft was , just like for ufo973 ( hello there ! ) a complete flop .
    The solution in my case was very simple but will only work if one is in possession of a Windows installation cdrom ( XP or VISTA ) .
    Start the cdrom and select exclusively the "Windows upgrade " option .This is important , otherwhise you could loose all contents of your previous system . Now , Windows cares for the rest and that' s all folks . In my case , my system is now up to date and Windows Installer has fully recovered .
     
    fanaudi, Feb 8, 2008
    #6
  7. John

    fanaudi

    Joined:
    Feb 8, 2008
    Messages:
    2
    Likes Received:
    0
    Windows Installer not correctly installed

    Ok ok ... It sometimes can happen that after having repaired Windows Installer , a new issue appears with the Updates Installer ! Replay then your Windows cdrom and select " reinstall Windows / repair " . This should doe the trick , it worked in my situation anyway ...
     
    fanaudi, Feb 10, 2008
    #7
  8. John

    NeophobiA

    Joined:
    Mar 13, 2006
    Messages:
    2
    Likes Received:
    0
    Hi,
    I'm having the errors on a windows ME system.
    I wish to install dontnetfix and it tells me
    "Setup has detected that the following prerequisite programs are not installed
    Microsoft Windows Installer 2.0
    You must first install these programs before ?Microsoft .net framework 2.0 can be installed"
    BUT
    I try to install Microsoft Windows Installer 2.0 and get this error
    "The specified service already exists"
    how can I fix or work around this ?
     
    NeophobiA, Jul 21, 2008
    #8
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Advanced Installer
    Replies:
    0
    Views:
    432
    Advanced Installer
    May 5, 2004
  2. quick35
    Replies:
    6
    Views:
    1,394
    quick35
    May 12, 2004
  3. Advanced Installer
    Replies:
    0
    Views:
    357
    Advanced Installer
    Jun 7, 2004
  4. Advanced Installer
    Replies:
    0
    Views:
    319
    Advanced Installer
    Jul 5, 2004
  5. Tyler Robinson [MSFT]
    Replies:
    0
    Views:
    703
    Tyler Robinson [MSFT]
    Jun 15, 2005
Loading...

Share This Page