Database Permissions Nightmare

Discussion in 'Microsoft Access Security' started by Gary, Jul 8, 2003.

  1. Gary

    Gary Guest

    Hi. I have a database that I created. I have set up a
    Workgroup file for security which works great when I call
    it as part of the shortcut. In Workgroup Administrator
    (after wards), I set the Workgroup to the Sysem.mdw file.
    Now if I use the shortcut, I get my security prompt and
    all is well. But if I call the database directly I get
    the following:

    You do not have the necessary permissions to use the
    <name> object. Have your system administrator or the
    person who created this object establish the appropriate
    permissions for you. (Error 3033)

    Shouldn't the database just use the default System file?
    Is there something else I need to change?

    Thanks,

    Any help is appreciated.

    Gary
     
    Gary, Jul 8, 2003
    #1
    1. Advertisements

  2. Gary

    Joan Wild Guest

    Sounds right to me. The point of securing it is that you want people to
    access it only if they have been authenticated via your secure workgroup
    file. If the database opens using the default system.mdw, then anyone could
    open it.

    Do you want people to be able to open the database without logging in (it is
    possible)?

    --
    Joan Wild
    Microsoft Access MVP

    "Gary" <> wrote in message
    news:004d01c3455c$f94dd040$...
    > Hi. I have a database that I created. I have set up a
    > Workgroup file for security which works great when I call
    > it as part of the shortcut. In Workgroup Administrator
    > (after wards), I set the Workgroup to the Sysem.mdw file.
    > Now if I use the shortcut, I get my security prompt and
    > all is well. But if I call the database directly I get
    > the following:
    >
    > You do not have the necessary permissions to use the
    > <name> object. Have your system administrator or the
    > person who created this object establish the appropriate
    > permissions for you. (Error 3033)
    >
    > Shouldn't the database just use the default System file?
    > Is there something else I need to change?
    >
    > Thanks,
    >
    > Any help is appreciated.
    >
    > Gary
     
    Joan Wild, Jul 8, 2003
    #2
    1. Advertisements

  3. Gary

    Joan Wild Guest

    Permissions are stored in the mdb file. The workgroup holds users, groups,
    memberships. You can't just join another workgroup and open the database.
    If you want to unsecure the database, there are steps in the FAQ to do this
    http://support.microsoft.com/?kbid=207793

    Basically you log in to the database, give permissions for all objects back
    to the Users Group.

    Open Access using the default system.mdw workgroup, start a new database,
    and import all the objects from your 'secure' database. It will no longer
    be secure.

    --
    Joan Wild
    Microsoft Access MVP

    "Gary" <> wrote in message
    news:8ac901c3456d$f4243030$...
    > I would like to be able to get back in without the
    > Security.
    >
     
    Joan Wild, Jul 8, 2003
    #3
  4. Gary

    alekbt

    Joined:
    Mar 9, 2009
    Messages:
    2
    Likes Received:
    0
    Please some help needed.

    i was using access 2000 from start to create a database but somewhere in the middle i have installed access 2003 and continue working with my database. in a order to prevent appearing that security warning window on the start i run security wizard . and didn't manage to find anything about but i accidenttly created a workgroup . on the security wizard i was only clicking next ,next and i didn't set any password. but it seems that the wizard has made security.mdw file and a shortcut for my database from where i was able to start my database, and a logon screen was appearing with only my username "alek" and no password and with only clicking OK my database was opening with full permissions. but somehow i have deleted the security file and now this message appears <b>You do not have the necessary permissions to use the <name> object. Have your system administrator or the person who created this object establish the appropriate permissions for you. (Error 3033)</b>
    i went to as many forums about this problem and i have tried many things like creating new mdw file with full permissions for admins and users , i have created user "alek" in this new file and give him admin rights , and then joined this file to my database through shortcut "C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE" "C:\Documents and Settings\alek\Desktop\potsetnik1.0.mdb" /WRKGRP "C:\Documents and Settings\alek\Desktop\security1.mdw" /user "alek" . but nothing helped.
     
    alekbt, Mar 9, 2009
    #4
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Guest

    Security nightmare - 2 mdw's mixed up

    Guest, Jul 13, 2006, in forum: Microsoft Access Security
    Replies:
    50
    Views:
    842
    Joan Wild
    Aug 17, 2006
  2. Guest

    Security nightmare

    Guest, Sep 14, 2006, in forum: Microsoft Access Security
    Replies:
    4
    Views:
    144
    Guest
    Sep 16, 2006
  3. Guest

    folder security nightmare to allow .ldb file deletion

    Guest, Oct 16, 2007, in forum: Microsoft Access Security
    Replies:
    6
    Views:
    422
    Guest
    Oct 18, 2007
  4. Do Table Permissions Override Query permissions?

    , Oct 22, 2007, in forum: Microsoft Access Security
    Replies:
    2
    Views:
    351
  5. E-Double

    Workgroup permissions for Access 97 DB (permissions error)

    E-Double, Jun 5, 2009, in forum: Microsoft Access Security
    Replies:
    1
    Views:
    939
    denny
    Jun 8, 2009
Loading...

Share This Page