Can't use UK keyboard layout at login

Discussion in 'Microsoft Windows 2000 Deployment' started by Chris, Aug 25, 2004.

  1. Chris

    Chris Guest

    Hi,

    I'm deploying Win2k SP4 machines from a RIS server
    including the UK regional settings. A problem came to
    light because we enforce the strong password policy GPO.
    Some users use the '@' symbol in their passwords, but when
    they type it in at the login screen, they get the US
    keyboard layout & so actually type '"'!

    I can't seem to find a way to enforce the UK keyboard
    layout at the login screen, even if I make UK default &
    delete US layout completely. Here's the section of my
    riprep.sif file from the RIPrep image folder which
    includes the UK keyboard layout:

    [RegionalSettings]
    Language=00000809
    LanguageGroup=1
    InputLocale=00000809

    and it's the same in the CD-based image ristndrd.sif file
    too. Machines built from this end up with both the UK & US
    layouts, defaulting to the UK layout. I can't seem to
    exclude the US layout in the RIPrep build.

    Any ideas?
     
    Chris, Aug 25, 2004
    #1
    1. Advertisements

  2. Hi

    You need the following lines:

    [Unattended]
    KeyboardLayout="United Kingdom"

    Also, if you haven't already got this, you'll want it too.

    [GUIUnattended]
    TimeZone=85

    If you want to fiddle with machines you've already deployed, try importing
    this registry file on a test machine.

    Windows Registry Editor Version 5.00

    [HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
    "1"="00000809"

    Hope this helps

    Oli




    "Chris" <> wrote in message
    news:5a8401c48a81$4d145950$...
    > Hi,
    >
    > I'm deploying Win2k SP4 machines from a RIS server
    > including the UK regional settings. A problem came to
    > light because we enforce the strong password policy GPO.
    > Some users use the '@' symbol in their passwords, but when
    > they type it in at the login screen, they get the US
    > keyboard layout & so actually type '"'!
    >
    > I can't seem to find a way to enforce the UK keyboard
    > layout at the login screen, even if I make UK default &
    > delete US layout completely. Here's the section of my
    > riprep.sif file from the RIPrep image folder which
    > includes the UK keyboard layout:
    >
    > [RegionalSettings]
    > Language=00000809
    > LanguageGroup=1
    > InputLocale=00000809
    >
    > and it's the same in the CD-based image ristndrd.sif file
    > too. Machines built from this end up with both the UK & US
    > layouts, defaulting to the UK layout. I can't seem to
    > exclude the US layout in the RIPrep build.
    >
    > Any ideas?
     
    Oli Restorick [MVP], Aug 26, 2004
    #2
    1. Advertisements

  3. Chris

    Chris Guest

    Thanks for the reply, Oli. Found it was down to an
    individual RIPrep image not installing the correct layout,
    so all machines of that type ended up with the problem.
    Not really sure why, because I tried making changes to
    the .sif file as you suggested, but the US keyboard was
    still the default at logon. Ended up re-imaging for that
    type of machine.

    The hint with the registry will be useful, though as I
    should be able to mop up machines that have already used
    the old image.

    Cheers - Chris.

    >-----Original Message-----
    >Hi
    >
    >You need the following lines:
    >
    >[Unattended]
    >KeyboardLayout="United Kingdom"
    >
    >Also, if you haven't already got this, you'll want it too.
    >
    >[GUIUnattended]
    >TimeZone=85
    >
    >If you want to fiddle with machines you've already

    deployed, try importing
    >this registry file on a test machine.
    >
    >Windows Registry Editor Version 5.00
    >
    >[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
    >"1"="00000809"
    >
    >Hope this helps
    >
    >Oli
    >
    >
    >
    >
    >"Chris" <> wrote in

    message
    >news:5a8401c48a81$4d145950$...
    >> Hi,
    >>
    >> I'm deploying Win2k SP4 machines from a RIS server
    >> including the UK regional settings. A problem came to
    >> light because we enforce the strong password policy GPO.
    >> Some users use the '@' symbol in their passwords, but

    when
    >> they type it in at the login screen, they get the US
    >> keyboard layout & so actually type '"'!
    >>
    >> I can't seem to find a way to enforce the UK keyboard
    >> layout at the login screen, even if I make UK default &
    >> delete US layout completely. Here's the section of my
    >> riprep.sif file from the RIPrep image folder which
    >> includes the UK keyboard layout:
    >>
    >> [RegionalSettings]
    >> Language=00000809
    >> LanguageGroup=1
    >> InputLocale=00000809
    >>
    >> and it's the same in the CD-based image ristndrd.sif

    file
    >> too. Machines built from this end up with both the UK &

    US
    >> layouts, defaulting to the UK layout. I can't seem to
    >> exclude the US layout in the RIPrep build.
    >>
    >> Any ideas?

    >
    >
    >.
    >
     
    Chris, Sep 1, 2004
    #3
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mary Savacool

    Mouse&Keyboard no longer work, can't login

    Mary Savacool, Sep 17, 2003, in forum: Microsoft Windows 2000 Deployment
    Replies:
    1
    Views:
    482
    Alex L
    Sep 17, 2003
  2. JeffO

    sysprep cant update registry

    JeffO, Sep 17, 2003, in forum: Microsoft Windows 2000 Deployment
    Replies:
    0
    Views:
    2,012
    JeffO
    Sep 17, 2003
  3. luis salgado

    cant setup two-way trust between two forest

    luis salgado, Oct 9, 2003, in forum: Microsoft Windows 2000 Deployment
    Replies:
    0
    Views:
    318
    luis salgado
    Oct 9, 2003
  4. Paul Dolen

    Machine works fine with USB keyboard, completely unusable with a PS2 keyboard

    Paul Dolen, Aug 23, 2004, in forum: Microsoft Windows 2000 Deployment
    Replies:
    0
    Views:
    341
    Paul Dolen
    Aug 23, 2004
  5. Jossie_2k

    Modify keyboard layout

    Jossie_2k, Apr 23, 2006, in forum: Microsoft Windows 2000 Deployment
    Replies:
    1
    Views:
    1,104
    Youghs
    May 31, 2006
Loading...

Share This Page