Can't insert PDF Objects into Microsoft Excel

Discussion in 'Microsoft Excel Discussion' started by Tegger, Jan 28, 2011.

  1. Tegger

    Tegger Guest

    Just posting this in case it helps somebody somewhere...

    Situation: Excel hangs for a couple of minutes, then errors with this
    message:
    "Microsoft Excel is waiting for another application to complete an OLE
    action".

    Other Objects and Pictures can be inserted without problem.

    The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as
    well (but I only have AAP 9.4, so cannot check to be sure).

    Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".
    This must be disabled in order for Excel to be able to insert PDFs into a
    spreadsheet.

    Disable "Protected Mode" this way:
    Go to Edit > Preferences > General, then UNcheck the box that says
    "Enable Protected Mode on Startup".

    Here's why: Excel cannot display an inserted PDF without asking the help of
    an already-installed copy of Reader or Acrobat, or other PDF-reading
    program. Reader X, by default, wants to corral the opened file all to
    itself, not allowing any other program to play with it. This is done for
    security reasons.

    The problem is that Excel is seen by Reader X to be a SECOND--and therefore
    illegal--program attempting to access the PDF file at the same time as
    Reader X (in violation of Protected Mode). So you need to disable Protected
    Mode so Reader will allow other programs to work with the PDF at the same
    time as Reader X.



    --
    Tegger
     
    Tegger, Jan 28, 2011
    #1
    1. Advertisements

  2. Tegger

    prtksr

    Joined:
    Mar 18, 2011
    Messages:
    1
    Likes Received:
    0
    Thank you! Tegger
     
    prtksr, Mar 18, 2011
    #2
    1. Advertisements

  3. Tegger

    R. Guest

    Thanks Tegger,

    This was exactely the solution I needed!

    Hopefully I'm not grave digging here, many of our machines are finally being upgraded to Reader X.

    > On Thursday, January 27, 2011 8:51 PM Tegger wrote:


    > Just posting this in case it helps somebody somewhere...
    >
    > Situation: Excel hangs for a couple of minutes, then errors with this
    > message:
    > "Microsoft Excel is waiting for another application to complete an OLE
    > action".
    >
    > Other Objects and Pictures can be inserted without problem.
    >
    > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as
    > well (but I only have AAP 9.4, so cannot check to be sure).
    >
    > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".
    > This must be disabled in order for Excel to be able to insert PDFs into a
    > spreadsheet.
    >
    > Disable "Protected Mode" this way:
    > Go to Edit > Preferences > General, then UNcheck the box that says
    > "Enable Protected Mode on Startup".
    >
    > Here is why: Excel cannot display an inserted PDF without asking the help of
    > an already-installed copy of Reader or Acrobat, or other PDF-reading
    > program. Reader X, by default, wants to corral the opened file all to
    > itself, not allowing any other program to play with it. This is done for
    > security reasons.
    >
    > The problem is that Excel is seen by Reader X to be a SECOND--and therefore
    > illegal--program attempting to access the PDF file at the same time as
    > Reader X (in violation of Protected Mode). So you need to disable Protected
    > Mode so Reader will allow other programs to work with the PDF at the same
    > time as Reader X.
    >
    >
    >
    > --
    > Tegger
     
    R., Apr 18, 2011
    #3
  4. Tegger

    Guest

    THANK YOU THANK YOU THANK YOU!!


    On Thursday, January 27, 2011 7:51:24 PM UTC-6, Tegger wrote:
    > Just posting this in case it helps somebody somewhere...
    >
    > Situation: Excel hangs for a couple of minutes, then errors with this
    > message:
    > "Microsoft Excel is waiting for another application to complete an OLE
    > action".
    >
    > Other Objects and Pictures can be inserted without problem.
    >
    > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as
    > well (but I only have AAP 9.4, so cannot check to be sure).
    >
    > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".
    > This must be disabled in order for Excel to be able to insert PDFs into a
    > spreadsheet.
    >
    > Disable "Protected Mode" this way:
    > Go to Edit > Preferences > General, then UNcheck the box that says
    > "Enable Protected Mode on Startup".
    >
    > Here's why: Excel cannot display an inserted PDF without asking the help of
    > an already-installed copy of Reader or Acrobat, or other PDF-reading
    > program. Reader X, by default, wants to corral the opened file all to
    > itself, not allowing any other program to play with it. This is done for
    > security reasons.
    >
    > The problem is that Excel is seen by Reader X to be a SECOND--and therefore
    > illegal--program attempting to access the PDF file at the same time as
    > Reader X (in violation of Protected Mode). So you need to disable Protected
    > Mode so Reader will allow other programs to work with the PDF at the same
    > time as Reader X.
    >
    >
    >
    > --
    > Tegger
     
    , Dec 5, 2012
    #4
  5. Tegger

    Guest

    This piece of the puzzle was exactly what I needed. This was PERFECT! THANK YOU TEGGER!!!
     
    , Aug 19, 2013
    #5
  6. Tegger

    Guest

    This was also what I needed. Thanks a ton.
     
    , Sep 27, 2013
    #6
  7. Tegger

    Guest

    On Thursday, January 27, 2011 8:51:24 PM UTC-5, Tegger wrote:
    > Just posting this in case it helps somebody somewhere...
    >
    > Situation: Excel hangs for a couple of minutes, then errors with this
    > message:
    > "Microsoft Excel is waiting for another application to complete an OLE
    > action".
    >
    > Other Objects and Pictures can be inserted without problem.
    >
    > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as
    > well (but I only have AAP 9.4, so cannot check to be sure).
    >
    > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".
    > This must be disabled in order for Excel to be able to insert PDFs into a
    > spreadsheet.
    >
    > Disable "Protected Mode" this way:
    > Go to Edit > Preferences > General, then UNcheck the box that says
    > "Enable Protected Mode on Startup".
    >
    > Here's why: Excel cannot display an inserted PDF without asking the help of
    > an already-installed copy of Reader or Acrobat, or other PDF-reading
    > program. Reader X, by default, wants to corral the opened file all to
    > itself, not allowing any other program to play with it. This is done for
    > security reasons.
    >
    > The problem is that Excel is seen by Reader X to be a SECOND--and therefore
    > illegal--program attempting to access the PDF file at the same time as
    > Reader X (in violation of Protected Mode). So you need to disable Protected
    > Mode so Reader will allow other programs to work with the PDF at the same
    > time as Reader X.
    >
    >
    >
    > --
    > Tegger


    Great solution SIR!!!. Its really helped me. This needs to be change in PDF reader software. Thanks!
     
    , Jan 31, 2014
    #7
  8. Tegger

    Guest

    On Thursday, January 27, 2011 7:51:24 PM UTC-6, Tegger wrote:
    > Just posting this in case it helps somebody somewhere...
    >
    > Situation: Excel hangs for a couple of minutes, then errors with this
    > message:
    > "Microsoft Excel is waiting for another application to complete an OLE
    > action".
    >
    > Other Objects and Pictures can be inserted without problem.
    >
    > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as
    > well (but I only have AAP 9.4, so cannot check to be sure).
    >
    > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".
    > This must be disabled in order for Excel to be able to insert PDFs into a
    > spreadsheet.
    >
    > Disable "Protected Mode" this way:
    > Go to Edit > Preferences > General, then UNcheck the box that says
    > "Enable Protected Mode on Startup".
    >
    > Here's why: Excel cannot display an inserted PDF without asking the help of
    > an already-installed copy of Reader or Acrobat, or other PDF-reading
    > program. Reader X, by default, wants to corral the opened file all to
    > itself, not allowing any other program to play with it. This is done for
    > security reasons.
    >
    > The problem is that Excel is seen by Reader X to be a SECOND--and therefore
    > illegal--program attempting to access the PDF file at the same time as
    > Reader X (in violation of Protected Mode). So you need to disable Protected
    > Mode so Reader will allow other programs to work with the PDF at the same
    > time as Reader X.
    >
    >
    >
    > --
    > Tegger


    I have adobe reader xi and they moved this to Edit->Preferences->Security (Enhanced) under Sandbox Protections you can UNcheck "Enable Protected Mode" and the solution will work.
     
    , Jun 3, 2014
    #8
  9. Tegger

    Guest

    On Tuesday, June 3, 2014 8:25:44 AM UTC-6, wrote:
    > On Thursday, January 27, 2011 7:51:24 PM UTC-6, Tegger wrote:
    >
    > > Just posting this in case it helps somebody somewhere...

    >
    > >

    >
    > > Situation: Excel hangs for a couple of minutes, then errors with this

    >
    > > message:

    >
    > > "Microsoft Excel is waiting for another application to complete an OLE

    >
    > > action".

    >
    > >

    >
    > > Other Objects and Pictures can be inserted without problem.

    >
    > >

    >
    > > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as

    >
    > > well (but I only have AAP 9.4, so cannot check to be sure).

    >
    > >

    >
    > > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".

    >
    > > This must be disabled in order for Excel to be able to insert PDFs into a

    >
    > > spreadsheet.

    >
    > >

    >
    > > Disable "Protected Mode" this way:

    >
    > > Go to Edit > Preferences > General, then UNcheck the box that says

    >
    > > "Enable Protected Mode on Startup".

    >
    > >

    >
    > > Here's why: Excel cannot display an inserted PDF without asking the help of

    >
    > > an already-installed copy of Reader or Acrobat, or other PDF-reading

    >
    > > program. Reader X, by default, wants to corral the opened file all to

    >
    > > itself, not allowing any other program to play with it. This is done for

    >
    > > security reasons.

    >
    > >

    >
    > > The problem is that Excel is seen by Reader X to be a SECOND--and therefore

    >
    > > illegal--program attempting to access the PDF file at the same time as

    >
    > > Reader X (in violation of Protected Mode). So you need to disable Protected

    >
    > > Mode so Reader will allow other programs to work with the PDF at the same

    >
    > > time as Reader X.

    >
    > >

    >
    > >

    >
    > >

    >
    > > --

    >
    > > Tegger

    >
    >
    >
    > I have adobe reader xi and they moved this to Edit->Preferences->Security (Enhanced) under Sandbox Protections you can UNcheck "Enable Protected Mode" and the solution will work.



    Rudy- I also have the XI version and I did all of what you told me and it still isn't letting me insert pdf's into my excel documents. This didn't happen before the XI update.... SUPER frustrating as my job depends on this!

    Anything else I can try? I'm not very tech savvy, what about uninstalling the XI version and installing another one?

    HELP!!!
     
    , Aug 1, 2014
    #9
  10. Tegger

    Guest

    On Friday, August 1, 2014 9:05:56 PM UTC+5, wrote:
    > On Tuesday, June 3, 2014 8:25:44 AM UTC-6, wrote:
    >
    > > On Thursday, January 27, 2011 7:51:24 PM UTC-6, Tegger wrote:

    >
    > >

    >
    > > > Just posting this in case it helps somebody somewhere...

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > Situation: Excel hangs for a couple of minutes, then errors with this

    >
    > >

    >
    > > > message:

    >
    > >

    >
    > > > "Microsoft Excel is waiting for another application to complete an OLE

    >
    > >

    >
    > > > action".

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > Other Objects and Pictures can be inserted without problem.

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as

    >
    > >

    >
    > > > well (but I only have AAP 9.4, so cannot check to be sure).

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".

    >
    > >

    >
    > > > This must be disabled in order for Excel to be able to insert PDFs into a

    >
    > >

    >
    > > > spreadsheet.

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > Disable "Protected Mode" this way:

    >
    > >

    >
    > > > Go to Edit > Preferences > General, then UNcheck the box that says

    >
    > >

    >
    > > > "Enable Protected Mode on Startup".

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > Here's why: Excel cannot display an inserted PDF without asking the help of

    >
    > >

    >
    > > > an already-installed copy of Reader or Acrobat, or other PDF-reading

    >
    > >

    >
    > > > program. Reader X, by default, wants to corral the opened file all to

    >
    > >

    >
    > > > itself, not allowing any other program to play with it. This is done for

    >
    > >

    >
    > > > security reasons.

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > The problem is that Excel is seen by Reader X to be a SECOND--and therefore

    >
    > >

    >
    > > > illegal--program attempting to access the PDF file at the same time as

    >
    > >

    >
    > > > Reader X (in violation of Protected Mode). So you need to disable Protected

    >
    > >

    >
    > > > Mode so Reader will allow other programs to work with the PDF at the same

    >
    > >

    >
    > > > time as Reader X.

    >
    > >

    >
    > > >

    >
    > >

    >
    > > >

    >
    > >

    >
    > > >

    >
    > >

    >
    > > > --

    >
    > >

    >
    > > > Tegger

    >
    > >

    >
    > >

    >
    > >

    >
    > > I have adobe reader xi and they moved this to Edit->Preferences->Security (Enhanced) under Sandbox Protections you can UNcheck "Enable Protected Mode" and the solution will work.

    >
    >
    >
    >
    >
    > Rudy- I also have the XI version and I did all of what you told me and it still isn't letting me insert pdf's into my excel documents. This didn't happen before the XI update.... SUPER frustrating as my job depends on this!
    >
    >
    >
    > Anything else I can try? I'm not very tech savvy, what about uninstalling the XI version and installing another one?
    >
    >
    >
    > HELP!!!


    IT IS NOT WORKING WITH ME! I TRIED UNCHECKING THE BOX, THE ERROR STILL APPEARS, PLEASE HELP!
     
    , Aug 17, 2014
    #10
  11. Tegger

    Guest

    On Tuesday, June 3, 2014 7:25:44 AM UTC-7, wrote:
    > On Thursday, January 27, 2011 7:51:24 PM UTC-6, Tegger wrote:
    > > Just posting this in case it helps somebody somewhere...
    > >
    > > Situation: Excel hangs for a couple of minutes, then errors with this
    > > message:
    > > "Microsoft Excel is waiting for another application to complete an OLE
    > > action".
    > >
    > > Other Objects and Pictures can be inserted without problem.
    > >
    > > The problem seems to be Adobe Reader X, and possibly Adobe Acrobat Pro X as
    > > well (but I only have AAP 9.4, so cannot check to be sure).
    > >
    > > Adobe Reader X has a brand-new-to-Reader setting called "Protected Mode".
    > > This must be disabled in order for Excel to be able to insert PDFs into a
    > > spreadsheet.
    > >
    > > Disable "Protected Mode" this way:
    > > Go to Edit > Preferences > General, then UNcheck the box that says
    > > "Enable Protected Mode on Startup".
    > >
    > > Here's why: Excel cannot display an inserted PDF without asking the help of
    > > an already-installed copy of Reader or Acrobat, or other PDF-reading
    > > program. Reader X, by default, wants to corral the opened file all to
    > > itself, not allowing any other program to play with it. This is done for
    > > security reasons.
    > >
    > > The problem is that Excel is seen by Reader X to be a SECOND--and therefore
    > > illegal--program attempting to access the PDF file at the same time as
    > > Reader X (in violation of Protected Mode). So you need to disable Protected
    > > Mode so Reader will allow other programs to work with the PDF at the same
    > > time as Reader X.
    > >
    > >
    > >
    > > --
    > > Tegger

    >
    > I have adobe reader xi and they moved this to Edit->Preferences->Security (Enhanced) under Sandbox Protections you can UNcheck "Enable Protected Mode" and the solution will work.


    Thank you! I'm also working in XI and it's a bit different.
     
    , Oct 28, 2014
    #11
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Brian

    Export PDF information into Microsoft Excel

    Brian, Jan 5, 2004, in forum: Microsoft Excel Discussion
    Replies:
    1
    Views:
    298
    Peo Sjoblom
    Jan 5, 2004
  2. Chuck Reed
    Replies:
    1
    Views:
    494
    Dave Peterson
    May 3, 2004
  3. DOsser

    Excel to PDF produces multiple PDF's instead of one.

    DOsser, Mar 10, 2007, in forum: Microsoft Excel Discussion
    Replies:
    5
    Views:
    438
    DOsser
    Mar 14, 2007
  4. Lisa B.

    Insert PDF into Excel Cell?

    Lisa B., Mar 26, 2008, in forum: Microsoft Excel Discussion
    Replies:
    0
    Views:
    688
    Lisa B.
    Mar 26, 2008
  5. tlee
    Replies:
    20
    Views:
    5,631
Loading...

Share This Page