PC Review


Reply
Thread Tools Rating: Thread Rating: 3 votes, 5.00 average.

You must first enter a valid email address for this contact beforeOutlook can send mail to it

 
 
Brooks
Guest
Posts: n/a
 
      25th Nov 2007
Version: Outlook 2003

I imported an medium size address book from Thunderbird via a CSV
file. Whenever I choose new message to this contact, I get the error
as listed above:

You must first enter a valid email address for this contact before
Outlook can send mail to it

I have tried top open the record in question and then save, but I
still get this error. How can I resolve this, if possible?

Thanks, Brooks
 
Reply With Quote
 
 
 
 
Russ Valentine [MVP-Outlook]
Guest
Posts: n/a
 
      25th Nov 2007
Have you checked to see that you mapped your fields correctly and that the
email field for these Contacts contain a valid, resolved electronic address?
That error message tells you they do not.
--
Russ Valentine
[MVP-Outlook]
"Brooks" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Version: Outlook 2003
>
> I imported an medium size address book from Thunderbird via a CSV
> file. Whenever I choose new message to this contact, I get the error
> as listed above:
>
> You must first enter a valid email address for this contact before
> Outlook can send mail to it
>
> I have tried top open the record in question and then save, but I
> still get this error. How can I resolve this, if possible?
>
> Thanks, Brooks


 
Reply With Quote
 
 
 
 
Brooks
Guest
Posts: n/a
 
      25th Nov 2007
Russ:

I figured out a work around, the field indeed mapped to the email
address field.

What I have done that seems to resolve my issue is the following:

Open a contact.

Double click into the actual email address, which opens the email
properties.

I change or modify the internet format field, even just adjust it to
the default choice of "Let outlook decide the best sending format"

select OK.

Then the right click command for sending a new message to the contact
works like a charm. When they imported, the name must not be
associated with the email address.

Regards,
Brooks



On Nov 25, 5:16 pm, "Russ Valentine [MVP-Outlook]" <(E-Mail Removed)>
wrote:
> Have you checked to see that you mapped your fields correctly and that the
> email field for these Contacts contain a valid, resolved electronic address?
> That error message tells you they do not.
> --
> Russ Valentine
> [MVP-Outlook]"Brooks" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed)...
>
> > Version: Outlook 2003

>
> > I imported an medium size address book from Thunderbird via a CSV
> > file. Whenever I choose new message to this contact, I get the error
> > as listed above:

>
> > You must first enter a valid email address for this contact before
> > Outlook can send mail to it

>
> > I have tried top open the record in question and then save, but I
> > still get this error. How can I resolve this, if possible?

>
> > Thanks, Brooks


 
Reply With Quote
 
Russ Valentine [MVP-Outlook]
Guest
Posts: n/a
 
      26th Nov 2007
Importing never resolves the addresses. That was your problem.
--
Russ Valentine
[MVP-Outlook]
"Brooks" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Russ:
>
> I figured out a work around, the field indeed mapped to the email
> address field.
>
> What I have done that seems to resolve my issue is the following:
>
> Open a contact.
>
> Double click into the actual email address, which opens the email
> properties.
>
> I change or modify the internet format field, even just adjust it to
> the default choice of "Let outlook decide the best sending format"
>
> select OK.
>
> Then the right click command for sending a new message to the contact
> works like a charm. When they imported, the name must not be
> associated with the email address.
>
> Regards,
> Brooks
>
>
>
> On Nov 25, 5:16 pm, "Russ Valentine [MVP-Outlook]" <(E-Mail Removed)>
> wrote:
>> Have you checked to see that you mapped your fields correctly and that
>> the
>> email field for these Contacts contain a valid, resolved electronic
>> address?
>> That error message tells you they do not.
>> --
>> Russ Valentine
>> [MVP-Outlook]"Brooks" <(E-Mail Removed)> wrote in message
>>
>> news:(E-Mail Removed)...
>>
>> > Version: Outlook 2003

>>
>> > I imported an medium size address book from Thunderbird via a CSV
>> > file. Whenever I choose new message to this contact, I get the error
>> > as listed above:

>>
>> > You must first enter a valid email address for this contact before
>> > Outlook can send mail to it

>>
>> > I have tried top open the record in question and then save, but I
>> > still get this error. How can I resolve this, if possible?

>>
>> > Thanks, Brooks

>


 
Reply With Quote
 
Meg84
Guest
Posts: n/a
 
      20th Feb 2008
I am getting the same error from outlook. I have imported over 600 contacts
as I work for an organization with many members and cringe at the thought of
having to manually open each one and change email settings for this feature
to work. There must be a solution that can be applied en mass. Does anyone
have an answer?

"Russ Valentine [MVP-Outlook]" wrote:

> Importing never resolves the addresses. That was your problem.
> --
> Russ Valentine
> [MVP-Outlook]
> "Brooks" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Russ:
> >
> > I figured out a work around, the field indeed mapped to the email
> > address field.
> >
> > What I have done that seems to resolve my issue is the following:
> >
> > Open a contact.
> >
> > Double click into the actual email address, which opens the email
> > properties.
> >
> > I change or modify the internet format field, even just adjust it to
> > the default choice of "Let outlook decide the best sending format"
> >
> > select OK.
> >
> > Then the right click command for sending a new message to the contact
> > works like a charm. When they imported, the name must not be
> > associated with the email address.
> >
> > Regards,
> > Brooks
> >
> >
> >
> > On Nov 25, 5:16 pm, "Russ Valentine [MVP-Outlook]" <(E-Mail Removed)>
> > wrote:
> >> Have you checked to see that you mapped your fields correctly and that
> >> the
> >> email field for these Contacts contain a valid, resolved electronic
> >> address?
> >> That error message tells you they do not.
> >> --
> >> Russ Valentine
> >> [MVP-Outlook]"Brooks" <(E-Mail Removed)> wrote in message
> >>
> >> news:(E-Mail Removed)...
> >>
> >> > Version: Outlook 2003
> >>
> >> > I imported an medium size address book from Thunderbird via a CSV
> >> > file. Whenever I choose new message to this contact, I get the error
> >> > as listed above:
> >>
> >> > You must first enter a valid email address for this contact before
> >> > Outlook can send mail to it
> >>
> >> > I have tried top open the record in question and then save, but I
> >> > still get this error. How can I resolve this, if possible?
> >>
> >> > Thanks, Brooks

> >

>

 
Reply With Quote
 
New Member
Join Date: Aug 2010
Posts: 1
 
      12th Aug 2010
Hello

I was in the same boat with over 900 contacts to correct the issue in.

I could not find a workaround to process the email addresses, but i did know that opening a contact, adding a space to the email address, removing it, and then saving the contact would fix the issue for that contact.

So that's enter, tab 7 times, space, backspace, Control -S to save, and close the window, and down to the next record.

I just needed to do that 900+ times.

Enter: Autohotkey, the universal macro writing program.

http://www.autohotkey.com/

I installed the program, read up on the syntax and wrote a script.

^!o::
Loop 900 (or however many contacts are in the folder)
{
Send {enter}{tab 7}{Space}{Backspace}^s{Alt Down}{F4}{Alt Up}{Down}
}

And saved and compiled it.

The first line says run this when you press CTRL-ALT-O.
So I ran the macro writer, opened outook, went to the contact window, changed to mailing list view, and pressed CTRL-ALT-O.

The macro went through and took about 3 minutes to process all of the contacts.

-Noah

Quote:
Originally Posted by Meg84
I am getting the same error from outlook. I have imported over 600 contacts
as I work for an organization with many members and cringe at the thought of
having to manually open each one and change email settings for this feature
to work. There must be a solution that can be applied en mass. Does anyone
have an answer?

"Russ Valentine [MVP-Outlook]" wrote:

> Importing never resolves the addresses. That was your problem.
> --
> Russ Valentine
> [MVP-Outlook]
> "Brooks" wrote in message
> news:(E-Mail Removed)...
> > Russ:
> >
> > I figured out a work around, the field indeed mapped to the email
> > address field.
> >
> > What I have done that seems to resolve my issue is the following:
> >
> > Open a contact.
> >
> > Double click into the actual email address, which opens the email
> > properties.
> >
> > I change or modify the internet format field, even just adjust it to
> > the default choice of "Let outlook decide the best sending format"
> >
> > select OK.
> >
> > Then the right click command for sending a new message to the contact
> > works like a charm. When they imported, the name must not be
> > associated with the email address.
> >
> > Regards,
> > Brooks
> >
> >
> >
> > On Nov 25, 5:16 pm, "Russ Valentine [MVP-Outlook]"
> > wrote:
> >> Have you checked to see that you mapped your fields correctly and that
> >> the
> >> email field for these Contacts contain a valid, resolved electronic
> >> address?
> >> That error message tells you they do not.
> >> --
> >> Russ Valentine
> >> [MVP-Outlook]"Brooks" wrote in message
> >>
> >> news:(E-Mail Removed)...
> >>
> >> > Version: Outlook 2003
> >>
> >> > I imported an medium size address book from Thunderbird via a CSV
> >> > file. Whenever I choose new message to this contact, I get the error
> >> > as listed above:
> >>
> >> > You must first enter a valid email address for this contact before
> >> > Outlook can send mail to it
> >>
> >> > I have tried top open the record in question and then save, but I
> >> > still get this error. How can I resolve this, if possible?
> >>
> >> > Thanks, Brooks

> >

>
 
Reply With Quote
 
New Member
Join Date: Aug 2010
Posts: 1
 
      20th Aug 2010
Quote:
Originally Posted by upc_head
I was in the same boat with over 900 contacts to correct the issue in.
<snip>
I installed the program, read up on the syntax and wrote a script.
<snip>
The macro went through and took about 3 minutes to process all of the contacts.
One of my users had over 2000 contacts, most of which were imported from a csv file. (All from the csv file exhibited the symptoms exactly as described above.) I exported the entire contacts folder to Excel, created a new contacts folder and imported from the Excel file.

That worked great, so I deleted the original contacts folder (it was a subfolder anyway) and renamed the new folder the same as the old one.

Hope this helps someone.

- Eric

Last edited by IT_Juggler; 20th Aug 2010 at 09:02 PM.. Reason: clarity
 
Reply With Quote
 
New Member
Join Date: Nov 2011
Posts: 1
 
      16th Nov 2011
I solved the problem this way:

I imported again my data from Excel but this time, i spread the field "e-mail" and associated my e-mail data with "e-mail address" instead of just "e-mail".

Now it works
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can not send ot email 503 Valid RCPT command must precede DATA Tony357 Microsoft Outlook Discussion 1 23rd Jul 2008 12:04 PM
error message: "The profile is not valid. Enter a valid profile n =?Utf-8?B?Sm9obg==?= Microsoft Outlook Discussion 8 10th Aug 2007 03:44 AM
Set which local email account can send mail to contacts in address book. (associating an email address with a contact) Scott Streit Microsoft Outlook 3 27th Jan 2006 03:57 PM
Upon receipt of email, Outlook XP changes Contact Sender name to first Contact with the email address associated with the Contact name Paul Billings Microsoft Outlook Contacts 1 11th Nov 2004 11:10 AM
553 To send mail, first check your mail with a valid POP account; this prevent Andrew Microsoft Outlook Interoperability 1 8th Jul 2003 01:31 PM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 12:18 PM.