PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

VSS Shadow Copy Problems

 
 
=?Utf-8?B?R2FldG9y?=
Guest
Posts: n/a
 
      2nd May 2006
Win XP SP2
All Disks Formatted NTFS

The volume shadow functionality which previously worked on this system now
fails with the error:

Error returned while creating the volume shadow copy:8004230f
Reverting to non-shadow copy backup mode.

Initially there was a problem with the COM+ System Application service which
would not start, but after following the steps regarding fixing this in MS
KB: 315296 it now starts without errors.

However the Volume shadow copy error remains.
MS KB article 283085 - describes a very closly related if not the same issue
relating to the failure of the Shadow Copy but offers no guidelines or
suggestions, I have been watching this article since January hoping for it to
be updated but this has not happened.

Looking around Google I found a list of .Dlls to re-register in such cases
and the following were registered succesfully:

regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
Regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll

However attempts to run the following give errors ...

regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
failed. Return Code was: 0x8000ffff"

regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
DllRegister server entry point was not found. VSSAPI.DLL does not appear to
be a .DLL or .OCX file."

I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
didn't change the error returned from regsvr32.

I am *very keen* to get the shadow copy service oprerational again, help
will be appreciated.

Thanks.
 
Reply With Quote
 
 
 
 
Touch Base
Guest
Posts: n/a
 
      2nd May 2006

Have you got both
MS Software Shadow Copy Provider and
Volume Shadow Copy services set to at least manual under Services. If Not Volume shadow copy will fail.

"Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
| Win XP SP2
| All Disks Formatted NTFS
|
| The volume shadow functionality which previously worked on this system now
| fails with the error:
|
| Error returned while creating the volume shadow copy:8004230f
| Reverting to non-shadow copy backup mode.
|
| Initially there was a problem with the COM+ System Application service which
| would not start, but after following the steps regarding fixing this in MS
| KB: 315296 it now starts without errors.
|
| However the Volume shadow copy error remains.
| MS KB article 283085 - describes a very closly related if not the same issue
| relating to the failure of the Shadow Copy but offers no guidelines or
| suggestions, I have been watching this article since January hoping for it to
| be updated but this has not happened.
|
| Looking around Google I found a list of .Dlls to re-register in such cases
| and the following were registered succesfully:
|
| regsvr32 ole32.dll
| regsvr32 vss_ps.dll
| Vssvc /Register
| Regsvr32 /i eventcls.dll
| regsvr32 es.dll
| regsvr32 stdprov.dll
| regsvr32 msxml.dll
| regsvr32 msxml3.dll
|
| However attempts to run the following give errors ...
|
| regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
| failed. Return Code was: 0x8000ffff"
|
| regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
| DllRegister server entry point was not found. VSSAPI.DLL does not appear to
| be a .DLL or .OCX file."
|
| I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
| didn't change the error returned from regsvr32.
|
| I am *very keen* to get the shadow copy service oprerational again, help
| will be appreciated.
|
| Thanks.
 
Reply With Quote
 
 
 
 
=?Utf-8?B?R2FldG9y?=
Guest
Posts: n/a
 
      2nd May 2006
yes both of those are set to manual. The Volume Shadow Copy service starts
sucessfully via the services control panel applet, but MS Software Shadow
Copy Provider service will not start, initial error message is 1053 - "did
not respond to start request in a timely manner" correponding event log entry
is "Timeout (30000 milliseconds) waiting for the MS Software Shadow Copy
Provider service to connect."

"Touch Base" wrote:

>
> Have you got both
> MS Software Shadow Copy Provider and
> Volume Shadow Copy services set to at least manual under Services. If Not Volume shadow copy will fail.
>
> "Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> | Win XP SP2
> | All Disks Formatted NTFS
> |
> | The volume shadow functionality which previously worked on this system now
> | fails with the error:
> |
> | Error returned while creating the volume shadow copy:8004230f
> | Reverting to non-shadow copy backup mode.
> |
> | Initially there was a problem with the COM+ System Application service which
> | would not start, but after following the steps regarding fixing this in MS
> | KB: 315296 it now starts without errors.
> |
> | However the Volume shadow copy error remains.
> | MS KB article 283085 - describes a very closly related if not the same issue
> | relating to the failure of the Shadow Copy but offers no guidelines or
> | suggestions, I have been watching this article since January hoping for it to
> | be updated but this has not happened.
> |
> | Looking around Google I found a list of .Dlls to re-register in such cases
> | and the following were registered succesfully:
> |
> | regsvr32 ole32.dll
> | regsvr32 vss_ps.dll
> | Vssvc /Register
> | Regsvr32 /i eventcls.dll
> | regsvr32 es.dll
> | regsvr32 stdprov.dll
> | regsvr32 msxml.dll
> | regsvr32 msxml3.dll
> |
> | However attempts to run the following give errors ...
> |
> | regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
> | failed. Return Code was: 0x8000ffff"
> |
> | regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
> | DllRegister server entry point was not found. VSSAPI.DLL does not appear to
> | be a .DLL or .OCX file."
> |
> | I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
> | didn't change the error returned from regsvr32.
> |
> | I am *very keen* to get the shadow copy service oprerational again, help
> | will be appreciated.
> |
> | Thanks.
>

 
Reply With Quote
 
=?Utf-8?B?R2FldG9y?=
Guest
Posts: n/a
 
      2nd May 2006


"Gaetor" wrote:

> yes both of those are set to manual. The Volume Shadow Copy service starts
> sucessfully via the services control panel applet, but MS Software Shadow
> Copy Provider service will not start, initial error message is 1053 - "did
> not respond to start request in a timely manner" correponding event log entry
> is "Timeout (30000 milliseconds) waiting for the MS Software Shadow Copy
> Provider service to connect."


Also there is an event log entry when an attempt is made to backup which
reads:

Volume Shadow Copy Service error: Error creating the Shadow Copy Provider
COM class with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80040154].

>
> "Touch Base" wrote:
>
> >
> > Have you got both
> > MS Software Shadow Copy Provider and
> > Volume Shadow Copy services set to at least manual under Services. If Not Volume shadow copy will fail.
> >
> > "Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> > | Win XP SP2
> > | All Disks Formatted NTFS
> > |
> > | The volume shadow functionality which previously worked on this system now
> > | fails with the error:
> > |
> > | Error returned while creating the volume shadow copy:8004230f
> > | Reverting to non-shadow copy backup mode.
> > |
> > | Initially there was a problem with the COM+ System Application service which
> > | would not start, but after following the steps regarding fixing this in MS
> > | KB: 315296 it now starts without errors.
> > |
> > | However the Volume shadow copy error remains.
> > | MS KB article 283085 - describes a very closly related if not the same issue
> > | relating to the failure of the Shadow Copy but offers no guidelines or
> > | suggestions, I have been watching this article since January hoping for it to
> > | be updated but this has not happened.
> > |
> > | Looking around Google I found a list of .Dlls to re-register in such cases
> > | and the following were registered succesfully:
> > |
> > | regsvr32 ole32.dll
> > | regsvr32 vss_ps.dll
> > | Vssvc /Register
> > | Regsvr32 /i eventcls.dll
> > | regsvr32 es.dll
> > | regsvr32 stdprov.dll
> > | regsvr32 msxml.dll
> > | regsvr32 msxml3.dll
> > |
> > | However attempts to run the following give errors ...
> > |
> > | regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
> > | failed. Return Code was: 0x8000ffff"
> > |
> > | regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
> > | DllRegister server entry point was not found. VSSAPI.DLL does not appear to
> > | be a .DLL or .OCX file."
> > |
> > | I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
> > | didn't change the error returned from regsvr32.
> > |
> > | I am *very keen* to get the shadow copy service oprerational again, help
> > | will be appreciated.
> > |
> > | Thanks.
> >

 
Reply With Quote
 
Touch Base
Guest
Posts: n/a
 
      4th May 2006

"Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
| Win XP SP2
| All Disks Formatted NTFS
|
| The volume shadow functionality which previously worked on this system now
| fails with the error:
|
| Error returned while creating the volume shadow copy:8004230f
| Reverting to non-shadow copy backup mode.
|
| Initially there was a problem with the COM+ System Application service which
| would not start, but after following the steps regarding fixing this in MS
| KB: 315296 it now starts without errors.
|
| However the Volume shadow copy error remains.
| MS KB article 283085 - describes a very closly related if not the same issue
| relating to the failure of the Shadow Copy but offers no guidelines or
| suggestions, I have been watching this article since January hoping for it to
| be updated but this has not happened.
|
| Looking around Google I found a list of .Dlls to re-register in such cases
| and the following were registered succesfully:
|
| regsvr32 ole32.dll
| regsvr32 vss_ps.dll
| Vssvc /Register
| Regsvr32 /i eventcls.dll
| regsvr32 es.dll
| regsvr32 stdprov.dll
| regsvr32 msxml.dll
| regsvr32 msxml3.dll
|
| However attempts to run the following give errors ...
|
| regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
| failed. Return Code was: 0x8000ffff"
|
| regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
| DllRegister server entry point was not found. VSSAPI.DLL does not appear to
| be a .DLL or .OCX file."
|
| I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
| didn't change the error returned from regsvr32.
|
| I am *very keen* to get the shadow copy service oprerational again, help
| will be appreciated.
|
| Thanks.

==========================================================

Also make sure that Remote Procedure Call (RPC) and Removable Storage is set to automatic.
 
Reply With Quote
 
=?Utf-8?B?R2FldG9y?=
Guest
Posts: n/a
 
      4th May 2006
yes both are ... I suspect this has something to do with the Com+ subsystem
or possibly the .Net framework config, does anyone with more knowledge than
me on these subjects have any suggestions on the error message which mentions
CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and/or why the swprv.dll fails
to register?

"Touch Base" wrote:

>
> "Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> | Win XP SP2
> | All Disks Formatted NTFS
> |
> | The volume shadow functionality which previously worked on this system now
> | fails with the error:
> |
> | Error returned while creating the volume shadow copy:8004230f
> | Reverting to non-shadow copy backup mode.
> |
> | Initially there was a problem with the COM+ System Application service which
> | would not start, but after following the steps regarding fixing this in MS
> | KB: 315296 it now starts without errors.
> |
> | However the Volume shadow copy error remains.
> | MS KB article 283085 - describes a very closly related if not the same issue
> | relating to the failure of the Shadow Copy but offers no guidelines or
> | suggestions, I have been watching this article since January hoping for it to
> | be updated but this has not happened.
> |
> | Looking around Google I found a list of .Dlls to re-register in such cases
> | and the following were registered succesfully:
> |
> | regsvr32 ole32.dll
> | regsvr32 vss_ps.dll
> | Vssvc /Register
> | Regsvr32 /i eventcls.dll
> | regsvr32 es.dll
> | regsvr32 stdprov.dll
> | regsvr32 msxml.dll
> | regsvr32 msxml3.dll
> |
> | However attempts to run the following give errors ...
> |
> | regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
> | failed. Return Code was: 0x8000ffff"
> |
> | regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
> | DllRegister server entry point was not found. VSSAPI.DLL does not appear to
> | be a .DLL or .OCX file."
> |
> | I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
> | didn't change the error returned from regsvr32.
> |
> | I am *very keen* to get the shadow copy service oprerational again, help
> | will be appreciated.
> |
> | Thanks.
>
> ==========================================================
>
> Also make sure that Remote Procedure Call (RPC) and Removable Storage is set to automatic.
>

 
Reply With Quote
 
Touch Base
Guest
Posts: n/a
 
      5th May 2006

"Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
| Win XP SP2
| All Disks Formatted NTFS
|
| The volume shadow functionality which previously worked on this system now
| fails with the error:
|
| Error returned while creating the volume shadow copy:8004230f
| Reverting to non-shadow copy backup mode.
|
<snip>

Have a look here and see if any of this data is relevant to the situation:

Volume Shadow Copy Error
http://www.backupassist.com/Knowledg...lumeShadowCopy

Good luck
--

(A)bort, (R)etry, (P)retend this never happened
--
Touch Base
Post back here on the result- good or bad


 
Reply With Quote
 
bricenott
Guest
Posts: n/a
 
      7th May 2006
Hi there Guys,

Sorry to interrupt, but I have to say I have a similar problem that
craking my head. I get this same errors below discribed by Gaetor
"Volume Shadow Copy Service error: Error creating the Shadow Copy
Provider COM class with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a}
[0x80040154].", but also, I just realize that get this whitout even
trying to make a backup, also I get an error when I cmd "vssadmin list
shadows" with error 0x8000ffff, the writers cmd sais all stable... I
began to check on this because I'm trying to make a backup with norton
ghost 10, from one drive to another 80 gb both with the copy drive
feature, the errors I get with ghost are
5/7/2006 7:15:20 AM High Priority Error: Error EC8F17B3: Cannot
complete copying of SYSTEM (C:\) drive. 0xEBAB0005 (Norton Ghost)
5/7/2006 9:06:14 AM High Priority Error: Error EC8F17B3: Cannot
complete copying of SYSTEM (C:\) drive. 0xEBAB0005 (Norton Ghost)

Can you help me please ???


Gaetor ha escrito:

> yes both of those are set to manual. The Volume Shadow Copy service starts
> sucessfully via the services control panel applet, but MS Software Shadow
> Copy Provider service will not start, initial error message is 1053 - "did
> not respond to start request in a timely manner" correponding event log entry
> is "Timeout (30000 milliseconds) waiting for the MS Software Shadow Copy
> Provider service to connect."
>
> "Touch Base" wrote:
>
> >
> > Have you got both
> > MS Software Shadow Copy Provider and
> > Volume Shadow Copy services set to at least manual under Services. If Not Volume shadow copy will fail.
> >
> > "Gaetor" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> > | Win XP SP2
> > | All Disks Formatted NTFS
> > |
> > | The volume shadow functionality which previously worked on this system now
> > | fails with the error:
> > |
> > | Error returned while creating the volume shadow copy:8004230f
> > | Reverting to non-shadow copy backup mode.
> > |
> > | Initially there was a problem with the COM+ System Application service which
> > | would not start, but after following the steps regarding fixing this in MS
> > | KB: 315296 it now starts without errors.
> > |
> > | However the Volume shadow copy error remains.
> > | MS KB article 283085 - describes a very closly related if not the same issue
> > | relating to the failure of the Shadow Copy but offers no guidelines or
> > | suggestions, I have been watching this article since January hoping for it to
> > | be updated but this has not happened.
> > |
> > | Looking around Google I found a list of .Dlls to re-register in such cases
> > | and the following were registered succesfully:
> > |
> > | regsvr32 ole32.dll
> > | regsvr32 vss_ps.dll
> > | Vssvc /Register
> > | Regsvr32 /i eventcls.dll
> > | regsvr32 es.dll
> > | regsvr32 stdprov.dll
> > | regsvr32 msxml.dll
> > | regsvr32 msxml3.dll
> > |
> > | However attempts to run the following give errors ...
> > |
> > | regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
> > | failed. Return Code was: 0x8000ffff"
> > |
> > | regsvr32 VSSAPI.DLL returns the error VSSAPI.DLL was loaded, but the
> > | DllRegister server entry point was not found. VSSAPI.DLL does not appear to
> > | be a .DLL or .OCX file."
> > |
> > | I replaced VSSAPI.DLL with a clean copy in case it had corrupted, but this
> > | didn't change the error returned from regsvr32.
> > |
> > | I am *very keen* to get the shadow copy service oprerational again, help
> > | will be appreciated.
> > |
> > | Thanks.
> >


 
Reply With Quote
 
New Member
Join Date: Feb 2009
Posts: 1
 
      5th Feb 2009
The problem is the MBR doesn't match from the original image.

Download mbrfix
MbrFix /drive 0 listpartitions

MbrFix /drive 0 generatesignature
Reboot twice
 
Reply With Quote
 
New Member
Join Date: Jun 2010
Posts: 1
 
      18th Jun 2010
Follow these steps:
http://support.microsoft.com/kb/940032
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A comparison among six VSS remote tools including SourceOffSite , SourceAnyWhere, VSS Connect, SourceXT, VSS Remoting, VSS.NET mayamorning123@yahoo.com Microsoft C# .NET 2 25th Aug 2005 03:45 AM
A comparison among six VSS remote tools including SourceOffSite , SourceAnyWhere, VSS Connect, SourceXT, VSS Remoting, VSS.NET mayamorning123@yahoo.com Windows XP Work Remotely 0 24th Aug 2005 08:43 AM
A comparison among six VSS remote tools including SourceOffSite , SourceAnyWhere, VSS Connect, SourceXT, VSS Remoting, VSS.NET mayamorning123@yahoo.com Microsoft ASP .NET 0 24th Aug 2005 03:50 AM
A comparison among six VSS remote tools including SourceOffSite , SourceAnyWhere, VSS Connect, SourceXT, VSS Remoting, VSS.NET mayamorning123@yahoo.com Microsoft Dot NET 0 23rd Aug 2005 08:35 AM
Re: VSS Shadow Copy Error and Damaged Com+ Catalog Adi Oltean [MSFT] Windows XP Performance 1 30th Jun 2004 12:50 PM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 03:27 PM.