PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

System.Net.Mail.SmtpClient Send method causing an Application popup in IIS ???

 
 
ticketdirector@gmail.com
Guest
Posts: n/a
 
      24th Apr 2006
Hi,

In the event viewer on our production web server (win2k3), I am seeing
that if a call to the System.Net.Mail.SmtpClient.Send() function fails
/ throws an exception, it is popping up an assertion failure message
box. But since this is a remote server, there is no logged in user, so
the assertion failure message box is just sitting there waiting forever
for someone to come along and hit "OK" button. This is causing problems
on the server.

We have this call in a try/catch, so I can't understand why assertion
failires or exceptions are not caught. Why is this call causing an
application assertion failure popup message that can never be seen? Is
there a way to fix this?

thanks for any help.

Roy.

 
Reply With Quote
 
 
 
 
=?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=
Guest
Posts: n/a
 
      25th Apr 2006
Sounds like you may want to check your JIT debugger settings in the Registry.
Sorry don't have a link handy. Also, make sure debug=false in the web.config.
Peter
--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com




"(E-Mail Removed)" wrote:

> Hi,
>
> In the event viewer on our production web server (win2k3), I am seeing
> that if a call to the System.Net.Mail.SmtpClient.Send() function fails
> / throws an exception, it is popping up an assertion failure message
> box. But since this is a remote server, there is no logged in user, so
> the assertion failure message box is just sitting there waiting forever
> for someone to come along and hit "OK" button. This is causing problems
> on the server.
>
> We have this call in a try/catch, so I can't understand why assertion
> failires or exceptions are not caught. Why is this call causing an
> application assertion failure popup message that can never be seen? Is
> there a way to fix this?
>
> thanks for any help.
>
> Roy.
>
>

 
Reply With Quote
 
 
 
 
ticketdirector@gmail.com
Guest
Posts: n/a
 
      25th Apr 2006
Peter,

thanks for your response. I checked my web.config and debug is set to
false. I did some searching on google for the proper reg key to modify
to disable this behavior, but was unsuccessful. Aside from needing to
figure out how to fix this, I'd love to also know *why* it's happening.
All other exceptions thrown in my web app get caught by exception
handlers except this one.

: (

 
Reply With Quote
 
hazz
Guest
Posts: n/a
 
      25th Apr 2006
There is some unmanaged code stuff going on at the lower levels. My
experience with smtp and the .net controls led me to test locally and I had
to use devmail.net's product to get my sends to work. Even with a detail
trace on what was going on at the port level, I never could sort out my
issue. -greg

<(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Peter,
>
> thanks for your response. I checked my web.config and debug is set to
> false. I did some searching on google for the proper reg key to modify
> to disable this behavior, but was unsuccessful. Aside from needing to
> figure out how to fix this, I'd love to also know *why* it's happening.
> All other exceptions thrown in my web app get caught by exception
> handlers except this one.
>
> : (
>



 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MSXML 4 error: This method cannot be called after the send method. =?Utf-8?B?UGhpbF9N?= Windows XP General 0 10th Aug 2007 04:30 PM
Deploying IIS 6.0 Application To IIS 5.0 Box.... Tam OShanter Microsoft ADO .NET 1 14th Jul 2005 06:33 PM
Epson R300M - using non-epson cartridges causing popup before printing Te Printers 0 14th Jan 2005 02:30 AM
validator causing password prompt to popup =?Utf-8?B?SnVzdGlu?= Microsoft ASP .NET 1 9th Oct 2004 04:37 AM
ASP.NET application works in IIS PWS, but not in remote IIS. Matthew Louden Microsoft ASP .NET 3 7th Nov 2003 10:58 PM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 04:31 AM.