PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

System.Data.OleDb.OleDbException: Parameter ?_1 has no default value

 
 
silesius
Guest
Posts: n/a
 
      16th Nov 2004
I've been using VS 2003 to develop a webapplication using C#. Today I
exported the application to a remote webserver I begun experiencing
problems.
It's a simple application that retrieves some information from an Access
database. It worked fine when I ran on my computer. I use a parameterized
query to retrieve some customer specific information. Customer logs in, I
store the username they log in with in the session state and on the
following page use it in my parameterized query to retrieve customers info.
I'm using a data adapter with a dataset. Anyway, since I moved the
application to the remote server I started getting the following error after
logging in, but not all the time, sometimes it works fine. I'm relatively
new to ASP.NET and would appreciate it if someone could point me in the
right direction. TIA

Parameter ?_1 has no default value.
Description: An unhandled exception occurred during the execution of the
current web request. Please review the stack trace for more information
about the error and where it originated in the code.

Exception Details: System.Data.OleDb.OleDbException: Parameter ?_1 has no
default value.

Source Error:

An unhandled exception was generated during the execution of the current web
request. Information regarding the origin and location of the exception can
be identified using the exception stack trace below.

Stack Trace:

[OleDbException (0x80040e10): Parameter ?_1 has no default value.]
System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(Int32 hr)
+41
System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS
dbParams, Object& executeResult) +174
System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult)
+92
System.Data.OleDb.OleDbCommand.ExecuteCommand(CommandBehavior behavior,
Object& executeResult) +65
System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior
behavior, String method) +112
System.Data.OleDb.OleDbCommand.ExecuteReader(CommandBehavior behavior)
+69
System.Data.OleDb.OleDbCommand.System.Data.IDbCommand.ExecuteReader(CommandBehavior
behavior) +5
System.Data.Common.DbDataAdapter.FillFromCommand(Object data, Int32
startRecord, Int32 maxRecords, String srcTable, IDbCommand command,
CommandBehavior behavior) +304
System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord,
Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior
behavior) +77
System.Data.Common.DbDataAdapter.Fill(DataSet dataSet) +38
MaxCustInfo.WebForm1.Page_Load(Object sender, EventArgs e) in
c:\documents and
settings\richard\vswebcache\http://www.bielmax.com\maccustinfo\c...orm.aspx.cs:74
System.Web.UI.Control.OnLoad(EventArgs e) +67
System.Web.UI.Control.LoadRecursive() +35
System.Web.UI.Page.ProcessRequestMain() +750


 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parameter ?_1 has no default value Thanasis \(sch\) Microsoft Frontpage 0 15th Jan 2005 01:45 PM
error STOP:0x0000007B (parameter, parameter, parameter, parameter) robert35 Microsoft Access Getting Started 1 15th Dec 2004 04:28 PM
Error: Parameter @Abstract has no default value jeff Microsoft ADO .NET 2 9th Apr 2004 07:12 AM
Error: Parameter @Abstract has no default value jeff Microsoft Dot NET Framework 0 5th Dec 2003 10:25 PM
Parameter 1_? has no default value Nurul Hassan Microsoft ADO .NET 0 19th Nov 2003 08:00 AM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 03:31 PM.