PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

Set English UK as default spell check language

 
 
Jessie Leung
Guest
Posts: n/a
 
      11th Jun 2009
I am using Microsoft office 2007. But I find it impossible to set English
(UK) as the default spell check language. It keeps boucing back to English
(US).
I tired to follow http://homepage.swissonline.ch/cindymeister/LangFmt.htm
but it didn't work for Microsoft 2007.

It has been a very disturbing issue as our company requires us to write in
English (UK). Anyone know how to solve this problem? Many thanks.
 
Reply With Quote
 
 
 
 
Graham Mayor
Guest
Posts: n/a
 
      11th Jun 2009
If from Windows regional settings you delete the US English option and
configure as English UK; and you turn off the automatically detect language
option from Review > Set Language, English UK should hold for typed text.
Inserted text will still adopt the language in which it was formatted.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>


Jessie Leung wrote:
> I am using Microsoft office 2007. But I find it impossible to set
> English (UK) as the default spell check language. It keeps boucing
> back to English (US).
> I tired to follow
> http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it didn't
> work for Microsoft 2007.
>
> It has been a very disturbing issue as our company requires us to
> write in English (UK). Anyone know how to solve this problem? Many
> thanks.



 
Reply With Quote
 
 
 
 
Jessie Leung
Guest
Posts: n/a
 
      11th Jun 2009
I already set windows regional as Eng UK. I also set Eng UK as custom
dictionary for spell check but still it doesn't work. :-(

"Graham Mayor" wrote:

> If from Windows regional settings you delete the US English option and
> configure as English UK; and you turn off the automatically detect language
> option from Review > Set Language, English UK should hold for typed text.
> Inserted text will still adopt the language in which it was formatted.
>
> --
> <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
> Graham Mayor - Word MVP
>
> My web site www.gmayor.com
> Word MVP web site http://word.mvps.org
> <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
>
>
> Jessie Leung wrote:
> > I am using Microsoft office 2007. But I find it impossible to set
> > English (UK) as the default spell check language. It keeps boucing
> > back to English (US).
> > I tired to follow
> > http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it didn't
> > work for Microsoft 2007.
> >
> > It has been a very disturbing issue as our company requires us to
> > write in English (UK). Anyone know how to solve this problem? Many
> > thanks.

>
>
>

 
Reply With Quote
 
DeanH
Guest
Posts: n/a
 
      11th Jun 2009
Have you checked the language assigned to the dictionary, i.e. Tools,
Options, Spelling & Grammar, Custom Dictionaries, Modify. Do you see English
UK, US, or All Languages?
Also have you checked all your styles and templates, that none of these have
English (US) in their settings?
If this is all OK, then the only thing I can think that is causing the
conflict is the Language Registry Code, which is set upon install. Sometime
ago I had a spurious French (France) appearing (just like your English US)
and it turned out that because my new build (going from Word 2000 on 2000 to
Word2003 on XP) was done in-house and the disks were bought in France (I work
for a French company – stop… don't turn-off), and even though the IT chappie
did the build in English and told everything to be in English, the default
language was French! So the only remedy was to go into the Registry and
change the Language code to English (UK), which has solved my problems of
both French and US.

English (UK) code is 2057 (LCID Dec) but please check on:
http://www.microsoft.com/globaldev/r.../lcid-all.mspx
Where this is changed I am not entirely sure, maybe someone else on the
Newsgroup will chip in here with the correct procedure for Registry changes.

Please remember that if the document is distributed to others that may have
EN US as their language, you may/will get occurances of this language in your
document.

All of the above is for 2003 and prior, instructions may differ for 2007.

Hope this helps
DeanH

"Jessie Leung" wrote:

> I already set windows regional as Eng UK. I also set Eng UK as custom
> dictionary for spell check but still it doesn't work. :-(
>
> "Graham Mayor" wrote:
>
> > If from Windows regional settings you delete the US English option and
> > configure as English UK; and you turn off the automatically detect language
> > option from Review > Set Language, English UK should hold for typed text.
> > Inserted text will still adopt the language in which it was formatted.
> >
> > --
> > <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
> > Graham Mayor - Word MVP
> >
> > My web site www.gmayor.com
> > Word MVP web site http://word.mvps.org
> > <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
> >
> >
> > Jessie Leung wrote:
> > > I am using Microsoft office 2007. But I find it impossible to set
> > > English (UK) as the default spell check language. It keeps boucing
> > > back to English (US).
> > > I tired to follow
> > > http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it didn't
> > > work for Microsoft 2007.
> > >
> > > It has been a very disturbing issue as our company requires us to
> > > write in English (UK). Anyone know how to solve this problem? Many
> > > thanks.

> >
> >
> >

 
Reply With Quote
 
Graham Mayor
Guest
Posts: n/a
 
      11th Jun 2009
The proofing language is a paragraph formatting attribute. The default is
set according to the Windows regional settings. Check that the normal
paragraph style has the proofing option set to English UK.

You need to set the language associated with the text and as I suggested
earlier you need to turn off the automatically detect language option.

See also See http://sbarnhill.mvps.org/WordFAQs/MasterSpellCheck.htm
--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com
Word MVP web site http://word.mvps.org
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>

Jessie Leung wrote:
> I already set windows regional as Eng UK. I also set Eng UK as custom
> dictionary for spell check but still it doesn't work. :-(
>
> "Graham Mayor" wrote:
>
>> If from Windows regional settings you delete the US English option
>> and configure as English UK; and you turn off the automatically
>> detect language option from Review > Set Language, English UK should
>> hold for typed text. Inserted text will still adopt the language in
>> which it was formatted.
>>
>> --
>> <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
>> Graham Mayor - Word MVP
>>
>> My web site www.gmayor.com
>> Word MVP web site http://word.mvps.org
>> <>>< ><<> ><<> <>>< ><<> <>>< <>><<>
>>
>>
>> Jessie Leung wrote:
>>> I am using Microsoft office 2007. But I find it impossible to set
>>> English (UK) as the default spell check language. It keeps boucing
>>> back to English (US).
>>> I tired to follow
>>> http://homepage.swissonline.ch/cindymeister/LangFmt.htm but it
>>> didn't work for Microsoft 2007.
>>>
>>> It has been a very disturbing issue as our company requires us to
>>> write in English (UK). Anyone know how to solve this problem? Many
>>> thanks.



 
Reply With Quote
 
New Member
Join Date: Jan 2010
Posts: 1
 
      7th Jan 2010
I am running Office 2007 under Windows 7.

As I understand it having read the various help files and the posts in this and another forum, the default language is now controlled by the regional setting in the operating system. But that also defines the keyboard layout.

So I can have UK English if I have a UK keyboard.
But I cannot find any way to select a US keyboard while still wishing to use UK spelling.

Am I mistaken?

The symptoms I observe seem to be worse than that in fact. I can change my language in the Language bar to be UK English then create a Word document and it will be checked for UK spelling. Fine.
But as soon as I quit Word, the Language Bar insists on reverting to US English.

Any suggestions?
(Or do I have to get used to pretending I have a UK keyboard and therefore mistyping the @ (") sign frequently?)
 
Reply With Quote
 
WJR WJR is offline
New Member
Join Date: Feb 2010
Posts: 1
 
      1st Feb 2010
Just found out myself after much searching.

http://office.microsoft.com/en-us/he...514161033.aspx

"Step-by-step: Preparing your computer to type and edit text in another language"
 
Reply With Quote
 
New Member
Join Date: Jun 2010
Posts: 1
 
      10th Jun 2010
Hi everyone! this is my first post in this forum.

I have the same issue and the solution is to set the "system locale" to English (Singapore).

I am from Singapore, we study UK english but use US keyboard.

cheers! : D
 
Reply With Quote
 
New Member
Join Date: Dec 2012
Posts: 1
 
      14th Dec 2012
hi all,

work for a multilingual company and my OS is set to German and i have to write in both German and English.

The reason i found this thread (and decided now ther is no solution): I started a PPT in English without changing my default language to English.

I wanted to ask: Can I afterwards change the spell checking language for all text in the PPT to English? and the answer is: No, PowerPoint will always revert back to the language it was started in even if you delete the German spell checker, even if you change your reginal settings and even if you change your keyboard layout to Engliush, it still doesnt work.

Why would it? It's not like this is modern technology... its not like this problem is 15 years old and still not fixed. (sarcasm off)

piece of ***** software


PS: Office 2010

Last edited by Marmit3; 14th Dec 2012 at 06:26 PM..
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Spell Check states no longer offered for this language. Does anyone know how I can get spell check? Bruce Hagen Windows Vista Mail 0 21st Jul 2010 03:38 AM
why does spell check revert from English UK to English US =?Utf-8?B?c3VlNDQxNw==?= Microsoft Word Document Management 2 10th Feb 2007 12:44 AM
Outlook spell checker default ENGLISH (UK) checks in ENGLISH (US) =?Utf-8?B?QUUyMDA1?= Microsoft Outlook Discussion 0 12th Sep 2005 01:46 PM
How do I change spell/grammar check from US English to UK English. =?Utf-8?B?Vi4=?= Microsoft Word New Users 1 26th Feb 2005 08:30 PM
How do I use English spell check in a outlook if non -English keyb =?Utf-8?B?VklLVE9S?= Microsoft Outlook Discussion 0 4th Jan 2005 09:15 AM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 12:17 AM.