PC Review


Reply
Thread Tools Rate Thread

Help - After SP 4 on W2K - Print Jobs say "Printing" on HP 1000 printer, but never print. Must restart spooler to print.

 
 
John
Guest
Posts: n/a
 
      16th Dec 2003
Hi folks,

I'm having an odd problem. Judging from the group I'm not the only one
with printer problems after service pack 4.

I had a client PC running Windows 2000 Professional. It was on service
pack 2 and printer just find. After I upgraded it to Service Pack 4 I have
a problem where print jobs say they are printing, but they are not. The
spooler service must be restarted for the print job to print.

Here some more details:

These are small print jobs, 1.5K or so.
The jobs cannot be cancelled. Only stoping and restarting the spooler
service fixes it.
The printer is a HP 1000 - USB.
The are printing using an old DOS app.
If it prints, it can print dozens of pages without a problem.
It's always the first print in a while that does it. It never happens in
the middle.
Almost always after a restart the first print job will hang.
I've updated the USB host drivers to the lastest version on HP Web site.
I've updated the Print drivers.
I've uninstalled everything, and reinstalled everything related to the HP
printer.

Any ideas? I'm pretty much out of ideas....

John Riggle
MCSE
MCT
MCP since 1996.
 
Reply With Quote
 
 
 
 
byte_me73119
Guest
Posts: n/a
 
      9th Jan 2004

I'm having a very simular problem. I have Windows Service that I wrot
in Visual Basic, this service creates PDF files using a Print Drive
and since upgrading to SP4 it has failed to work. All print job
created by the service just hang. If I run the program manually i
works fine. (One exception, my print functions are in an ActiveX DLL
wrote and if this is registered through MTS (Component Services) th
manual methods fails as well).
Anyway, I believe it is something to do with some security changes wit
sp4, but I haven't been able to pinpoint or corect it as of yet.

I would be gratefull for any help

byte_me7311
-----------------------------------------------------------------------
Posted via http://www.mcse.m
-----------------------------------------------------------------------
View this thread: http://www.mcse.ms/message187877.htm

 
Reply With Quote
 
 
 
 
Brian Smither
Guest
Posts: n/a
 
      11th Jan 2004
byte_me73119 <(E-Mail Removed)> wrote in
news:(E-Mail Removed):

> I have Windows Service that I wrote
> in Visual Basic, this service creates PDF files using a Print Driver
> and since upgrading to SP4 it has failed to work. All print jobs
> created by the service just hang.


I have no real solution for you. My experience:

When jobs came in to the print server, they then just disappeared without
printing. The cause was that the owner of the print job (a 'regular' user
on the LAN) did not have (NTFS) permission to create files in the %system%
\spool\printers directory.

*However*, everyone on the LAN is running W2KSP2. So for your problem, I
cannot help other than to ask, "Are you running NTFS and have you given
your service/application permissions?"



--
Remove INVALID from e-mail address.
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 10:22 PM.