PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

Error - Windows Installer not correctly installed

 
 
John
Guest
Posts: n/a
 
      10th Nov 2003
Any programs and applications that needs Windows Installer
will not run. Message reads: "The Windows Installer
Service could not be accessed. This can occur if running
Windows in safe mode, or if the Windows Installer is nt
correctly installed. Contact your support personnel for
assistance." First answer to that is "No I'm not running
in safe mode" and I try to reinstall "msiexec.exe" and
message say's "The specified service already exists". In
Administrative Services, Services, properties of Windows
Installer I try starting and message reads " Could not
start the Windows Installer service on local computer. The
service did not return an error. This could be an internal
Windows error or an internal service error.
If the problem persists,contact your system administrator".
I'll try any cure but don't really what to reinstall
Windows if possible. Thanks, John
 
Reply With Quote
 
 
 
 
Stefan Krueger [MVP]
Guest
Posts: n/a
 
      10th Nov 2003
Please try the steps described here:
http://www.msifaq.com/error/1719.htm


--
Stefan Krueger
Microsoft Windows Installer MVP

Please post your questions in the newsgroup or vist one of these web sites:

Windows Installer FAQ
http://www.msifaq.com - http://www.msifaq.de

InstallSite - Resources for Setup Developers
http://www.installsite.org
http://www.installsite.de (GERMAN)

"John" <(E-Mail Removed)> schrieb im Newsbeitrag
news:02b101c3a71d$b2e86250$(E-Mail Removed)...
> Any programs and applications that needs Windows Installer
> will not run. Message reads: "The Windows Installer
> Service could not be accessed. This can occur if running
> Windows in safe mode, or if the Windows Installer is nt
> correctly installed. Contact your support personnel for
> assistance." First answer to that is "No I'm not running
> in safe mode" and I try to reinstall "msiexec.exe" and
> message say's "The specified service already exists". In
> Administrative Services, Services, properties of Windows
> Installer I try starting and message reads " Could not
> start the Windows Installer service on local computer. The
> service did not return an error. This could be an internal
> Windows error or an internal service error.
> If the problem persists,contact your system administrator".
> I'll try any cure but don't really what to reinstall
> Windows if possible. Thanks, John



 
Reply With Quote
 
 
 
 
Torgeir Bakken (MVP)
Guest
Posts: n/a
 
      10th Nov 2003
John wrote:

> Any programs and applications that needs Windows Installer
> will not run. Message reads: "The Windows Installer
> Service could not be accessed. This can occur if running
> Windows in safe mode, or if the Windows Installer is nt
> correctly installed. Contact your support personnel for
> assistance." First answer to that is "No I'm not running
> in safe mode" and I try to reinstall "msiexec.exe" and
> message say's "The specified service already exists". In
> Administrative Services, Services, properties of Windows
> Installer I try starting and message reads " Could not
> start the Windows Installer service on local computer. The
> service did not return an error. This could be an internal
> Windows error or an internal service error.
> If the problem persists,contact your system administrator".
> I'll try any cure but don't really what to reinstall


Hi

For Windows 2000:
http://groups.google.com/groups?selm...B8%40hydro.com

For Windows XP:
http://groups.google.com/groups?selm...51%40hydro.com


--
torgeir
Microsoft MVP Scripting and WMI, Porsgrunn Norway
Administration scripting examples and an ONLINE version of the 1328 page
Scripting Guide: http://www.microsoft.com/technet/scriptcenter


 
Reply With Quote
 
Jim Leach
Guest
Posts: n/a
 
      11th Nov 2003
I too have had this problem after playing with COM.

Do you have OfficeXP - If so, this is my solution..

Delete the registry key in
HKEY_CLASSES_ROOT \ Installer \ Products
that matches the same folder namer in
..\WINNT\Installer\
that contains the OfficeXP files.

In my case (I don't know if this will be the same for
other installations the CLSID was {91110409-6000-11D3-8CFE-
0050048383C9}

Thus both the registry key and folder {91110409-6000-11D3-
8CFE-0050048383C9} were deleted from the Installer
key/folder.

Then Reinstall OfficeXP from the CD. Your Office settings
are kept, and it would seem that so are any Service Packs,
but you will need to reinstall Service Packs as Office
Update won't see them.
 
Reply With Quote
 
New Member
Join Date: Oct 2007
Posts: 1
 
      14th Oct 2007
Hi
i had same problem but fortuanately i found the solution.
The solution described in the microsoft is not working and i emailed them this new solution.
There is problem with your installscript engine.
http://www.installsite.org/pages/en/msifaq/a/1027.htm
 
Reply With Quote
 
New Member
Join Date: Feb 2008
Posts: 2
 
      8th Feb 2008
Hello Guys ,
I' m a newbe here and hope that my modest experience can eventually be of any help to anyone.
The solution described in Microsoft was , just like for ufo973 ( hello there ! ) a complete flop .
The solution in my case was very simple but will only work if one is in possession of a Windows installation cdrom ( XP or VISTA ) .
Start the cdrom and select exclusively the "Windows upgrade " option .This is important , otherwhise you could loose all contents of your previous system . Now , Windows cares for the rest and that' s all folks . In my case , my system is now up to date and Windows Installer has fully recovered .
 
Reply With Quote
 
New Member
Join Date: Feb 2008
Posts: 2
 
      10th Feb 2008
Ok ok ... It sometimes can happen that after having repaired Windows Installer , a new issue appears with the Updates Installer ! Replay then your Windows cdrom and select " reinstall Windows / repair " . This should doe the trick , it worked in my situation anyway ...
 
Reply With Quote
 
New Member
Join Date: Mar 2006
Posts: 2
 
      21st Jul 2008
Hi,
I'm having the errors on a windows ME system.
I wish to install dontnetfix and it tells me
"Setup has detected that the following prerequisite programs are not installed
Microsoft Windows Installer 2.0
You must first install these programs before ?Microsoft .net framework 2.0 can be installed"
BUT
I try to install Microsoft Windows Installer 2.0 and get this error
"The specified service already exists"
how can I fix or work around this ?
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows Installer not installed correctly Bob Microsoft Windows 2000 Setup 0 6th Jul 2004 06:18 AM
windows installer not installed correctly or in safe mode? Highlandish Windows XP General 1 7th May 2004 11:38 AM
Windows Installer not Correctly Installed/MSIEXEC.EXE was missing... Jeff N. Windows XP General 16 9th Feb 2004 08:45 AM
Windows installer not correctly installed Jeffcorr Windows XP General 0 9th Oct 2003 04:33 PM
Windows Installer Sevice not correctly installed or missing. Landy Atkinson Microsoft Windows 2000 Upgrade 0 16th Sep 2003 07:13 PM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 06:01 AM.