PC Review


Reply
Thread Tools Rate Thread

Device Got Stuck In An Infinite Loop Blue Screen error researchedon NGOHQ.com

 
 
FH
Guest
Posts: n/a
 
      14th Jan 2008
This was one of the threads I found on ngohq forums - all credis go to
the author, some people will probably benefit from this info as did I...

""
Hi there:

I'm very happy and I want to share my experience fixing the random
reboot while playing games.
The BSOD related to the "ati3duag.dll". I have to say for sure, I've
finally fixed it, and I want to share the "more official" solution to
the problem. (At least official for me). I really want you to read this,
even if it's long because you will find answers to many common problems.

I want to document the problem and I will cover all the bases because
I'm sure it will help every ATI RADEON user.

My Former System:
Case Antec P150
ASUS P5W DH Deluxe
HIS ATI X1900XTX IceQ3
PSU Seasonic S12 500W
4GB Corsair Dual Channel 4 Sticks of 1GB each (DDR2-800)
Sound Card : Soundblaster Audigy SZ2
WD 250 GB HD 7200RPM
Catalyst Drivers 6.8 with CCC.
Windows XP Pro SP2.


Mini Chapter 1 : IT'S NOT THE SOUND CARD.

1) The problem is, and I know you guys know it. You are playing any
particular game and you are about 15-30 minutes of play, and then a Blue
Screen, BSOD appears saying something about a sound driver, and the
stuttering noise of the game.

Yeah, that was the infamous "squeal of death" reported on many CREATIVE
sites. (google "squeal of death", and you'll find thousands of posts)

After trying over and over to fix the problem, I've decided to give up
with my Soundblaster Card, and got myself a Bluegears B-Enspirer sound
card.
Device which I really recommend everyone, because it's powerful, and a
comparable low CPU consumer like the Soundblaster.And also it's reported
to have great solid drivers for both XP and Vista.

I cleaned all the Creative drivers, and even used drivercleaner to get
rid of them. Then installed the new sound card drivers.

I fired a game , Tomb Rider Anniversary. And played, thinking my
problems were solved.
And then after an hour, I got another BSOD with the same exact
stuttering (squeal) like the Soundblaster did.

I took the minidump file and debugged it and it reported a
"IRQ_NOT_LESS_OR_EQUAL" and having guilty the "cmaudio.sys" driver from
the new sound card driver. That means, two devices are sharing the same
port, and might conflict between each other, depending on how the memory
addresses requests from each one of the devices.

2) Interesting, the older and new card were located on the lower PCI.
I've found in my Device Manager (Control Panel) by checking the
devices "by connectrion" that the cards were sharing an IRQ with a
J-Micron (SATA controler).
Of course, I've opened my case and took the sound card out, and moved it
to the PCI socket, right above it.

When I started my machine again, I've checked the Device Manager again,
and this time it showed me that the soundcard was using now
a clean IRQ# 23 just for it, no sharing.

Ok, sure, now the problem is over...
I've fired up a game again "Lost Planet Extreme Condition", and guess
what, BSOD, with a squeal, again.

This time i got: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
realeted to the "ati3duag.dll"

SYMBOL_NAME: ati3duag+4b3c8
FOLLOWUP_NAME: MachineOwner
MODULE_NAME: ati3duag
IMAGE_NAME: ati3duag.dll
DEBUG_FLR_IMAGE_TIMESTAMP: 44d11f6d
STACK_COMMAND: .cxr 0xffffffff984ac80c ; kb
FAILURE_BUCKET_ID: 0x7E_ati3duag+4b3c8
BUCKET_ID: 0x7E_ati3duag+4b3c8
Followup: MachineOwner

Ok, I got a BSOD, but definetely I got rid of the IRQ_NOT_LESS_OR_EQUAL
BSOD, by putting the sound card on its own unique IRQ.

From there I can proceed to isolate the problem even more...

Mini Chapter 2: IT'S NOT THE VIDEO CARD

I've started to pull my hair out. And rapidly got into forums trying to
investigate what the heck ATI3DUAG.dll is.
The web is plagued with sites and people talking of a random BSOD
related to this file, there is also information in other languages
(german, french, spanish)
But no one really tells you what ATI3DDUAG.dll is. I found out it is
somehow related to the anti-aliasing feature on Catalyst.

They tell you :

a) It is a driver problem, just get the newest drivers. So I got the 7.6
and even tried the 7.7

b) Replace the ATI3DUAG.DLL file with an older one, it might be corrupted.
I've tried both solutions and then guess what, something interesting
ocurred.

I've got a BSOD but this time the blue screen didn't give me anything
related to a specific driver.
It was a 0X000008E bug, or 0x8E, but again didn't say anything about
what driver was causing this.
I used a debugger to check the minidump and i got this:

KERNEL_MODE_EXCEPTION_NOT_HANDLED_M (1000008e)
Debugging Details:
------------------

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx"
referenced memory at "0x%08lx". The memory could not be "%s".
FAULTING_IP:
+15268880
15268880 ?? ???
TRAP_FRAME: b2152650 -- (.trap 0xffffffffb2152650)
..trap 0xffffffffb2152650
ErrCode = 00000000
eax=00000000 ebx=b2152744 ecx=00000000 edx=0012f5e8 esi=b2152728
edi=b2152760
eip=15268880 esp=b21526c4 ebp=b21526e4 iopl=0 nv up ei pl zr na pe nc
cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010246
15268880 ?? ???
..trap
Resetting default scope
CUSTOMER_CRASH_COUNT: 2
DEFAULT_BUCKET_ID: DRIVER_FAULT
BUGCHECK_STR: 0x8E
PROCESS_NAME: ati2evxx.exe

STACK_COMMAND: kb
FOLLOWUP_IP:
nt!SeCaptureSubjectContextEx+4
8056b9c3 ec in al,dx
SYMBOL_STACK_INDEX: 1
SYMBOL_NAME: nt!SeCaptureSubjectContextEx+4
FOLLOWUP_NAME: MachineOwner
MODULE_NAME: nt
IMAGE_NAME: ntkrnlmp.exe
DEBUG_FLR_IMAGE_TIMESTAMP: 45e54690
FAILURE_BUCKET_ID: 0x8E_nt!SeCaptureSubjectContextEx+4
BUCKET_ID: 0x8E_nt!SeCaptureSubjectContextEx+4
Followup: MachineOwner

So, first the ATI driver ati2evxx.exe caput, but then NTKRNLMP.EXE
capput-ed as well.

Mini Chapter 3 IT'S NOT THE MEMORY

Probably, like me you've read this many many times on the web. "It's a
bad memory stick" "One of your sticks is faulty"
Fine, why not. I can talk with Corsair, no problem they can send me a
new stick under my waranty, but ONLY IF I INDEED have a defective stick.

I let my computer run Memtest +86, ON ALL STICKS first at for about 10
TIMES:
No errors whatsoever.
Then I ran Memtest +86, but now on EACH of the Sticks 10 times:
No errors again.
No memory issues., period.

In fact my computer never ever crashes while using any application. The
BSODS happen only while running games.
So I definetely discarded that this could be a memory issue. I would
definetely be in favor of this to be a memory issue if my computer
crashes randomnly for any reason other than games.

Mini Chapter 4 IT'S NOT THE POWER SUPPLY (PSU)

Again, you've heard this many times. "Then it's your power supply going
wacko on you", "You don't have enough juice for your video card",
"Your PSU is giving up".

Sure, I have a Seasonic S-12 500W power supply, which has enough amps on
the 12V rails to actually power the X1900XTX very stable.
But why not? It has been a year since I've purchased this PSU, and
probably it started to give up.

Anyway, I'll probably need a better power supply to feed the newest
cards, 8800GTX the Ultra, the Radeon HD 2900XT or XTX or whatever comes
after the R600 chip from ATI.

So I purchased a Corsair 620HX, which has been reviewed as one of the
most stable and efficient power supplies on the market, and it even
capable of powering
two 8800GTX on SLI mode, no problem and stable, thanks to its strong
amperage on the 12V rails, adding up to 54 amps. (Correct me if I'm wrong)

This should be by far more enough to power my X1900XTX, piece of cake.
I installed the new power supply and tested my system.

New system now:

Case Antec P150
ASUS P5W DH Deluxe
HIS ATI X1900XTX IceQ3
PSU Corsair HX 620W
4GB Corsair Dual Channel 4 Sticks of 1GB each (DDR2-800)
Sound Card : Bluegears B-Enspirer
WD 250 GB HD 7200RPM
Catalyst Drivers 6.8 with CCC.

Results: Guess what. I have a magnificent Blue Screen of Death after
playing for 30 minutes. Same bugcheck.
It's not the power supply, period. The possibility of having two power
supplies going wacko is very minimal.

Mini Chapter 5 IT'S NOT THE BIOS REVISION.

I flashed my bios to the new revision. And it didn't help at all. It
only helped reorganize the memory better, so instead of having 3 GB
recongized in
Windows XP, now I have 3.12 GB. Wow!! But nothing more.

Remember, 4 GIGS can only be used in 64 bit OS.
So, it's not the BIOS.

Mini Chapter 6 IT'S NOT OVERHEATING.

I used to play games perfectly with my machine. And frankly don't know
why I cannot play any games anymore without a random BSOD. It's because
they are new? Is it because they draw much more power and requirements
from my machine?

Is this a trend or a pattern on newest games to just crash critically on
Windows?

I've checked the temps on my CPU: Dual Core X6800 2.93Ghz cooled by a
Scythe Ninja, which IMHO is an overkill for this processor.
It doens't go above 35C on load and it's summer, and I have 80F ambient
temp.

All my memories have heatsinks. They are warm, on load, but nothing to
worry about.
My GPU cooler is made by HIS, and it exhaust the hot air outside my
case, and it's also very silent.

Checked the temps on my GPU running Lost Planet with all high settings.
It doesn't go beyond 85C after playing, for, let's say the time I can
play without an BSOD.
Negative pressure is very good inside my case. All the hot aire is being
pulled out by two 120mm fans plus the Radeon's exhaust cooling system.
It has been cool before, and it' cool now nothing to worry about.

So what the hell is it?

Mini Chapter 7 IN DEEP RESEARCH.

At this point, I was having many weeks of investigation, pulling my hair
out, many nights of investigation in google, different forums blogs,
translating french and german pages that talk about it.

Many questions, same useless or undocumented answers, and sometimes,
even silence on the forums regarding these issues.

I was thinking to myself, that this was the end of the PC Gaming for me,
that now you cannot trust any brand, they all lead to the same crappy or
unstable drivers, expensive videocards that two months later cost nothing.

Why should I spend a single more dime on new technology to power up my
rig and play games?
Should I just get an XBOX 360, and forget about spending stupid money on
a PC? Losing my ability to use the mouse to play 3D shooters? ( I just
CAN'T :-()

Then I've found something very interesting.

During my long research on bugchecks from many people on the web having
audio driver problems, or that stupid ATI3DUAG.DLL BSOD

I've found ONE THING IN COMMON.


If you observe the UNLOADED MODULES on the debugged minidump of all of
these users like me. You will observe something like this:

9d0ef000 9d112000 aec.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
9dc09000 9dc16000 DMusic.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
b7c64000 b7c6b000 USBSTOR.SYS
Timestamp: unavailable (00000000)
Checksum: 00000000
9df49000 9df74000 kmixer.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
b1e01000 b1e02000 drmkaud.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
b98a7000 b98b4000 DMusic.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
9df74000 9df97000 aec.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
ba715000 ba723000 swmidi.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
f79e7000 f79e9000 splitter.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
b2915000 b2922000 ATITool.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
bae0f000 bae13000 kbdhid.sys
Timestamp: unavailable (00000000)
Checksum: 00000000
acb2d000 acb3a000 i8042prt.SYS
Timestamp: unavailable (00000000)
Checksum: 00000000
b2656000 b265b000 Cdaudio.SYS
Timestamp: unavailable (00000000)
Checksum: 00000000
bae13000 bae16000 Sfloppy.SYS
Timestamp: unavailable (00000000)
Checksum: 00000000

All of the buchecks I studied will mentioned these drivers:

Always AEC.SYS, DMusic.SYS, CDAUDIO.SYS, SFLOPPY.SYS, SPLITTER.SYS,
DRMKAUDIO.SYS, KMIXER.SYS.

You will always find them on any debugged minidump related to this BSOD.
Have you noticed it? Because this leads to my conclusion on the problem.

CONCLUSION: IT'S MICROSOFT FAULT, IT'S WINDOWS. BUT THEY'VE SOLVED IT.
(HERE IS THE SOLUTION)

I always make and keep images of my current system. And I do prefer
TrueImage over Ghost. When the system gets screwed I ussually recovery
from a mess uing an image.
But his time I decided finally to make a clean install of Windows XP.
And I wanted to make things very carefully, to finally identify the problem.

Sorry for the long thread, but I'm documenting how I've isolated the
problem.

1) First formatted the hard drive (a real format, and NOT a quick one).
I wanted to make sure to be free of any potential rootkit.

2) Installed windows, but MOST IMPORTANT, DO NOT INSTALL ANY AUDIO AND
VIDEO DRIVERS YET. (Helps isolate problems)

3) Downloaded and installed all the updates, and also installed the .Net
Framework 1.1 (Just in case) Also please DO NOT install any audio or
video drivers
offered by Windows Update.

4) Installed all my usual programs (OFFICE, PHOTOSHOP, NERO), but DO NOT
INSTALL GAMES.

5) In other words have your system ready, but DO NOT INSTALL ANY AUDIO
OR VIDEO DRIVERS.

6) Backed up this clean configuration on a TrueImage Image, to have it
ready, just in case something gets screwed.

Then, and only then I proceeded to install my Video Card Driver. But I
installed the Catalyst Driver only. NO F...ING Catalyst Control Center.

I've decided, this time I didn't want any bloatware on my machine for
good. So I got to NGOHQ and installed the Old and great Catalyst Control
Panel. (Thanks to NGO and Regeneration for his work on drivers)

I've installed CAT 6.7 the only version that gave me at best experience
with my current video card.
After that I've installed my soundcard driver.

Then suddenly the most interesting and miraculous thing happened!
For some reason I've clicked on Windows Update and by surprise I saw two
critical updates:

KB900485
Overview
"Install this update to prevent an issue in which you may receive a
“stop 0x7e in aec.sys” error message on a computer that is running
Windows XP Service Pack 2. The error may occur during startup, or after
the system has started. AEC.SYS is the acoustic echo canceling driver."

KB920872
This is a reliability update for Windows XP machines. Install this
audio component update to prevent memory corruption issues which may
cause an unstable state on a computer that is running Windows XP
Service Pack 2. After you install this item, you may have to restart
your computer.
"You may experience one or more of the following symptoms when you try
to play audio files on a computer that is running Microsoft Windows XP
Service Pack 2 (SP2):• When you resume audio playback after you pause
it, the audio playback does not play the audio file from the correct
position. Instead, the audio playback resumes from a random position on
the audio track.
• You randomly receive the following Stop error message during audio
file playback:

Note If one or more of the following audio drivers are being used when
you install this update, you must restart the computer. This enables the
functionality of the following files:
• Kmixer.sys
• Splitter.sys
• Wdmaud.sys

Interesting isn't it?
Of course!! It happens that all the bugschecks I've seen of the web from
people with the same problems always mentioned AEC.SYS, KMIXER.SYS and
SPLITTER as unloaded modules.
It's more interesting to notice that this type of BSOD happen more
concurrently with games that use reverb or echo sounds, like happened to
me with BF 2142, Tomb Raider Anniversary and Lost Planet. Games that
have echo all the time.


So I went ahead and installed these updates that were offered.

One month from this and counting.

Believe me, until this day I've never ever have another BSOD. I've been
playing all these games again for more than 5 hours, fearing that this
nightmare might happen again, but it didn't.

Now all this fear, and frustration is left behind, and now I can finally
start enjoying playing in my PC again, feeling safe and happy.

At the most I've had one crash in one game, but a CTD. A crash back to
desktop, without a message, but not the horrid Blue Screen of Death or a
Squeal of Death.

So the solution, I think it's on these two Microsoft updates. I
sincerely think it has to do with sound, but it's not your soundcard,
the problem
resides on the windows drivers that work hand-hand with your specific
soundcard drivers. And I think it's related to the echo (aec.sys).
Remember that in all BSOD's we have stuttering or a squeal in the sound,
that gets repeated while you see the blue screen.

Other recommendations:
- I think it also helps to make a clean-clean Windows install
- Don't mess too much with registry cleaners.
- Refrain from installing the CCC, and really make ATI wake up and give
customers an utility other that the bloated CCC.

I really wanted to share this, because I think it would really help
hardcore PC gamers like me who spend money to have our machines fine.
There's been so much silence and lack of investigation, and I think it's
because this research took me time and months, to finally discover the
solution.
I don't think that video and sound card manufacturers have the time and
dedication to nail the problem, or maybe even the motivation. But I do,
and I'm sure
you have the motivation too.

And now, let's play. ""
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI X1600 AGP 512MB - blue screen during setup (driver in infinite loop) Colin Nash [MVP] Windows Vista Hardware 4 2nd Mar 2007 08:07 AM
ATI X1600 AGP 512MB - blue screen during setup (driver in infinite loop) Colin Nash [MVP] Windows Vista Installation 3 21st Nov 2006 09:22 PM
RC1 Driver stuck in infinite loop - blue screen Henry Horrocks - 108943 Windows Vista Installation 2 2nd Nov 2006 09:44 AM
blue screen/infinite loop/nv4_disp driver problem MilesG Windows XP Hardware 4 17th Sep 2004 09:38 AM
Infinite Loop Infinite Loop Infinite Loop Infinite Loop... Donna Windows XP Setup 0 8th Dec 2003 11:58 AM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 08:15 PM.