PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

Can't use UK keyboard layout at login

 
 
Chris
Guest
Posts: n/a
 
      25th Aug 2004
Hi,

I'm deploying Win2k SP4 machines from a RIS server
including the UK regional settings. A problem came to
light because we enforce the strong password policy GPO.
Some users use the '@' symbol in their passwords, but when
they type it in at the login screen, they get the US
keyboard layout & so actually type '"'!

I can't seem to find a way to enforce the UK keyboard
layout at the login screen, even if I make UK default &
delete US layout completely. Here's the section of my
riprep.sif file from the RIPrep image folder which
includes the UK keyboard layout:

[RegionalSettings]
Language=00000809
LanguageGroup=1
InputLocale=00000809

and it's the same in the CD-based image ristndrd.sif file
too. Machines built from this end up with both the UK & US
layouts, defaulting to the UK layout. I can't seem to
exclude the US layout in the RIPrep build.

Any ideas?
 
Reply With Quote
 
 
 
 
Oli Restorick [MVP]
Guest
Posts: n/a
 
      26th Aug 2004
Hi

You need the following lines:

[Unattended]
KeyboardLayout="United Kingdom"

Also, if you haven't already got this, you'll want it too.

[GUIUnattended]
TimeZone=85

If you want to fiddle with machines you've already deployed, try importing
this registry file on a test machine.

Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
"1"="00000809"

Hope this helps

Oli




"Chris" <(E-Mail Removed)> wrote in message
news:5a8401c48a81$4d145950$(E-Mail Removed)...
> Hi,
>
> I'm deploying Win2k SP4 machines from a RIS server
> including the UK regional settings. A problem came to
> light because we enforce the strong password policy GPO.
> Some users use the '@' symbol in their passwords, but when
> they type it in at the login screen, they get the US
> keyboard layout & so actually type '"'!
>
> I can't seem to find a way to enforce the UK keyboard
> layout at the login screen, even if I make UK default &
> delete US layout completely. Here's the section of my
> riprep.sif file from the RIPrep image folder which
> includes the UK keyboard layout:
>
> [RegionalSettings]
> Language=00000809
> LanguageGroup=1
> InputLocale=00000809
>
> and it's the same in the CD-based image ristndrd.sif file
> too. Machines built from this end up with both the UK & US
> layouts, defaulting to the UK layout. I can't seem to
> exclude the US layout in the RIPrep build.
>
> Any ideas?



 
Reply With Quote
 
 
 
 
Chris
Guest
Posts: n/a
 
      1st Sep 2004
Thanks for the reply, Oli. Found it was down to an
individual RIPrep image not installing the correct layout,
so all machines of that type ended up with the problem.
Not really sure why, because I tried making changes to
the .sif file as you suggested, but the US keyboard was
still the default at logon. Ended up re-imaging for that
type of machine.

The hint with the registry will be useful, though as I
should be able to mop up machines that have already used
the old image.

Cheers - Chris.

>-----Original Message-----
>Hi
>
>You need the following lines:
>
>[Unattended]
>KeyboardLayout="United Kingdom"
>
>Also, if you haven't already got this, you'll want it too.
>
>[GUIUnattended]
>TimeZone=85
>
>If you want to fiddle with machines you've already

deployed, try importing
>this registry file on a test machine.
>
>Windows Registry Editor Version 5.00
>
>[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
>"1"="00000809"
>
>Hope this helps
>
>Oli
>
>
>
>
>"Chris" <(E-Mail Removed)> wrote in

message
>news:5a8401c48a81$4d145950$(E-Mail Removed)...
>> Hi,
>>
>> I'm deploying Win2k SP4 machines from a RIS server
>> including the UK regional settings. A problem came to
>> light because we enforce the strong password policy GPO.
>> Some users use the '@' symbol in their passwords, but

when
>> they type it in at the login screen, they get the US
>> keyboard layout & so actually type '"'!
>>
>> I can't seem to find a way to enforce the UK keyboard
>> layout at the login screen, even if I make UK default &
>> delete US layout completely. Here's the section of my
>> riprep.sif file from the RIPrep image folder which
>> includes the UK keyboard layout:
>>
>> [RegionalSettings]
>> Language=00000809
>> LanguageGroup=1
>> InputLocale=00000809
>>
>> and it's the same in the CD-based image ristndrd.sif

file
>> too. Machines built from this end up with both the UK &

US
>> layouts, defaulting to the UK layout. I can't seem to
>> exclude the US layout in the RIPrep build.
>>
>> Any ideas?

>
>
>.
>

 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change Keyboard layout[i mean english,italian keyboard] =?Utf-8?B?LmJyZWF0aA==?= Windows XP Help 3 21st Aug 2007 03:38 PM
Need driver for keyboard layout for German Microsoft Natural Keyboard mydejamail@googlemail.com Windows XP General 0 5th Jan 2007 07:57 PM
Choosing Layout: Css-Layout or Table-Layout hpourfard@gmail.com Microsoft ASP .NET 1 19th Jun 2006 11:06 AM
Keyboard layout for login screen Rene Windows XP Help 2 3rd May 2004 08:31 PM
Login Keyboard Layout Setting Jen Hunnisett Windows XP Setup 0 20th Aug 2003 09:05 AM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 08:42 AM.