PC Review


Reply
Thread Tools Rating: Thread Rating: 1 votes, 5.00 average.

Cannot send mail - Helo command rejected error

 
 
=?Utf-8?B?dmVzcGVyaG9sbHk=?=
Guest
Posts: n/a
 
      13th Dec 2004
When I try to send email in Outlook 2000, I get this message:

"The message could not be sent because one of the recipients was
rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
command rejected: need fully-qualified hostname'.
(Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
0x800ccc79)"

I have the right smtp server for outgoing mail, and the system admin of that
server says it's not a server problem. Help please!
 
Reply With Quote
 
 
 
 
Ben M. Schorr - MVP OneNote
Guest
Posts: n/a
 
      13th Dec 2004
"vesperholly" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> When I try to send email in Outlook 2000, I get this message:
>
> "The message could not be sent because one of the recipients was
> rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
> command rejected: need fully-qualified hostname'.
> (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
> 0x800ccc79)"
>
> I have the right smtp server for outgoing mail, and the system admin of
> that
> server says it's not a server problem. Help please!


Sounds like you may not have a complete e-mail address for one of your
recipients. i.e (E-Mail Removed) or whatever. Double-check the e-mail
address(es) you sent to.


--
Aloha,

-Ben-
Ben M. Schorr, OneNote-MVP
Stockholm Consulting Group/KSG
http://www.scgab.com
Microsoft OneNote FAQ:
http://home.hawaii.rr.com/schorr/com...onenotefaq.htm

**I apologize but I am unable to respond to direct requests for assistance.
Please post questions and replies here in the newsgroup. Mahalo!


 
Reply With Quote
 
 
 
 
=?Utf-8?B?dmVzcGVyaG9sbHk=?=
Guest
Posts: n/a
 
      13th Dec 2004
Hi, thanks but the email is 100% correct. I've checked it again and again. I
am trying to send a test mail to my account, and a test email to another
account of mine. Could this error be coming from some kind of hidden
firewall? I disabled the Windows XP one, but in a file sharing program I
have, I am behind a firewall still. I have Norton AntiVirus but I am not
aware if it has a firewall. Thanks!

"Ben M. Schorr - MVP OneNote" wrote:

> "vesperholly" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > When I try to send email in Outlook 2000, I get this message:
> >
> > "The message could not be sent because one of the recipients was
> > rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
> > command rejected: need fully-qualified hostname'.
> > (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
> > 0x800ccc79)"
> >
> > I have the right smtp server for outgoing mail, and the system admin of
> > that
> > server says it's not a server problem. Help please!

>
> Sounds like you may not have a complete e-mail address for one of your
> recipients. i.e (E-Mail Removed) or whatever. Double-check the e-mail
> address(es) you sent to.
>
>
> --
> Aloha,
>
> -Ben-
> Ben M. Schorr, OneNote-MVP
> Stockholm Consulting Group/KSG
> http://www.scgab.com
> Microsoft OneNote FAQ:
> http://home.hawaii.rr.com/schorr/com...onenotefaq.htm
>
> **I apologize but I am unable to respond to direct requests for assistance.
> Please post questions and replies here in the newsgroup. Mahalo!
>
>
>

 
Reply With Quote
 
Jeff Stephenson [MSFT]
Guest
Posts: n/a
 
      13th Dec 2004
You're going to need to talk to your mail provider about the best way to
resolve this. What's happening is that when Outlook connects to your mail
provider's server it sends your computer name, say "mycomputer", but the
server requires that the name be a "fully qualified hostname" - something
like "mycomputer.kent.edu".

You could try just changing your computer name to something like the latter
form, but it may well be that the server will try and look up the address
for that name, not find it (or find it but with a different address) and
continue to reject your connection. If that's the case, you'll need to
talk to your provider to figure out what you need to do.

--
Jeff Stephenson
Outlook Development
This posting is provided "AS IS" with no warranties, and confers no rights

On Sun, 12 Dec 2004 23:29:02 -0800, vesperholly wrote:

> Hi, thanks but the email is 100% correct. I've checked it again and
> again. I am trying to send a test mail to my account, and a test email
> to another account of mine. Could this error be coming from some kind of
> hidden firewall? I disabled the Windows XP one, but in a file sharing
> program I have, I am behind a firewall still. I have Norton AntiVirus
> but I am not aware if it has a firewall. Thanks!
>
> "Ben M. Schorr - MVP OneNote" wrote:
>
>> "vesperholly" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> When I try to send email in Outlook 2000, I get this message:
>>>
>>> "The message could not be sent because one of the recipients was
>>> rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
>>> command rejected: need fully-qualified hostname'.
>>> (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
>>> 0x800ccc79)"
>>>
>>> I have the right smtp server for outgoing mail, and the system admin of
>>> that
>>> server says it's not a server problem. Help please!

>>
>> Sounds like you may not have a complete e-mail address for one of your
>> recipients. i.e (E-Mail Removed) or whatever. Double-check the e-mail
>> address(es) you sent to.
>>
>>
>> --
>> Aloha,
>>
>> -Ben-
>> Ben M. Schorr, OneNote-MVP
>> Stockholm Consulting Group/KSG
>> http://www.scgab.com
>> Microsoft OneNote FAQ:
>> http://home.hawaii.rr.com/schorr/com...onenotefaq.htm
>>
>> **I apologize but I am unable to respond to direct requests for
>> assistance. Please post questions and replies here in the newsgroup.
>> Mahalo!
>>
>>
>>

 
Reply With Quote
 
Brian Tillman
Guest
Posts: n/a
 
      13th Dec 2004
Jeff Stephenson [MSFT] <(E-Mail Removed)> wrote:

> You could try just changing your computer name to something like the
> latter form, but it may well be that the server will try and look up
> the address for that name, not find it (or find it but with a
> different address) and continue to reject your connection. If that's
> the case, you'll need to talk to your provider to figure out what you
> need to do.


The better way is to configure the TCP/IP connection to supply the domain.
Right-click My Network Places and choose Properties. Right-click the
network interface providing the link to yoru ISP and choose Properties.
Select Internet Protocol (TCP/IP) and click Properties. Click Advanced,
then the DNS tab. At the bottom, include the ISP's domain (kent.edu, for
example, as you stated) in the "DNS suffix for this connection" box.
--
Brian Tillman

 
Reply With Quote
 
=?Utf-8?B?dmVzcGVyaG9sbHk=?=
Guest
Posts: n/a
 
      14th Dec 2004
Thanks for your help, but I really don't think it's an ISP or server problem.
Two days ago I could download mail just fine. The only thing that's changed
since then is I had to do a System Restore which wiped my settings. I had to
go back and manually take down the Norton firewall and WinXP firewall,
reinstall programs, etc. Some kind of default has been turned on, that used
to be off, that now won't let my SMTP connect but I can't figure out what it
is.

I think the key lies in HELO command and fully-qualified host name. I tried
changing it to my name, and then to my ISP's domain name (not kent.edu but
xyz.net), and STILL no go! Any more ideas?

"Brian Tillman" wrote:

> Jeff Stephenson [MSFT] <(E-Mail Removed)> wrote:
>
> > You could try just changing your computer name to something like the
> > latter form, but it may well be that the server will try and look up
> > the address for that name, not find it (or find it but with a
> > different address) and continue to reject your connection. If that's
> > the case, you'll need to talk to your provider to figure out what you
> > need to do.

>
> The better way is to configure the TCP/IP connection to supply the domain.
> Right-click My Network Places and choose Properties. Right-click the
> network interface providing the link to yoru ISP and choose Properties.
> Select Internet Protocol (TCP/IP) and click Properties. Click Advanced,
> then the DNS tab. At the bottom, include the ISP's domain (kent.edu, for
> example, as you stated) in the "DNS suffix for this connection" box.
> --
> Brian Tillman
>
>

 
Reply With Quote
 
Brian Tillman
Guest
Posts: n/a
 
      14th Dec 2004
vesperholly <(E-Mail Removed)> wrote:

> Two days ago I could download mail just fine. The only thing
> that's changed since then is I had to do a System Restore which wiped
> my settings. I had to go back and manually take down the Norton
> firewall and WinXP firewall, reinstall programs, etc.


You're running two firewalls simultaneously? Unnecessary. Choose one and
run it. Frankly, with how many problems have been reported with Norton
products on Windows XP SP2, I'd choose the Windows firewall or one of the
(excellent) freeware firewalls before choosing Norton. I'd also make sure
the Norton antivirus was uninstalled completely and then reinstalled without
the mail scanning feature. This, too, has caused more headaches for more
people.
--
Brian Tillman

 
Reply With Quote
 
=?Utf-8?B?R3JlZ0c=?=
Guest
Posts: n/a
 
      13th May 2005
From what I've been able to find out, both Outlook and Outlook Express use
the NETBIOS name for the helo command. I have several users who would like to
use OE or Outlook to send mail through our server, but policy dictates that
the helo command contains the fqdn.

I've been digging around on Google for a week and haven't found anything
close to the solution. Is there a registry setting we can do that tells
Outlook and OE to use the Internet settings instead of NETBIOS?

By the way, non Microsoft email clients work fine for our other users so
it's not a configuration issue on the server side. The mail logs show that
the helo command only contains the netbios name. Here's an example:

May 12 13:59:37 www postfix/smtpd[2648]: NOQUEUE: reject: RCPT from
wsip-x.x.x.cox.net[x.x.x.x]: 504 <SP6100GORMAN>: Helo command rejected: need
fully-qualified hostname; from=<(E-Mail Removed)> to=<(E-Mail Removed)>
proto=ESMTP helo=<SP6100GORMAN>

The actual host name of that PC is SP6100-GORMAN so it even pulls the dash
out.

Greg

"Brian Tillman" wrote:

> vesperholly <(E-Mail Removed)> wrote:
>
> > Two days ago I could download mail just fine. The only thing
> > that's changed since then is I had to do a System Restore which wiped
> > my settings. I had to go back and manually take down the Norton
> > firewall and WinXP firewall, reinstall programs, etc.

>
> You're running two firewalls simultaneously? Unnecessary. Choose one and
> run it. Frankly, with how many problems have been reported with Norton
> products on Windows XP SP2, I'd choose the Windows firewall or one of the
> (excellent) freeware firewalls before choosing Norton. I'd also make sure
> the Norton antivirus was uninstalled completely and then reinstalled without
> the mail scanning feature. This, too, has caused more headaches for more
> people.
> --
> Brian Tillman
>
>

 
Reply With Quote
 
New Member
Join Date: Jan 2009
Posts: 1
 
      7th Jan 2009
Just a note to say I followed Brian Tillman's

suggestion to modify the TCP/IP connection.
Not sure why it works, but it does! My IP
says to leave this area blank.

I also noted that on the home page for this
forum there is a reference to the problem
and to use RegCure to solve it. I am using
RegCure, but did not notice this until I
logged on to write this note. I am curious
now, but will not try it now that I have things
working!

This is puzzling in that why did it pop up
after 8 months of use? And of course,
everyone points the finger at the other guy!
I talked with my ISP rep who had worked for
other ISPs who offered the solution to problems
like this. However, my ISP provides limited
support to OE, and not helping their customers
with this problem has ticked numerous people
off. The rep stated the solution was very simple
and could be provided in seconds, but he couldn't
because of policy! I am thinking about makiing
a change!

williebuilt72
 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need HELP with REJECTED newsgroup POSTS - Error Message 441 Posting Failed (Rejected by POST filter) Charlie Windows Vista Mail 21 1st Mar 2008 02:10 AM
Cannot send email from outlook, error message 50 invalid HELO/EHLO =?Utf-8?B?a2l0ZXJkb24=?= Microsoft Outlook Discussion 1 2nd Mar 2007 11:50 PM
Occasional error message"504 <BUILDUP23>: Helo command rejected: n =?Utf-8?B?d2F5Ym9tYg==?= Microsoft Outlook Discussion 4 30th Apr 2006 10:23 PM
e-mail with cdo --> Helo command rejected =?Utf-8?B?Um9uYWxkRg==?= Microsoft Excel Programming 0 23rd Mar 2006 04:08 PM
554 <VAIO>: Helo command rejected: Access denied... =?Utf-8?B?RG9t?= Microsoft Outlook Discussion 3 8th Mar 2006 05:15 AM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 02:53 AM.