PC Review


Reply
Thread Tools Rating: Thread Rating: 12 votes, 4.67 average.

ASP.NET 2.0 (64bit), IIS 6, Windows Server 2003 (64 bit)

 
 
=?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=
Guest
Posts: n/a
 
      13th Jun 2006
I'm having a bit of a weird problem and I've spent the last few hours
scouring the web trying to solve this before coming here.

Here is the problem:
I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.

Setup:
IIS 6 (64 bit)
Windows Server 2003 64bit
ASP.NET 2.0 (64 bit)

Some Additional Facts:
Classic-ASP components for IIS not installed.
ASP.NET is registered with IIS.
Directory permissions are fine.
Just .NET 2.0 64 bit on machine (no 1.1 installed)
It's not the "app_offline.htm" issue.
File extension mappings (aspx, asmx, ashx, etc) all fine

What I have tried so far:
It's not the "app_offline.htm" issue - I have confirmed that. I have
unregistered ASP.NET from IIS and re-registered it. No difference. When
ASP.NET is unregistered the files are found and served by IIS (although they
obviously don't work as ASP.NET is not installed). When ASP.NET is registered
it's an immediate 404.

I'm trying to service webservices but I have tried it with simple ASPX file
with no code behind and just "static" html content - same problem. I've tried
it with ASPX files with code behind - same problem.

I've tried removing IIS, restarting machine (even though this is not
necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
Same problem. All the ASPX and ASMX files/projects I have tried work fine on
IIS 5 on my XP pro dev box.

I've tried manually recreating the file extension mappings to the 64 bit
ASP.NET engine
(c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
didn't work either.

I've enabled directory browsing to see if IIS itself is even seeing the file
which I knew it was as when ASP.NET in not registered it does try to serve
it... anyway, IIS sees it, but when you click on the file - 404. I checked
the error mappings to ensure it really is a 404 and it is - the log says 404
too.

I mapped .html files to the ASP.NET worker process too
(c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
mapped to it, they give 404s too.

And, after doing all this, I again uninstalled and reinstalled IIS and
re-registered ASP.NET 2.0 and still no joy!

Anybody have any suggestions?
 
Reply With Quote
 
 
 
 
Juan T. Llibre
Guest
Posts: n/a
 
      13th Jun 2006
Have you enabled ASP.NET 2.0 in IIS 6.0 ?

You need to enable ASP.NET by opening the IIS Manager
and scrolling down the left-hand side to "Web Service Extensions",
click once on it and look on the right-hand panel.

Click once on the ASP.NET version you want to enable,
( in this case 2.0 ) and click the "Allow" button.




Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espa˝ol : http://asp.net.do/foros/
===================================
"Brian Delahunty" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> I'm having a bit of a weird problem and I've spent the last few hours
> scouring the web trying to solve this before coming here.
>
> Here is the problem:
> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
>
> Setup:
> IIS 6 (64 bit)
> Windows Server 2003 64bit
> ASP.NET 2.0 (64 bit)
>
> Some Additional Facts:
> Classic-ASP components for IIS not installed.
> ASP.NET is registered with IIS.
> Directory permissions are fine.
> Just .NET 2.0 64 bit on machine (no 1.1 installed)
> It's not the "app_offline.htm" issue.
> File extension mappings (aspx, asmx, ashx, etc) all fine
>
> What I have tried so far:
> It's not the "app_offline.htm" issue - I have confirmed that. I have
> unregistered ASP.NET from IIS and re-registered it. No difference. When
> ASP.NET is unregistered the files are found and served by IIS (although they
> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
> it's an immediate 404.
>
> I'm trying to service webservices but I have tried it with simple ASPX file
> with no code behind and just "static" html content - same problem. I've tried
> it with ASPX files with code behind - same problem.
>
> I've tried removing IIS, restarting machine (even though this is not
> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
> IIS 5 on my XP pro dev box.
>
> I've tried manually recreating the file extension mappings to the 64 bit
> ASP.NET engine
> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
> didn't work either.
>
> I've enabled directory browsing to see if IIS itself is even seeing the file
> which I knew it was as when ASP.NET in not registered it does try to serve
> it... anyway, IIS sees it, but when you click on the file - 404. I checked
> the error mappings to ensure it really is a 404 and it is - the log says 404
> too.
>
> I mapped .html files to the ASP.NET worker process too
> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
> mapped to it, they give 404s too.
>
> And, after doing all this, I again uninstalled and reinstalled IIS and
> re-registered ASP.NET 2.0 and still no joy!
>
> Anybody have any suggestions?




 
Reply With Quote
 
 
 
 
mnichols
Guest
Posts: n/a
 
      13th Jun 2006
Hi,

If you go to the IIS Manager and select the Web Service Extensions node
is ASP.NET "allowed"? This is something that can be missed.

Also, look into aspnet_regiis.exe and it various options (see msdn).

Windows firewall?

hth

mnichols

Brian Delahunty wrote:
> I'm having a bit of a weird problem and I've spent the last few hours
> scouring the web trying to solve this before coming here.
>
> Here is the problem:
> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
>
> Setup:
> IIS 6 (64 bit)
> Windows Server 2003 64bit
> ASP.NET 2.0 (64 bit)
>
> Some Additional Facts:
> Classic-ASP components for IIS not installed.
> ASP.NET is registered with IIS.
> Directory permissions are fine.
> Just .NET 2.0 64 bit on machine (no 1.1 installed)
> It's not the "app_offline.htm" issue.
> File extension mappings (aspx, asmx, ashx, etc) all fine
>
> What I have tried so far:
> It's not the "app_offline.htm" issue - I have confirmed that. I have
> unregistered ASP.NET from IIS and re-registered it. No difference. When
> ASP.NET is unregistered the files are found and served by IIS (although they
> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
> it's an immediate 404.
>
> I'm trying to service webservices but I have tried it with simple ASPX file
> with no code behind and just "static" html content - same problem. I've tried
> it with ASPX files with code behind - same problem.
>
> I've tried removing IIS, restarting machine (even though this is not
> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
> IIS 5 on my XP pro dev box.
>
> I've tried manually recreating the file extension mappings to the 64 bit
> ASP.NET engine
> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
> didn't work either.
>
> I've enabled directory browsing to see if IIS itself is even seeing the file
> which I knew it was as when ASP.NET in not registered it does try to serve
> it... anyway, IIS sees it, but when you click on the file - 404. I checked
> the error mappings to ensure it really is a 404 and it is - the log says 404
> too.
>
> I mapped .html files to the ASP.NET worker process too
> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
> mapped to it, they give 404s too.
>
> And, after doing all this, I again uninstalled and reinstalled IIS and
> re-registered ASP.NET 2.0 and still no joy!
>
> Anybody have any suggestions?

 
Reply With Quote
 
=?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=
Guest
Posts: n/a
 
      13th Jun 2006
Yep. Sorry. Forgot to mention that I had enabled it.

I'm wondering if it has something to do with the whole 64 bit thing.


"Juan T. Llibre" wrote:

> Have you enabled ASP.NET 2.0 in IIS 6.0 ?
>
> You need to enable ASP.NET by opening the IIS Manager
> and scrolling down the left-hand side to "Web Service Extensions",
> click once on it and look on the right-hand panel.
>
> Click once on the ASP.NET version you want to enable,
> ( in this case 2.0 ) and click the "Allow" button.
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espa├▒ol : http://asp.net.do/foros/
> ===================================
> "Brian Delahunty" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > I'm having a bit of a weird problem and I've spent the last few hours
> > scouring the web trying to solve this before coming here.
> >
> > Here is the problem:
> > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
> >
> > Setup:
> > IIS 6 (64 bit)
> > Windows Server 2003 64bit
> > ASP.NET 2.0 (64 bit)
> >
> > Some Additional Facts:
> > Classic-ASP components for IIS not installed.
> > ASP.NET is registered with IIS.
> > Directory permissions are fine.
> > Just .NET 2.0 64 bit on machine (no 1.1 installed)
> > It's not the "app_offline.htm" issue.
> > File extension mappings (aspx, asmx, ashx, etc) all fine
> >
> > What I have tried so far:
> > It's not the "app_offline.htm" issue - I have confirmed that. I have
> > unregistered ASP.NET from IIS and re-registered it. No difference. When
> > ASP.NET is unregistered the files are found and served by IIS (although they
> > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
> > it's an immediate 404.
> >
> > I'm trying to service webservices but I have tried it with simple ASPX file
> > with no code behind and just "static" html content - same problem. I've tried
> > it with ASPX files with code behind - same problem.
> >
> > I've tried removing IIS, restarting machine (even though this is not
> > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
> > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
> > IIS 5 on my XP pro dev box.
> >
> > I've tried manually recreating the file extension mappings to the 64 bit
> > ASP.NET engine
> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
> > didn't work either.
> >
> > I've enabled directory browsing to see if IIS itself is even seeing the file
> > which I knew it was as when ASP.NET in not registered it does try to serve
> > it... anyway, IIS sees it, but when you click on the file - 404. I checked
> > the error mappings to ensure it really is a 404 and it is - the log says 404
> > too.
> >
> > I mapped .html files to the ASP.NET worker process too
> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
> > mapped to it, they give 404s too.
> >
> > And, after doing all this, I again uninstalled and reinstalled IIS and
> > re-registered ASP.NET 2.0 and still no joy!
> >
> > Anybody have any suggestions?

>
>
>
>

 
Reply With Quote
 
=?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=
Guest
Posts: n/a
 
      13th Jun 2006
ASP.NET is allowed and I'm testing from the local machine.


"mnichols" wrote:

> Hi,
>
> If you go to the IIS Manager and select the Web Service Extensions node
> is ASP.NET "allowed"? This is something that can be missed.
>
> Also, look into aspnet_regiis.exe and it various options (see msdn).
>
> Windows firewall?
>
> hth
>
> mnichols
>
> Brian Delahunty wrote:
> > I'm having a bit of a weird problem and I've spent the last few hours
> > scouring the web trying to solve this before coming here.
> >
> > Here is the problem:
> > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
> >
> > Setup:
> > IIS 6 (64 bit)
> > Windows Server 2003 64bit
> > ASP.NET 2.0 (64 bit)
> >
> > Some Additional Facts:
> > Classic-ASP components for IIS not installed.
> > ASP.NET is registered with IIS.
> > Directory permissions are fine.
> > Just .NET 2.0 64 bit on machine (no 1.1 installed)
> > It's not the "app_offline.htm" issue.
> > File extension mappings (aspx, asmx, ashx, etc) all fine
> >
> > What I have tried so far:
> > It's not the "app_offline.htm" issue - I have confirmed that. I have
> > unregistered ASP.NET from IIS and re-registered it. No difference. When
> > ASP.NET is unregistered the files are found and served by IIS (although they
> > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
> > it's an immediate 404.
> >
> > I'm trying to service webservices but I have tried it with simple ASPX file
> > with no code behind and just "static" html content - same problem. I've tried
> > it with ASPX files with code behind - same problem.
> >
> > I've tried removing IIS, restarting machine (even though this is not
> > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
> > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
> > IIS 5 on my XP pro dev box.
> >
> > I've tried manually recreating the file extension mappings to the 64 bit
> > ASP.NET engine
> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
> > didn't work either.
> >
> > I've enabled directory browsing to see if IIS itself is even seeing the file
> > which I knew it was as when ASP.NET in not registered it does try to serve
> > it... anyway, IIS sees it, but when you click on the file - 404. I checked
> > the error mappings to ensure it really is a 404 and it is - the log says 404
> > too.
> >
> > I mapped .html files to the ASP.NET worker process too
> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
> > mapped to it, they give 404s too.
> >
> > And, after doing all this, I again uninstalled and reinstalled IIS and
> > re-registered ASP.NET 2.0 and still no joy!
> >
> > Anybody have any suggestions?

>

 
Reply With Quote
 
mnichols
Guest
Posts: n/a
 
      13th Jun 2006
A client had similar problems and it was because of folder permissions.

A few more ideas:

Check IIS logs: C:\windows\system32\Logfiles
Check httplogs: C:\WINDOWS\system32\LogFiles\HTTPERR
Run Filemon from SystemInternals to see if permissions are an issue
Event viewer?

hth

mnichols

Brian Delahunty wrote:
> ASP.NET is allowed and I'm testing from the local machine.
>
>
> "mnichols" wrote:
>
>> Hi,
>>
>> If you go to the IIS Manager and select the Web Service Extensions node
>> is ASP.NET "allowed"? This is something that can be missed.
>>
>> Also, look into aspnet_regiis.exe and it various options (see msdn).
>>
>> Windows firewall?
>>
>> hth
>>
>> mnichols
>>
>> Brian Delahunty wrote:
>>> I'm having a bit of a weird problem and I've spent the last few hours
>>> scouring the web trying to solve this before coming here.
>>>
>>> Here is the problem:
>>> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
>>>
>>> Setup:
>>> IIS 6 (64 bit)
>>> Windows Server 2003 64bit
>>> ASP.NET 2.0 (64 bit)
>>>
>>> Some Additional Facts:
>>> Classic-ASP components for IIS not installed.
>>> ASP.NET is registered with IIS.
>>> Directory permissions are fine.
>>> Just .NET 2.0 64 bit on machine (no 1.1 installed)
>>> It's not the "app_offline.htm" issue.
>>> File extension mappings (aspx, asmx, ashx, etc) all fine
>>>
>>> What I have tried so far:
>>> It's not the "app_offline.htm" issue - I have confirmed that. I have
>>> unregistered ASP.NET from IIS and re-registered it. No difference. When
>>> ASP.NET is unregistered the files are found and served by IIS (although they
>>> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
>>> it's an immediate 404.
>>>
>>> I'm trying to service webservices but I have tried it with simple ASPX file
>>> with no code behind and just "static" html content - same problem. I've tried
>>> it with ASPX files with code behind - same problem.
>>>
>>> I've tried removing IIS, restarting machine (even though this is not
>>> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
>>> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
>>> IIS 5 on my XP pro dev box.
>>>
>>> I've tried manually recreating the file extension mappings to the 64 bit
>>> ASP.NET engine
>>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
>>> didn't work either.
>>>
>>> I've enabled directory browsing to see if IIS itself is even seeing the file
>>> which I knew it was as when ASP.NET in not registered it does try to serve
>>> it... anyway, IIS sees it, but when you click on the file - 404. I checked
>>> the error mappings to ensure it really is a 404 and it is - the log says 404
>>> too.
>>>
>>> I mapped .html files to the ASP.NET worker process too
>>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
>>> mapped to it, they give 404s too.
>>>
>>> And, after doing all this, I again uninstalled and reinstalled IIS and
>>> re-registered ASP.NET 2.0 and still no joy!
>>>
>>> Anybody have any suggestions?

 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      13th Jun 2006
Nah...I'm very sure this isn't 64-bit related.
We would have heard many reports by now if it was.

I know you said that : "ASP.NET is registered with IIS" but
have you run aspnet_regiis -i from the
"c:\windows\Microsoft.NET\Framework64\v2.0.50727" directory ?

( just to make sure... )

Also, how are you calling your ASP.NET pages ?

http://yourserver.com/some.aspx ?
http://yourserver.com/somevirtualdir/some.aspx ?
http://yourmachinename/some.aspx ?
http://yourmachinename/somevirtualdir/some.aspx ?

I mention this because you say that "when you click on the file - 404",
and you don't call aspx files by clicking on them.

Did you mean "click on a link" ?
But, if you clicked on a link...then your original aspx file *did* load.




Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espa˝ol : http://asp.net.do/foros/
===================================
"Brian Delahunty" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Yep. Sorry. Forgot to mention that I had enabled it.
>
> I'm wondering if it has something to do with the whole 64 bit thing.
>
>
> "Juan T. Llibre" wrote:
>
>> Have you enabled ASP.NET 2.0 in IIS 6.0 ?
>>
>> You need to enable ASP.NET by opening the IIS Manager
>> and scrolling down the left-hand side to "Web Service Extensions",
>> click once on it and look on the right-hand panel.
>>
>> Click once on the ASP.NET version you want to enable,
>> ( in this case 2.0 ) and click the "Allow" button.
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> aspnetfaq.com : http://www.aspnetfaq.com/
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espa˝ol : http://asp.net.do/foros/
>> ===================================
>> "Brian Delahunty" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>> > I'm having a bit of a weird problem and I've spent the last few hours
>> > scouring the web trying to solve this before coming here.
>> >
>> > Here is the problem:
>> > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
>> >
>> > Setup:
>> > IIS 6 (64 bit)
>> > Windows Server 2003 64bit
>> > ASP.NET 2.0 (64 bit)
>> >
>> > Some Additional Facts:
>> > Classic-ASP components for IIS not installed.
>> > ASP.NET is registered with IIS.
>> > Directory permissions are fine.
>> > Just .NET 2.0 64 bit on machine (no 1.1 installed)
>> > It's not the "app_offline.htm" issue.
>> > File extension mappings (aspx, asmx, ashx, etc) all fine
>> >
>> > What I have tried so far:
>> > It's not the "app_offline.htm" issue - I have confirmed that. I have
>> > unregistered ASP.NET from IIS and re-registered it. No difference. When
>> > ASP.NET is unregistered the files are found and served by IIS (although they
>> > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
>> > it's an immediate 404.
>> >
>> > I'm trying to service webservices but I have tried it with simple ASPX file
>> > with no code behind and just "static" html content - same problem. I've tried
>> > it with ASPX files with code behind - same problem.
>> >
>> > I've tried removing IIS, restarting machine (even though this is not
>> > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
>> > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
>> > IIS 5 on my XP pro dev box.
>> >
>> > I've tried manually recreating the file extension mappings to the 64 bit
>> > ASP.NET engine
>> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
>> > didn't work either.
>> >
>> > I've enabled directory browsing to see if IIS itself is even seeing the file
>> > which I knew it was as when ASP.NET in not registered it does try to serve
>> > it... anyway, IIS sees it, but when you click on the file - 404. I checked
>> > the error mappings to ensure it really is a 404 and it is - the log says 404
>> > too.
>> >
>> > I mapped .html files to the ASP.NET worker process too
>> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
>> > mapped to it, they give 404s too.
>> >
>> > And, after doing all this, I again uninstalled and reinstalled IIS and
>> > re-registered ASP.NET 2.0 and still no joy!
>> >
>> > Anybody have any suggestions?



 
Reply With Quote
 
=?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=
Guest
Posts: n/a
 
      13th Jun 2006
I've checked all the permissions and everything seems fine. I'll turn on
filemon and keep an eye on it.

Cheers.

"mnichols" wrote:

> A client had similar problems and it was because of folder permissions.
>
> A few more ideas:
>
> Check IIS logs: C:\windows\system32\Logfiles
> Check httplogs: C:\WINDOWS\system32\LogFiles\HTTPERR
> Run Filemon from SystemInternals to see if permissions are an issue
> Event viewer?
>
> hth
>
> mnichols
>
> Brian Delahunty wrote:
> > ASP.NET is allowed and I'm testing from the local machine.
> >
> >
> > "mnichols" wrote:
> >
> >> Hi,
> >>
> >> If you go to the IIS Manager and select the Web Service Extensions node
> >> is ASP.NET "allowed"? This is something that can be missed.
> >>
> >> Also, look into aspnet_regiis.exe and it various options (see msdn).
> >>
> >> Windows firewall?
> >>
> >> hth
> >>
> >> mnichols
> >>
> >> Brian Delahunty wrote:
> >>> I'm having a bit of a weird problem and I've spent the last few hours
> >>> scouring the web trying to solve this before coming here.
> >>>
> >>> Here is the problem:
> >>> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
> >>>
> >>> Setup:
> >>> IIS 6 (64 bit)
> >>> Windows Server 2003 64bit
> >>> ASP.NET 2.0 (64 bit)
> >>>
> >>> Some Additional Facts:
> >>> Classic-ASP components for IIS not installed.
> >>> ASP.NET is registered with IIS.
> >>> Directory permissions are fine.
> >>> Just .NET 2.0 64 bit on machine (no 1.1 installed)
> >>> It's not the "app_offline.htm" issue.
> >>> File extension mappings (aspx, asmx, ashx, etc) all fine
> >>>
> >>> What I have tried so far:
> >>> It's not the "app_offline.htm" issue - I have confirmed that. I have
> >>> unregistered ASP.NET from IIS and re-registered it. No difference. When
> >>> ASP.NET is unregistered the files are found and served by IIS (although they
> >>> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
> >>> it's an immediate 404.
> >>>
> >>> I'm trying to service webservices but I have tried it with simple ASPX file
> >>> with no code behind and just "static" html content - same problem. I've tried
> >>> it with ASPX files with code behind - same problem.
> >>>
> >>> I've tried removing IIS, restarting machine (even though this is not
> >>> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
> >>> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
> >>> IIS 5 on my XP pro dev box.
> >>>
> >>> I've tried manually recreating the file extension mappings to the 64 bit
> >>> ASP.NET engine
> >>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
> >>> didn't work either.
> >>>
> >>> I've enabled directory browsing to see if IIS itself is even seeing the file
> >>> which I knew it was as when ASP.NET in not registered it does try to serve
> >>> it... anyway, IIS sees it, but when you click on the file - 404. I checked
> >>> the error mappings to ensure it really is a 404 and it is - the log says 404
> >>> too.
> >>>
> >>> I mapped .html files to the ASP.NET worker process too
> >>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
> >>> mapped to it, they give 404s too.
> >>>
> >>> And, after doing all this, I again uninstalled and reinstalled IIS and
> >>> re-registered ASP.NET 2.0 and still no joy!
> >>>
> >>> Anybody have any suggestions?

>

 
Reply With Quote
 
mnichols
Guest
Posts: n/a
 
      13th Jun 2006
Our client gave 'everyone' permissions on the folder which is really
wrong but it identified at least that security was an issue. The ASPNET
user has very few rights by default.

mnichols

Brian Delahunty wrote:
> I've checked all the permissions and everything seems fine. I'll turn on
> filemon and keep an eye on it.
>
> Cheers.
>
> "mnichols" wrote:
>
>> A client had similar problems and it was because of folder permissions.
>>
>> A few more ideas:
>>
>> Check IIS logs: C:\windows\system32\Logfiles
>> Check httplogs: C:\WINDOWS\system32\LogFiles\HTTPERR
>> Run Filemon from SystemInternals to see if permissions are an issue
>> Event viewer?
>>
>> hth
>>
>> mnichols
>>
>> Brian Delahunty wrote:
>>> ASP.NET is allowed and I'm testing from the local machine.
>>>
>>>
>>> "mnichols" wrote:
>>>
>>>> Hi,
>>>>
>>>> If you go to the IIS Manager and select the Web Service Extensions node
>>>> is ASP.NET "allowed"? This is something that can be missed.
>>>>
>>>> Also, look into aspnet_regiis.exe and it various options (see msdn).
>>>>
>>>> Windows firewall?
>>>>
>>>> hth
>>>>
>>>> mnichols
>>>>
>>>> Brian Delahunty wrote:
>>>>> I'm having a bit of a weird problem and I've spent the last few hours
>>>>> scouring the web trying to solve this before coming here.
>>>>>
>>>>> Here is the problem:
>>>>> I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
>>>>>
>>>>> Setup:
>>>>> IIS 6 (64 bit)
>>>>> Windows Server 2003 64bit
>>>>> ASP.NET 2.0 (64 bit)
>>>>>
>>>>> Some Additional Facts:
>>>>> Classic-ASP components for IIS not installed.
>>>>> ASP.NET is registered with IIS.
>>>>> Directory permissions are fine.
>>>>> Just .NET 2.0 64 bit on machine (no 1.1 installed)
>>>>> It's not the "app_offline.htm" issue.
>>>>> File extension mappings (aspx, asmx, ashx, etc) all fine
>>>>>
>>>>> What I have tried so far:
>>>>> It's not the "app_offline.htm" issue - I have confirmed that. I have
>>>>> unregistered ASP.NET from IIS and re-registered it. No difference. When
>>>>> ASP.NET is unregistered the files are found and served by IIS (although they
>>>>> obviously don't work as ASP.NET is not installed). When ASP.NET is registered
>>>>> it's an immediate 404.
>>>>>
>>>>> I'm trying to service webservices but I have tried it with simple ASPX file
>>>>> with no code behind and just "static" html content - same problem. I've tried
>>>>> it with ASPX files with code behind - same problem.
>>>>>
>>>>> I've tried removing IIS, restarting machine (even though this is not
>>>>> necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
>>>>> Same problem. All the ASPX and ASMX files/projects I have tried work fine on
>>>>> IIS 5 on my XP pro dev box.
>>>>>
>>>>> I've tried manually recreating the file extension mappings to the 64 bit
>>>>> ASP.NET engine
>>>>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
>>>>> didn't work either.
>>>>>
>>>>> I've enabled directory browsing to see if IIS itself is even seeing the file
>>>>> which I knew it was as when ASP.NET in not registered it does try to serve
>>>>> it... anyway, IIS sees it, but when you click on the file - 404. I checked
>>>>> the error mappings to ensure it really is a 404 and it is - the log says 404
>>>>> too.
>>>>>
>>>>> I mapped .html files to the ASP.NET worker process too
>>>>> (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
>>>>> mapped to it, they give 404s too.
>>>>>
>>>>> And, after doing all this, I again uninstalled and reinstalled IIS and
>>>>> re-registered ASP.NET 2.0 and still no joy!
>>>>>
>>>>> Anybody have any suggestions?

 
Reply With Quote
 
=?Utf-8?B?QnJpYW4gRGVsYWh1bnR5?=
Guest
Posts: n/a
 
      13th Jun 2006
Hi Juan,

Yes, aspnet_regiis.exe -i has been run.. numerous times by now :-)

When I said I was clicking on the files I just meant that when I turned on
directory browseing and saw the files - just to ensure that IIS itself was
seeing them - clicking on them didn't work either. I'm normally just entering
the URL.

I think it might actually be a permissions thing in IIS. I'll look into it
in more detail.

"Juan T. Llibre" wrote:

> Nah...I'm very sure this isn't 64-bit related.
> We would have heard many reports by now if it was.
>
> I know you said that : "ASP.NET is registered with IIS" but
> have you run aspnet_regiis -i from the
> "c:\windows\Microsoft.NET\Framework64\v2.0.50727" directory ?
>
> ( just to make sure... )
>
> Also, how are you calling your ASP.NET pages ?
>
> http://yourserver.com/some.aspx ?
> http://yourserver.com/somevirtualdir/some.aspx ?
> http://yourmachinename/some.aspx ?
> http://yourmachinename/somevirtualdir/some.aspx ?
>
> I mention this because you say that "when you click on the file - 404",
> and you don't call aspx files by clicking on them.
>
> Did you mean "click on a link" ?
> But, if you clicked on a link...then your original aspx file *did* load.
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espa├▒ol : http://asp.net.do/foros/
> ===================================
> "Brian Delahunty" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Yep. Sorry. Forgot to mention that I had enabled it.
> >
> > I'm wondering if it has something to do with the whole 64 bit thing.
> >
> >
> > "Juan T. Llibre" wrote:
> >
> >> Have you enabled ASP.NET 2.0 in IIS 6.0 ?
> >>
> >> You need to enable ASP.NET by opening the IIS Manager
> >> and scrolling down the left-hand side to "Web Service Extensions",
> >> click once on it and look on the right-hand panel.
> >>
> >> Click once on the ASP.NET version you want to enable,
> >> ( in this case 2.0 ) and click the "Allow" button.
> >>
> >>
> >>
> >>
> >> Juan T. Llibre, asp.net MVP
> >> aspnetfaq.com : http://www.aspnetfaq.com/
> >> asp.net faq : http://asp.net.do/faq/
> >> foros de asp.net, en espa├▒ol : http://asp.net.do/foros/
> >> ===================================
> >> "Brian Delahunty" <(E-Mail Removed)> wrote in message
> >> news:(E-Mail Removed)...
> >> > I'm having a bit of a weird problem and I've spent the last few hours
> >> > scouring the web trying to solve this before coming here.
> >> >
> >> > Here is the problem:
> >> > I get 404 errors for all ASP.NET 2.0 content trying to be served from IIS.
> >> >
> >> > Setup:
> >> > IIS 6 (64 bit)
> >> > Windows Server 2003 64bit
> >> > ASP.NET 2.0 (64 bit)
> >> >
> >> > Some Additional Facts:
> >> > Classic-ASP components for IIS not installed.
> >> > ASP.NET is registered with IIS.
> >> > Directory permissions are fine.
> >> > Just .NET 2.0 64 bit on machine (no 1.1 installed)
> >> > It's not the "app_offline.htm" issue.
> >> > File extension mappings (aspx, asmx, ashx, etc) all fine
> >> >
> >> > What I have tried so far:
> >> > It's not the "app_offline.htm" issue - I have confirmed that. I have
> >> > unregistered ASP.NET from IIS and re-registered it. No difference. When
> >> > ASP.NET is unregistered the files are found and served by IIS (although they
> >> > obviously don't work as ASP.NET is not installed). When ASP.NET is registered
> >> > it's an immediate 404.
> >> >
> >> > I'm trying to service webservices but I have tried it with simple ASPX file
> >> > with no code behind and just "static" html content - same problem. I've tried
> >> > it with ASPX files with code behind - same problem.
> >> >
> >> > I've tried removing IIS, restarting machine (even though this is not
> >> > necessary), reinstall IIS, re-register ASP.NET 2 with IIS - no difference.
> >> > Same problem. All the ASPX and ASMX files/projects I have tried work fine on
> >> > IIS 5 on my XP pro dev box.
> >> >
> >> > I've tried manually recreating the file extension mappings to the 64 bit
> >> > ASP.NET engine
> >> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll). That
> >> > didn't work either.
> >> >
> >> > I've enabled directory browsing to see if IIS itself is even seeing the file
> >> > which I knew it was as when ASP.NET in not registered it does try to serve
> >> > it... anyway, IIS sees it, but when you click on the file - 404. I checked
> >> > the error mappings to ensure it really is a 404 and it is - the log says 404
> >> > too.
> >> >
> >> > I mapped .html files to the ASP.NET worker process too
> >> > (c:\windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll) and when
> >> > mapped to it, they give 404s too.
> >> >
> >> > And, after doing all this, I again uninstalled and reinstalled IIS and
> >> > re-registered ASP.NET 2.0 and still no joy!
> >> >
> >> > Anybody have any suggestions?

>
>
>

 
Reply With Quote
 
 
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iis on windows xp embedded versus iis on windows 2003 Carl Windows XP Embedded 2 8th Dec 2007 12:24 AM
Frontpage 2003 publish web from remote iis 6.0 server to remote iis 6.0 server slow Lloyd Microsoft Frontpage 5 10th Feb 2005 03:37 PM
Server IIS 5.0 with Compression software Turbo IIS & HttpZip =?Utf-8?B?SUlTIDUuMCB3aXRoIGNvbXByZXNzaW9uOkh0dHBa Windows XP Internet Explorer 0 13th Dec 2004 03:33 PM
Windows 2000 vs 2003 (IIS 5 vs. IIS 6) Baskar Vadivelu \(www.bassoft.com\) Microsoft Windows 2000 6 25th Sep 2003 05:23 AM
RE: Windows 2000 vs 2003 (IIS 5 vs. IIS 6) Marc Reynolds [MSFT] Microsoft Windows 2000 0 22nd Sep 2003 12:43 AM


Features
 

Advertising
 

Newsgroups
 


All times are GMT +1. The time now is 11:19 AM.